[PATCH v4 4/6] gnu: python-jupytext: Update to 1.15.2.

  • Done
  • quality assurance status badge
Details
One participant
  • Giacomo Leidi
Owner
unassigned
Submitted by
Giacomo Leidi
Severity
normal
G
G
Giacomo Leidi wrote on 15 Jan 00:56 +0100
(address . guix-patches@gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20240114235609.24296-4-goodoldpaul@autistici.org
* gnu/packages/python-xyz.scm (python-jupytext): Update to 1.15.2;
[build-system]: switch to pyproject-build-system;
[arguments]<phases>: add setup-test-environment phase, use check phase
from build system and move test flags from here...
<test-flags>: ... to here.

Change-Id: Iaec4090823715230e26865d4639871fb7c565802
---
gnu/packages/python-xyz.scm | 26 +++++++++++---------------
1 file changed, 11 insertions(+), 15 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cef458e0fc..b4b95637c7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -336,7 +336,7 @@ (define-public python-janus
(define-public python-jupytext
(package
(name "python-jupytext")
- (version "1.14.4")
+ (version "1.15.2")
(source
(origin
(method git-fetch)
@@ -345,27 +345,23 @@ (define-public python-jupytext
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "19d443vx597zzxna09qpync9iic3mris80bwm3kd8xaxaq0zq9w4"))))
- (build-system python-build-system)
+ (base32 "0zi2b2g9b2dkzl69li5rwc17pdcxj8cxzlysd8s6jqbcc37jiwqs"))))
+ (build-system pyproject-build-system)
(arguments
(list
+ #:test-flags
+ #~'("-k" #$(string-join (list "not test_create_header_with_set_formats"
+ "test_pre_commit_hook"
+ "test_sync_with_pre_commit_hook")
+ " and not "))
#:phases
#~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
+ (add-before 'check 'setup-test-environment
+ (lambda _
;; some tests fail when HOME=/homeless-shelter.
(setenv "HOME" "/tmp")
;; OSError: [Errno 18] Invalid cross-device link
- (setenv "TMPDIR" "/tmp")
- (when tests?
- (let ((disabled-tests
- (list "test_create_header_with_set_formats"
- "test_pre_commit_hook"
- "test_sync_with_pre_commit_hook")))
- (invoke "pytest" "-vv" "-k"
- (string-append "not "
- (string-join disabled-tests
- " and not "))))))))))
+ (setenv "TMPDIR" "/tmp"))))))
(native-inputs
(list git-minimal
pre-commit
--
2.41.0
P
Close issue
(address . 68457-done@debbugs.gnu.org)
108c21ee-bca0-8556-4403-eaf6551afb82@autistici.org
This issue was opened by mistake, apologies for the noise.
Closed
?