icewm do not install MO files.

  • Done
  • quality assurance status badge
Details
3 participants
  • Andy Tai
  • Christopher Baines
  • Feng Shu
Owner
unassigned
Submitted by
Feng Shu
Severity
normal

Debbugs page

Feng Shu wrote 1 years ago
(name . guix-bug)(address . bug-guix@gnu.org)
87le8s393e.fsf@163.com
Hello:

At the moment: icewm do not install MO files to
'share/locale/<lang>/LC_MESSAGES', gmo files in tarball are removed, but
do not re-generated, I try to add gettext-minimul to inputs, but can not
re-generate gmo files successfully.

Any reason we should remove gmo files in tarball?

```
(add-after 'unpack 'remove-gmo-files
;; gmo files are generated from .po files
;; so remove them before build to make sure
;; they are re-generated if needed
(lambda _
(for-each delete-file
(find-files "po" "\\.gmo$"))))
```


--
Andy Tai wrote 1 years ago
(name . Feng Shu)(address . tumashu@163.com)
CAJsg1E9OFnVLQbT+5KMBRaXt717mycKLAyuttmkLQTbw6wP=qw@mail.gmail.com
I remember that was left over and kept from previous patches. If they
are not rebuilt there is a bug

I will remove these lines in the next update to the next version,
unless there is objection.

On Sat, Jan 13, 2024 at 7:08 PM Feng Shu <tumashu@163.com> wrote:
Toggle quote (24 lines)
>
>
> Hello:
>
> At the moment: icewm do not install MO files to
> 'share/locale/<lang>/LC_MESSAGES', gmo files in tarball are removed, but
> do not re-generated, I try to add gettext-minimul to inputs, but can not
> re-generate gmo files successfully.
>
> Any reason we should remove gmo files in tarball?
>
> ```
> (add-after 'unpack 'remove-gmo-files
> ;; gmo files are generated from .po files
> ;; so remove them before build to make sure
> ;; they are re-generated if needed
> (lambda _
> (for-each delete-file
> (find-files "po" "\\.gmo$"))))
> ```
>
>
> --
>
Andy Tai wrote 12 months ago
[PATCH v2] gnu: icewm: Update to 3.4.6
(name . Andy Tai)(address . atai@atai.org)
4bd9cafc35b9cbd3406361ba5c47bcabb5026c3c.1711374916.git.atai@atai.org
* gnu/packages/wm.scm (icewm): Update to 3.4.6
[arguments]: Remove the deletion of gmo files as
they are not regenerated correctly.

Change-Id: Ieff1fc5417cfe164fa7886774e8855fd95248c8f
---
gnu/packages/wm.scm | 11 ++---------
1 file changed, 2 insertions(+), 9 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 7d21d04094..65378040e5 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -797,7 +797,7 @@ (define-public i3lock-fancy
(define-public icewm
(package
(name "icewm")
- (version "3.4.5")
+ (version "3.4.6")
(source (origin
(method url-fetch)
(uri (string-append
@@ -805,7 +805,7 @@ (define-public icewm
version "/icewm-" version ".tar.lz"))
(sha256
(base32
- "1wd5k0whh2b43a72223cy19pwc29fhrhd2dnc61fha2y5ndgw6ld"))))
+ "1j4jd1fim12h8ry7jkx6y298kyn63pabih1m61rljbzvr3lyy1db"))))
(build-system gnu-build-system)
(native-inputs (list pkg-config))
(inputs (list fontconfig
@@ -830,13 +830,6 @@ (define-public icewm
(arguments
(list #:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'remove-gmo-files
- ;; gmo files are generated from .po files
- ;; so remove them before build to make sure
- ;; they are re-generated if needed
- (lambda _
- (for-each delete-file
- (find-files "po" "\\.gmo$"))))
(add-after 'unpack 'skip-failing-test
;; strtest.cc tests failing due to $HOME and /etc setup
;; difference under guix

base-commit: 1415ea78c15043ddc9d3d3dfe9219a4160493bf1
--
2.34.1
Christopher Baines wrote 12 months ago
Re: [bug#69793] [PATCH] gnu: icewm: Update to 3.4.6
(name . Andy Tai)(address . atai@atai.org)
87sf0bg78o.fsf@cbaines.net
Andy Tai <atai@atai.org> writes:

Toggle quote (7 lines)
> * gnu/packages/wm.scm (icewm): Update to 3.4.6
>
> Change-Id: Ieff1fc5417cfe164fa7886774e8855fd95248c8f
> ---
> gnu/packages/wm.scm | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)

Thanks both, I've pushed this to master as
8cc450e59a4c83fa39097964f62c2b2c84e0aee3.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmYEGFdfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XeJRRAAmBeRPDNaiBwdagrqilKqBf+d/fRMleLc
TcKjIwlffcwkqIEGj8+BbL9ebNP29jxhBoXLmp3TFdo4kZsQWCQPqZBc9wiyJep/
73INAmr8zpYYavLw00AiescxUUgsDHYgRWekjtvKgjLGYEg0QiSwUkMrIB2NPk6w
G6ZVQzhtC7V+LdpOj1F6eFyEl9DjrreTlAJuhn4DFI62mEVnLz9V8qoACF3U3NPT
bTyyOQC23LJmTFhBgyvDGFPv1AKhVDtlWpQOfC/H2XwjyYwKk0OFJq4ikA49d3MP
SO2UNKWpxXEbkkDhey0RAer3tj/u6RXpwh7x+/kSEUup5Iaw0D36hozp4Q5AdOQ3
3s0cvMG/wWQsD/33xmIXBEr6/0h0pXAjWtJ3UsAv/yVrJDf2xOQb4Qpj9tH4pv7t
SyKtUO/rs8HOk1DEWTC9I90Y5x851ubBIGP0P9mzaZ6fXtAUWXM3tqpA26+xQFgz
FyyoBVkbzBrHiFGnQ8yUfeEsKjDmeNsAh8/w70xchc62ZOoxeagiWYB77e+JPEzh
4k5dE0+Pd9lxJ5aIkJYsDPVTOHJn6w8bfHhBDyC9Zx3bZVNuSzQ2wTzqqY7id7CR
0nrGVmCOvPZix6jejjC/0AG686sYFu6wi8MlFWTnp5tmTBeejYcAmSgcTW+DcmcB
TBG2nvm0JHs=
=a8n7
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68439@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68439
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help