Feng Shu wrote 1 years ago
(name . guix-bug)(address . bug-guix@gnu.org)
Hello:
At the moment: icewm do not install MO files to
'share/locale/<lang>/LC_MESSAGES', gmo files in tarball are removed, but
do not re-generated, I try to add gettext-minimul to inputs, but can not
re-generate gmo files successfully.
Any reason we should remove gmo files in tarball?
```
(add-after 'unpack 'remove-gmo-files
;; gmo files are generated from .po files
;; so remove them before build to make sure
;; they are re-generated if needed
(lambda _
(for-each delete-file
(find-files "po" "\\.gmo$"))))
```
--