(address . guix-patches@gnu.org)
* gnu/packages/python-xyz.scm (python-activepapers)[source]: Add snippet fixing MutableMapping import.
---
gnu/packages/python-xyz.scm | 6 ++++++
1 file changed, 6 insertions(+)
Toggle diff (21 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 37d7dd0dd5..ddba925fd7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24143,6 +24143,12 @@ (define-public python-activepapers
(origin
(method url-fetch)
(uri (pypi-uri "ActivePapers.Py" version))
+ ;; This package has not seen active maintenance since 2017. This is a
+ ;; hack needed to make it build against a recent version of Python 3.
+ (modules '((guix build utils)))
+ (snippet '(substitute* "lib/activepapers/execution.py"
+ (("collections\\.MutableMapping")
+ "collections.abc.MutableMapping")))
(sha256
(base32
"12wkhjh90ffipjzv10swndp2xv9hd7xrxvg6v0n4n3i411pj4xb8"))))
base-commit: c0b303aaa3d6154acbe054120d11467eb98e6d33
--
2.42.0