[PATCH] gnu: python-activepapers: Fix build.

  • Done
  • quality assurance status badge
Details
3 participants
  • Konrad Hinsen
  • Sharlatan Hellseher
  • Troy Figiel
Owner
unassigned
Submitted by
Troy Figiel
Severity
normal
T
T
Troy Figiel wrote on 13 Jan 13:23 +0100
(address . guix-patches@gnu.org)
871qal4cl5.fsf@troyfigiel.com
* gnu/packages/python-xyz.scm (python-activepapers)[source]: Add snippet fixing MutableMapping import.
---
gnu/packages/python-xyz.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (21 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 37d7dd0dd5..ddba925fd7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24143,6 +24143,12 @@ (define-public python-activepapers
(origin
(method url-fetch)
(uri (pypi-uri "ActivePapers.Py" version))
+ ;; This package has not seen active maintenance since 2017. This is a
+ ;; hack needed to make it build against a recent version of Python 3.
+ (modules '((guix build utils)))
+ (snippet '(substitute* "lib/activepapers/execution.py"
+ (("collections\\.MutableMapping")
+ "collections.abc.MutableMapping")))
(sha256
(base32
"12wkhjh90ffipjzv10swndp2xv9hd7xrxvg6v0n4n3i411pj4xb8"))))

base-commit: c0b303aaa3d6154acbe054120d11467eb98e6d33
--
2.42.0
T
T
Troy Figiel wrote on 13 Jan 14:05 +0100
python-activepapers is unmaintained
(address . 68425@debbugs.gnu.org)
87y1ct2xjk.fsf@troyfigiel.com
python-activepapers has not been maintained since 2017. This patch is a
quick fix, but the latest version is actually built for Python >=3.3,
<=3.5. Trying to keep it buildable against newer versions of Python
would increase the maintenance burden over time.

Would it make more sense to remove/deprecate this package altogether?
S
S
Sharlatan Hellseher wrote on 15 Jan 00:25 +0100
(address . 68425@debbugs.gnu.org)
CAO+9K5rp1YE4xot-Dk2aFPU1ZSq9AgdWUKHQDmjK1QUwWrEGiw@mail.gmail.com
Hi,
Pinging Konrad to check the status of the project as
he was the last commiter to upstream package.
Thanks,
Oleg
--
VCS: https://github.incerto.xyz/;https://git.sr.ht/~hellseher/
GPG: 9847 81DE 689C 21C2 6418 0867 76D7 27BF F62C D2B5
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
K
K
Konrad Hinsen wrote on 15 Jan 09:57 +0100
(address . troy@troyfigiel.com)
m1fryzezxy.fsf@fastmail.net
Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (3 lines)
> Pinging Konrad to check the status of the project as
> he was the last commiter to upstream package.

Thanks for the ping!

It's OK to deprecate or remove this package, since it is useful only
with time-machine going back a few years.

I just added a note to the README:


and archived the project.

Cheers,
Konrad.
S
S
Sharlatan Hellseher wrote on 15 Jan 22:09 +0100
(address . 68425-done@debbugs.gnu.org)
CAO+9K5rgrRX_LB3fOmZSmZuu1bu=2UvSeoJ8_jqvAoP0GKanfw@mail.gmail.com
Hi,
I've remvoed the package.
Pushed as 1e3f1f9f92c1d3727d1ef69aa11455286abd0ebc.
Thanks,
Oleg
--
VCS: https://github.incerto.xyz/;https://git.sr.ht/~hellseher/
GPG: 9847 81DE 689C 21C2 6418 0867 76D7 27BF F62C D2B5
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68425@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68425
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch