[PATCH] Clarify definition of channel files in the cookbook.

  • Open
  • quality assurance status badge
Details
One participant
  • Daniel Khodabakhsh
Owner
unassigned
Submitted by
Daniel Khodabakhsh
Severity
normal
D
D
Daniel Khodabakhsh wrote on 13 Jan 00:53 +0100
(address . guix-patches@gnu.org)
CAADuFn+5OHG3A+_O_yPjg1exszURLdGDwzu6AvE-QrE7X=zHbg@mail.gmail.com
From 8bad2696e628f9415a4e720b60df095d65686ba9 Mon Sep 17 00:00:00 2001
From: Daniel Khodabakhsh <d.khodabakhsh@gmail.com>
Date: Fri, 12 Jan 2024 12:49:27 -0800
Subject: [PATCH] Clarify definition of channel files in the cookbook.

---
doc/guix-cookbook.texi | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)

Toggle diff (29 lines)
diff --git a/doc/guix-cookbook.texi b/doc/guix-cookbook.texi
index 2366c13..21fec10 100644
--- a/doc/guix-cookbook.texi
+++ b/doc/guix-cookbook.texi
@@ -805,7 +805,7 @@ mkdir ~/my-channel
@end example

Suppose you want to add the @samp{my-hello} package we saw previously;
-it first needs some adjustments:
+@file{my-hello.scm} first needs some adjustments:

@lisp
(define-module (my-hello)
@@ -835,6 +835,10 @@ command-line arguments, multiple languages, and so on.")
(license gpl3+)))
@end lisp

+Instead of starting with a @code{user-module} expression, a
@code{define-module}
+expression is used. This expression defines the name of the module
and must match
+the file name used (@samp{my-hello} from @file{my-hello.scm}).
+
Note that we have assigned the package value to an exported variable name with
@code{define-public}. This is effectively assigning the package to
the @code{my-hello}
variable so that it can be referenced, among other as dependency of other
--
2.30.2
D
?