[PATCH] tests: security: Fix fail2ban-extension-test.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • Tomas Volf
Owner
unassigned
Submitted by
Tomas Volf
Severity
normal

Debbugs page

Tomas Volf wrote 1 years ago
(address . guix-patches@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
a6548d682df00ab4d880cc719f6bead48d1106a9.1705016575.git.~@wolfsden.cz
The openssh-service-type requires 'networking to be setup. So add a
static-networking-service-type that provides it.

* gnu/tests/security.scm
(run-fail2ban-extension-test)[simple-operating-system]: Add
static-networking-service-type service.

Change-Id: I8d736cbf3fcaa54f86fbd60c52b3595b647731e2
---
gnu/tests/security.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (27 lines)
diff --git a/gnu/tests/security.scm b/gnu/tests/security.scm
index ca6c857899..93cbe4a977 100644
--- a/gnu/tests/security.scm
+++ b/gnu/tests/security.scm
@@ -20,6 +20,7 @@ (define-module (gnu tests security)
#:use-module (guix gexp)
#:use-module (gnu packages admin)
#:use-module (gnu services)
+ #:use-module (gnu services base)
#:use-module (gnu services security)
#:use-module (gnu services ssh)
#:use-module (gnu system)
@@ -176,7 +177,9 @@ (define run-fail2ban-extension-test
(simple-operating-system
(service (fail2ban-jail-service openssh-service-type (fail2ban-jail-configuration
(name "sshd") (enabled? #t)))
- (openssh-configuration)))
+ (openssh-configuration))
+ (service static-networking-service-type
+ (list %qemu-static-networking)))
(test-equal "fail2ban sshd jail running status output"
'("Status for the jail: sshd"

base-commit: 5c0f77f4241c9beac0c82deae946bfdc70b49ff0
--
2.41.0
Mathieu Othacehe wrote 1 years ago
(name . Tomas Volf)(address . ~@wolfsden.cz)(address . 68393-done@debbugs.gnu.org)
87jzoer0ne.fsf@gnu.org
Toggle quote (4 lines)
> * gnu/tests/security.scm
> (run-fail2ban-extension-test)[simple-operating-system]: Add
> static-networking-service-type service.

Applied, thanks,

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68393@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68393
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help