(address . bug-guix@gnu.org)
Enabling both TTY auto-login and elogind-service-type at the same time
results in an error immediately after automatic login to the tty with
the message "Error in service module", and the TTY then is
frozen. Auto-login works fine if I disable elogind, but elogind is
unfortunately a crucial part of the Guix system since a lot of things
does not work without it.
Below is attached a minimal example, simply commenting out the elogind
service in this example makes it works as expected. Running it as is
will result in the error I mentioned.
(use-modules
(gnu)
(gnu services)
(gnu services base)
(gnu services desktop)
(gnu bootloader)
(gnu bootloader grub)
(gnu system)
(gnu system file-systems)
(gnu system accounts)
(gnu system locale))
(operating-system
(host-name "minimal")
(users
(cons*
(user-account
(name "lars")
(group "users"))
%base-user-accounts))
(services
(cons*
(service elogind-service-type)
(modify-services %base-services
(mingetty-service-type config =>
(mingetty-configuration
(inherit config)
(auto-login "lars"))))))
(bootloader
(bootloader-configuration
(bootloader grub-efi-bootloader)
(targets '("/boot/efi"))))
(file-systems
(cons*
%base-file-systems)))