TTY Auto-login is not compatible with elogind

  • Open
  • quality assurance status badge
Details
2 participants
  • Christian Miller
  • Lars Rustand
Owner
unassigned
Submitted by
Lars Rustand
Severity
normal
L
L
Lars Rustand wrote on 11 Jan 13:46 +0100
(address . bug-guix@gnu.org)
87le8wc9ih.fsf@gmail.com
Enabling both TTY auto-login and elogind-service-type at the same time
results in an error immediately after automatic login to the tty with
the message "Error in service module", and the TTY then is
frozen. Auto-login works fine if I disable elogind, but elogind is
unfortunately a crucial part of the Guix system since a lot of things
does not work without it.

Below is attached a minimal example, simply commenting out the elogind
service in this example makes it works as expected. Running it as is
will result in the error I mentioned.


(use-modules
(gnu)
(gnu services)
(gnu services base)
(gnu services desktop)
(gnu bootloader)
(gnu bootloader grub)
(gnu system)
(gnu system file-systems)
(gnu system accounts)
(gnu system locale))

(operating-system
(host-name "minimal")

(users
(cons*
(user-account
(name "lars")
(group "users"))
%base-user-accounts))

(services
(cons*
(service elogind-service-type)
(modify-services %base-services
(mingetty-service-type config =>
(mingetty-configuration
(inherit config)
(auto-login "lars"))))))

(bootloader
(bootloader-configuration
(bootloader grub-efi-bootloader)
(targets '("/boot/efi"))))

(file-systems
(cons*
%base-file-systems)))
C
C
Christian Miller wrote on 14 Jan 17:00 +0100
(address . 68384@debbugs.gnu.org)
874jffzyzm.fsf@dadoes.de
Hello,

I have the same issue.

Using the following works for me, though you need to press a button on
the keyboard.

(modify-services %desktop-services
(delete gdm-service-type)
(mingetty-service-type config =>
(mingetty-configuration
(inherit config)
(auto-login "cm")
;; TODO: Work around to fix "Error in service module"
(login-pause? #t))))

I also created a thread in the guix-devel[0] mailing list, maybe I should
have not.


--
Christian Miller
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 68384@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68384
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch