nafkhamdc wrote 1 years ago
(address . guix-patches@gnu.org)(name . nafkhamdc)(address . navid.afkhami@mdc-berlin.de)
* gnu/packages/bioinformatics.scm (r-azimuth): New variable.
Change-Id: I2b0d087378028663ee8d76ced8950f7a9721cb03
---
gnu/packages/bioinformatics.scm | 60 +++++++++++++++++++++++++++++++++
1 file changed, 60 insertions(+)
Toggle diff (75 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f574fea0e9..9b45c54ef9 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11171,6 +11171,66 @@ (define-public r-archr
"This package is designed to streamline scATAC analyses in R.")
(license license:gpl2+))))
+(define-public r-azimuth
+ (let ((commit "243ee5db80fcbffa3452c944254a325a3da2ef9e")
+ (revision "1"))
+ (package
+ (name "r-azimuth")
+ (version (git-version "0.5.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/satijalab/azimuth")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0vs4813kf2cv2j1z800ihwk62bw4dgmwgkd47rln58581chv39zm"))))
+ (properties `((upstream-name . "Azimuth")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-bsgenome-hsapiens-ucsc-hg38
+ r-dt
+ r-ensdb-hsapiens-v86
+ r-future
+ r-ggplot2
+ r-glmgampoi
+ r-googlesheets4
+ r-hdf5r
+ r-htmltools
+ r-httr
+ r-jaspar2020
+ r-jsonlite
+ r-matrix
+ r-patchwork
+ r-plotly
+ r-presto
+ r-rcpp
+ r-rlang
+ r-scales
+ r-seurat
+ r-seuratdata
+ r-seuratdisk
+ r-seuratobject
+ r-shiny
+ r-shinybs
+ r-shinydashboard
+ r-shinyjs
+ r-signac
+ r-stringr
+ r-tfbstools
+ r-withr))
+ (home-page "https://github.com/satijalab/azimuth")
+ (synopsis
+ "Shiny app showcasing a single-cell data query-reference mapping algorithm")
+ (description "Azimuth utilizes an annotated reference dataset.
+It automates the processing, analysis, and interpretation.
+This applies specifically to new single-cell RNA-seq or
+ATAC-seq experiments. Azimuth leverages a reference-based
+mapping pipeline that inputs acounts matrix and performs
+normalization, visualization, cell annotation, and
+differential expression.")
+ (license license:gpl3))))
+
(define-public r-icellnet
;; v1.0 tagged in 2020, last commit contains many fixes.
;; DESCRIPTION says Version: 0.0.0.9000.
base-commit: 6341dddcb9e7c8d555ea7294d61dcf64d775e032
--
2.34.1