[PATCH] gnu: Add r-dsb.

  • Done
  • quality assurance status badge
Details
2 participants
  • nafkhamdc
  • Ricardo Wurmus
Owner
unassigned
Submitted by
nafkhamdc
Severity
normal

Debbugs page

nafkhamdc wrote 1 years ago
(address . guix-patches@gnu.org)(name . nafkhamdc)(address . navid.afkhami@mdc-berlin.de)
79a84f556ed434e7a51f4fb87872872ef719719b.1704891744.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-dsb): New variable.

Change-Id: I34b91da1ae177bd37cfa548c5f6fede453f29bcd
---
gnu/packages/bioconductor.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index a7af5c42ce..7c4272f8be 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -5599,6 +5599,34 @@ (define-public r-dropletutils
pseudo-cells, and downsampling of the count matrix.")
(license license:gpl3)))
+;; This is a CRAN package, but it depends on r-limma from Bioconductor.
+(define-public r-dsb
+ (package
+ (name "r-dsb")
+ (version "1.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "dsb" version))
+ (sha256
+ (base32 "1xzhd4q04c1vql49r6m4zskpx7f5hkl5hmdgr3gsbxb73xfs51v2"))))
+ (properties `((upstream-name . "dsb")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-limma r-magrittr r-mclust))
+ (native-inputs (list r-knitr r-rmarkdown))
+ (home-page "https://github.com/niaid/dsb")
+ (synopsis
+ "Normalize & denoise droplet single cell protein data (CITE-Seq)")
+ (description
+ "R-dsb improves protein expression analysis in droplet-based single-cell studies.
+The package specifically addresses noise in raw protein UMI counts from methods like
+CITE-seq. It identifies and removes two main sources of noise—protein-specific noise
+from unbound antibodies and droplet/cell-specific noise. The package is applicable to
+various methods, including CITE-seq, REAP-seq, ASAP-seq, TEA-seq, and Mission Bioplatform
+data. Check the vignette for tutorials on integrating dsb with Seurat and Bioconductor,
+and using dsb in Python.")
+ (license license:cc0)))
+
(define-public r-dss
(package
(name "r-dss")

base-commit: 537768018ee03a6a9a5562022a16b47ac287d131
--
2.34.1
Ricardo Wurmus wrote 1 years ago
(address . 68368-done@debbugs.gnu.org)
87il415b7y.fsf@elephly.net
Applied, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68368@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68368
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help