Can't pull my channel because of getaddrinfo -8 error

  • Open
  • quality assurance status badge
Details
4 participants
  • Christina O'Donnell
  • Josselin Poiret
  • ShinyZero0
  • Simon Tournier
Owner
unassigned
Submitted by
ShinyZero0
Severity
normal

Debbugs page

ShinyZero0 wrote 1 years ago
(address . bug-guix@gnu.org)
CYAMI74CD75T.3JZWP3FK5PE6Q@fedora
Here is my channel i'm trying to pull and keep getting that "SERVICE not
supported for `ai_socktype'" error

```
(channel
(name 'zero)
(commit
"1eacb7d9e2eb96c9d45b96af006b069e443c9ebc"))
```

the full log is

```
(repl-version 0 1 1)
(exception getaddrinfo-error (value -8))
```

It seems to work well on just the previous commit and i also tried some
rebasing/amending to change the "breaking" commit. Sometimes it worked,
but when i added other ones skipping the "breaking" one it throwed the
same error. Of course the channel as well as the package the commit adds
work well in my GUIX_PACKAGE_PATH
There is my `guix describe`:
```
(list (channel
(name 'shepherd)
(branch "main")
(commit
"10d8ad5050799ee91302a5ef7c92a9ba6afd8fa7"))
(channel
(name 'guix)
(branch "master")
(commit
"08d94fe20eca47b69678b3eced8749dd02c700a4")
(introduction
(make-channel-introduction
"9edb3f66fd807b096b48283debdcddccfea34bad"
(openpgp-fingerprint
"BBB0 2DDF 2CEA F6A8 0D1D E643 A2A0 6DF2 A33A 54FA"))))
(channel
(name 'zero)
(branch "master")
(commit
"e0d813eb175adb422a6993b173c6a3767957035d"))
(channel
(name 'rde)
(branch "master")
(commit
"d0cc15bbc47b8b218e712d1b7fc92fc63527e578")
(introduction
(make-channel-introduction
"257cebd587b66e4d865b3537a9a88cccd7107c95"
(openpgp-fingerprint
"2841 9AC6 5038 7440 C7E9 2FFA 2208 D209 58C1 DEB0")))))

;; warning: GUIX_PACKAGE_PATH="/home/zero/dev/guix-packages"
```
Josselin Poiret wrote 1 years ago
87r0ilh2pu.fsf@jpoiret.xyz
Hi,

"ShinyZero0" <shinyzero0@tilde.club> writes:

Toggle quote (18 lines)
> Here is my channel i'm trying to pull and keep getting that "SERVICE not
> supported for `ai_socktype'" error
>
> ```
> (channel
> (name 'zero)
> (url "https://codeberg.org/shinyzero0/guix-packages.git")
> (commit
> "1eacb7d9e2eb96c9d45b96af006b069e443c9ebc"))
> ```
>
> the full log is
>
> ```
> (repl-version 0 1 1)
> (exception getaddrinfo-error (value -8))
> ```

Isn't that rather related to Codeberg being DDoS'd yesterday? Can you
retry now?

Best,
--
Josselin Poiret
-----BEGIN PGP SIGNATURE-----

iQHEBAEBCAAuFiEEOSSM2EHGPMM23K8vUF5AuRYXGooFAmWieP4QHGRldkBqcG9p
cmV0Lnh5egAKCRBQXkC5FhcaigUlC/9qBVc4TQxA8nLDrx8oZTppXqVQ599Bk2+B
EAqPZqh1kwAL7vRHJoNoXnsYSCEm/G3XWe7RJSy0DUJ/2HI8XsL01PkAY0j5Fsgl
qxLYCL0SzKvXLsfpxb4swZO753uUYmC4eqwjSk3OO7w6/NS1JckUBFoR2ILXjkWi
IPs0Dz86R9mrC5MxrP1f8UAC2pbkzYN11Wwh7ujF7xzp78K0VFc2DfkbWo0wVuKD
g9eVKHFp5HU1+BJwyVpoKxt0aaDbZo0btibTRZCKtkqDN8fYubtQBIse1QHITLDf
TguqTe1+VjlhM1ZCY9DekymRGlv8T6trDsEHgLqIRcTbDW+ABb0Ni/7fQCt7qjeR
kTrTNspU79bPJQHbg3kfYNZ43mdzmZtK5lOC4FfWXBLa49ESTzAynxksKmWecfJi
f9vnxX43CPOXoSaZHAXF4rkKzN7g7qkm0KrKeonTk14qkdmDuNTUQ/qgVv3DU3ld
lzO2bQXreVl0FIdhl2b4JXOJ1tlk+Ak=
=xB5b
-----END PGP SIGNATURE-----

ShinyZero0 wrote 1 years ago
CYDZ4CQYPNIY.2B8ME5C3VVZ4J@fedora
Hi, Josselin. Thanks for replying!

Well, actually i encountered the problem at least 20 days ago so it
definitely isn't related to recent DDOS attacks. Even if there were some
before, i could and can build the commit
e0d813eb175adb422a6993b173c6a3767957035d as well as my shepherd channel
which is hosted on codeberg too

Best wishes, Paul
ShinyZero0 wrote 1 years ago
CYEGUEMNZSXG.3PM1U77VPNSAS@fedora
Hello again.

I retried the build from codeberg and it still crashes
on any commit above e0d813eb175adb422a6993b173c6a3767957035d.
Also i pushed the repo to github
the same error.

Best wishes,
Paul
ShinyZero0 wrote 1 years ago
Re: bug#68359: Acknowledgement (Can't pull my channel because of getaddrinfo -8 error)
(address . 68359@debbugs.gnu.org)
CYHHOP06YRAM.2GQYB2DMX8FHX@fedora
Well, the issue seems to be with the commit that adds the transformed
polybar package like this:

```
(define-module (zero packages polybar))
(use-modules (guix packages)
(guix transformations)
(gnu packages wm))
(define-public
polybar-3.7.1
((options->transformation
'((with-version . "polybar=3.7.1"))) polybar))
```
Simon Tournier wrote 1 years ago
87h6hg7fxc.fsf@gmail.com
Hi,

On jeu., 18 janv. 2024 at 05:50, "ShinyZero0" via Bug reports for GNU Guix <bug-guix@gnu.org> wrote:
Toggle quote (14 lines)
> Well, the issue seems to be with the commit that adds the transformed
> polybar package like this:
>
> ```
> (define-module (zero packages polybar))
> (use-modules (guix packages)
> (guix transformations)
> (gnu packages wm))
> (define-public
> polybar-3.7.1
> ((options->transformation
> '((with-version . "polybar=3.7.1"))) polybar))
> ```

Well, the bug seems coming from your channel. Could you update it and
make it compliant with Guix proper.

Somehow, I am going to close this issue because it is not a bug. :-)

Is it fine? Let us know if more details are required.

Cheers,
simon
Christina O'Donnell wrote 11 months ago
Re: bug#68359: Can't pull my channel because of, getaddrinfo -8 error
deecb047-0dbf-a1f7-ac53-f6fb7443bddc@mutix.org
Hi Simon, Paul,

I've also run into this bug and I believe it is due to the error being
cached. This is clearly undesirable so this issue should stay open until
that is resolved.

My reasoning for thinking it is a cache issues is:
 - An issue with package transformations should never cause an
getaddrinfo error as Guix generally only goes up to servers for channels
and build packages.
 - I ran into this after my gitlab instance had some outage, and
persisted since my server came back up.
 - Pulling from a duplicate ref with the same hash succeeds, indicating
that the bug occurs before the checkout is fetched.

I'm happy to have a stab at working on this. Currently working on
reproducing this, it's not as simple as making the channel url point at
a closed port (eg. https://localhost:1212). I even tried binding a SCTP
server to the port, but I just get connection refused. Anyone have any
ideas about this?

Should the title be changed to something like "Guix can cache
getaddrinfo failures on `guix pull`"? (.. on the assumption that I'm
proven right ;-)

I'll assign this to myself, if there are no objections.

Kind regards,

Christina
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 68359@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68359
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help