[PATCH 0/2] Minor improvements to the documentation.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Tomas Volf
Owner
unassigned
Submitted by
Tomas Volf
Severity
normal
T
T
Tomas Volf wrote on 9 Jan 23:29 +0100
(address . guix-patches@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
cover.1704839277.git.~@wolfsden.cz
cvs-fetch and cvs-reference were not documented at all, while hg-reference was
wrong. This mini-series fixes both.

Tomas Volf (2):
doc: Document cvs-fetch and cvs-reference.
doc: Fix bug in hg-reference documentation.

doc/guix.texi | 41 +++++++++++++++++++++++++++++++++++++++--
1 file changed, 39 insertions(+), 2 deletions(-)


base-commit: b212e6934643e085f168a5364cb593f61aa616ba
--
2.41.0
T
T
Tomas Volf wrote on 9 Jan 23:45 +0100
[PATCH 2/2] doc: Fix bug in hg-reference documentation.
(address . 68353@debbugs.gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
c31b440808a54a2a3d040a2d372f3e434c350480.1704839277.git.~@wolfsden.cz
The field is called changeset, not revision. And the string does not have to
be a number.

* doc/guix.texi (origin Reference): Fix documentation for hg-reference.

Change-Id: Ic622dfc7b44caf42d070cdab8e42808dd96e6d63
---
doc/guix.texi | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (17 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index fde8aa12b9..466e01eab5 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -8461,8 +8461,8 @@ origin Reference
@item @code{url}
The URL of the Mercurial repository to clone.
-@item @code{revision}
-This string denotes revision to fetch specified as a number.
+@item @code{changeset}
+This string denotes changeset to fetch.
@end table
@end deftp
--
2.41.0
T
T
Tomas Volf wrote on 9 Jan 23:45 +0100
[PATCH 1/2] doc: Document cvs-fetch and cvs-reference.
(address . 68353@debbugs.gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
341b6c7f9aad369812fb47b399ab4777641ca220.1704839277.git.~@wolfsden.cz
For some reason, they were missing from the documentation. This commit adds
them including an example of usage.

* doc/guix.texi (origin Reference): Add cvs-fetch and cvs-reference.

Change-Id: I6622a9f70e6d71ed31fbb3d2689df4a6946f8868
---
doc/guix.texi | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (50 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index a648a106b3..fde8aa12b9 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -8525,6 +8525,43 @@ origin Reference
@end table
@end deftp
+For CVS repositories, the module @code{(guix cvs-download)} defines the
+@code{cvs-fetch} origin method and @code{cvs-reference} data type for
+support of the Concurrent Versions System (CVS).
+
+@deffn {Procedure} cvs-fetch ref hash-algo hash [name]
+Return a fixed-output derivation that fetches @var{ref}, a
+@code{<cvs-reference>} object. The output is expected to have recursive
+hash @var{hash} of type @var{hash-algo} (a symbol). Use @var{name} as
+the file name, or a generic name if @code{#f}.
+@end deffn
+
+@deftp {Data Type} cvs-reference
+This data type represents a CVS reference for @code{cvs-fetch} to
+retrieve.
+
+@table @asis
+@item @code{root-directory}
+The CVS root directory.
+
+@item @code{module}
+Module to fetch.
+
+@item @code{revision}
+Revision to fetch.
+@end table
+
+The example below denotes a version of gnu-standards to fetch:
+
+@lisp
+(cvs-reference
+ (root-directory ":pserver:anonymous@@cvs.savannah.gnu.org:/sources/gnustandards")
+ (module "gnustandards")
+ (revision "2020-11-25"))
+@end lisp
+
+@end deftp
+
@node Defining Package Variants
@section Defining Package Variants
--
2.41.0
T
T
Tomas Volf wrote on 12 May 11:57 +0200
[PATCH v2 1/2] doc: Document cvs-fetch and cvs-reference.
(address . 68353@debbugs.gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
82ec854214fad37f82bc18d4424ac61f82da3f1a.1715507861.git.~@wolfsden.cz
For some reason, they were missing from the documentation. This commit adds
them including an example of usage.

* doc/guix.texi (origin Reference): Add cvs-fetch and cvs-reference.

Change-Id: I6622a9f70e6d71ed31fbb3d2689df4a6946f8868
---
doc/guix.texi | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (50 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index f20208f94f..bc73942eaf 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -8302,6 +8302,43 @@ origin Reference
@end table
@end deftp
+For CVS repositories, the module @code{(guix cvs-download)} defines the
+@code{cvs-fetch} origin method and @code{cvs-reference} data type for
+support of the Concurrent Versions System (CVS).
+
+@deffn {Procedure} cvs-fetch ref hash-algo hash [name]
+Return a fixed-output derivation that fetches @var{ref}, a
+@code{<cvs-reference>} object. The output is expected to have recursive
+hash @var{hash} of type @var{hash-algo} (a symbol). Use @var{name} as
+the file name, or a generic name if @code{#f}.
+@end deffn
+
+@deftp {Data Type} cvs-reference
+This data type represents a CVS reference for @code{cvs-fetch} to
+retrieve.
+
+@table @asis
+@item @code{root-directory}
+The CVS root directory.
+
+@item @code{module}
+Module to fetch.
+
+@item @code{revision}
+Revision to fetch.
+@end table
+
+The example below denotes a version of gnu-standards to fetch:
+
+@lisp
+(cvs-reference
+ (root-directory ":pserver:anonymous@@cvs.savannah.gnu.org:/sources/gnustandards")
+ (module "gnustandards")
+ (revision "2020-11-25"))
+@end lisp
+
+@end deftp
+
@node Defining Package Variants
@section Defining Package Variants
--
2.41.0
T
T
Tomas Volf wrote on 12 May 11:57 +0200
[PATCH v2 2/2] doc: Fix bug in hg-reference documentation.
(address . 68353@debbugs.gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
fe1c1fed1d27728d3e82c167c3b3aefcc4b21350.1715507861.git.~@wolfsden.cz
The field is called changeset, not revision. And the string does not have to
be a number.

* doc/guix.texi (origin Reference): Fix documentation for hg-reference.

Change-Id: Ic622dfc7b44caf42d070cdab8e42808dd96e6d63
---
doc/guix.texi | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (17 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index bc73942eaf..230ba511c5 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -8238,8 +8238,8 @@ origin Reference
@item @code{url}
The URL of the Mercurial repository to clone.
-@item @code{revision}
-This string denotes revision to fetch specified as a number.
+@item @code{changeset}
+This string denotes changeset to fetch.
@end table
@end deftp
--
2.41.0
L
L
Ludovic Courtès wrote on 13 May 14:45 +0200
Re: [bug#68353] [PATCH v2 1/2] doc: Document cvs-fetch and cvs-reference.
(name . Tomas Volf)(address . ~@wolfsden.cz)
87o799anj1.fsf@gnu.org
Tomas Volf <~@wolfsden.cz> skribis:

Toggle quote (7 lines)
> For some reason, they were missing from the documentation. This commit adds
> them including an example of usage.
>
> * doc/guix.texi (origin Reference): Add cvs-fetch and cvs-reference.
>
> Change-Id: I6622a9f70e6d71ed31fbb3d2689df4a6946f8868

[...]

Toggle quote (7 lines)
> The field is called changeset, not revision. And the string does not have to
> be a number.
>
> * doc/guix.texi (origin Reference): Fix documentation for hg-reference.
>
> Change-Id: Ic622dfc7b44caf42d070cdab8e42808dd96e6d63

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68353@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68353
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch