* gnu/packages/fonts.scm (font-abattis-cantarell): Update to 0.303.1.
[source]: Use the provided mirror tarball.
Change-Id: I1635000e0bac61e034ff6e290685681222d23c6b
---
gnu/packages/fonts.scm | 63 +++++++++++++++++++++---------------------
1 file changed, 31 insertions(+), 32 deletions(-)
Toggle diff (79 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 7516e1642b..16920208f0 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -289,41 +289,40 @@ (define-public font-canada1500
(license license:cc0)))
(define-public font-abattis-cantarell
- ;; Use the latest commit, as the last released version, 0.303, has problems
- ;; with the newer statmake. The dependency has been removed in the latest
- ;; code base.
- (let ((commit "e049149faf0c15b0711e8d790e2333be923f0486")
- (revision "0"))
- (package
- (name "font-abattis-cantarell")
- (version (git-version "0.303" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.gnome.org/GNOME/cantarell-fonts")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "032csq99bkmmgh9mmmbrgg4fzxgkcsvxv4wy595qms72mmlgmcc7"))))
- (build-system meson-build-system)
- (arguments
- (list #:configure-flags #~(list "-Dbuildstatics=true")))
- (native-inputs
- (list gettext-minimal
- psautohint
- python
- python-cffsubr
- python-fontmath
- python-ufo2ft))
- (home-page "https://wiki.gnome.org/Projects/CantarellFonts")
- (synopsis "Cantarell sans-serif typeface")
- (description "The Cantarell font family is a contemporary Humanist
+ (package
+ (name "font-abattis-cantarell")
+ (version "0.303.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/cantarell-fonts/"
+ (version-major+minor version)
+ "/"
+ "cantarell-fonts-"
+ version
+ ".tar.xz"))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0484acq1hxi4jjc3b4dlqnam68i9377m7mzxh7imfgn6b433lipr"))))
+ (build-system meson-build-system)
+ (arguments
+ (list
+ #:configure-flags #~(list "-Dbuildstatics=true")))
+ (native-inputs
+ (list gettext-minimal
+ psautohint
+ python
+ python-cffsubr
+ python-fontmath
+ python-ufo2ft))
+ (home-page "https://wiki.gnome.org/Projects/CantarellFonts")
+ (synopsis "Cantarell sans-serif typeface")
+ (description
+ "The Cantarell font family is a contemporary Humanist
sans-serif designed for on-screen reading. It is used by GNOME@tie{}3.
This package contains both the non-variable as well as the variable versions
of the font.")
- (license license:silofl1.1))))
+ (license license:silofl1.1)))
(define-public font-lato
(package
--
2.41.0