(address . bug-guix@gnu.org)
Hello Guix,
Guix told me to report a bug here.
I fresh installed Guix in a qemu vm using the official guix 1.4 iso
image. After booting to desktop, I ran `guix pull
--substitute-url=https://guix.jing.rocks` (guix.jing.rocks is a server
running `guix publish` in my local LAN), then ran into a loop. I'm
attaching console message, config.scm, build log here. Maybe it's
already fixed, but let me know if any other information is needed.
--
Jing Luo
About me: https://jing.rocks/about/
PGP Fingerprint: 4E09 8D19 00AA 3F72 1899 2614 09B3 316E 13A1 1EFC
;; This is an operating system configuration generated
;; by the graphical installer.
;;
;; Once installation is complete, you can learn and modify
;; this file to tweak the system configuration, and pass it
;; to the 'guix system reconfigure' command to effect your
;; changes.
;; Indicate which modules to import to access the variables
;; used in this configuration.
(use-modules (gnu))
(use-service-modules cups desktop networking ssh xorg)
(operating-system
(locale "en_US.utf8")
(timezone "Asia/Tokyo")
(keyboard-layout (keyboard-layout "us"))
(host-name "guix1")
;; The list of user accounts ('root' is implicit).
(users (cons* (user-account
(name "jing")
(comment "Jing")
(group "users")
(home-directory "/home/jing")
(supplementary-groups '("wheel" "netdev" "audio" "video")))
%base-user-accounts))
;; Packages installed system-wide. Users can also install packages
;; under their own account: use 'guix search KEYWORD' to search
;; for packages and 'guix install PACKAGE' to install a package.
(packages (append (list (specification->package "nss-certs"))
%base-packages))
;; Below is the list of system services. To search for available
;; services, run 'guix system search KEYWORD' in a terminal.
(services
(append (list (service xfce-desktop-service-type)
(service mate-desktop-service-type)
;; To configure OpenSSH, pass an 'openssh-configuration'
;; record as a second argument to 'service' below.
(service openssh-service-type)
(set-xorg-configuration
(xorg-configuration (keyboard-layout keyboard-layout))))
;; This is the default list of services we
;; are appending to.
%desktop-services))
(bootloader (bootloader-configuration
(bootloader grub-bootloader)
(targets (list "/dev/sda"))
(keyboard-layout keyboard-layout)))
(initrd-modules (append '("virtio_scsi") %base-initrd-modules))
(swap-devices (list (swap-space
(target (uuid
"3a4bebe3-58ab-48a2-9258-c87cd8d0922f")))))
;; The list of file systems that get "mounted". The unique
;; file system identifiers there ("UUIDs") can be obtained
;; by running 'blkid' in a terminal.
(file-systems (cons* (file-system
(mount-point "/")
(device (uuid
"59038b8e-94b2-4699-8928-5f0e36284c4f"
'ext4))
(type "ext4")) %base-file-systems)))