Tomas Volf wrote 1 years ago
(address . guix-patches@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
Users might want to use different identity for their global emacs config and
for the Guix repository. In case they differ, there seems to be little reason
not to prefer the git's setting. Assuming magit is available, use the
user.name and user.email, with fallback to user-full-name and
user-mail-address respectively.
* etc/copyright.el (guix-copyright): Use git's user.name and user.email if
available.
Change-Id: Iad1c07681b38beeebf0feeda18702258ffb5d918
---
etc/copyright.el | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
Toggle diff (21 lines)
diff --git a/etc/copyright.el b/etc/copyright.el
index f5ed723cea..fdd67535d9 100644
--- a/etc/copyright.el
+++ b/etc/copyright.el
@@ -28,7 +28,11 @@
"FULL_NAME <MAIL_ADDRESS>: "
comment-start
";; Copyright © " `(format-time-string "%Y") " "
- (or (format "%s <%s>" user-full-name user-mail-address) str)
+ '(setq v1 (or (and (featurep 'magit) (magit-get "user.name"))
+ (user-full-name)))
+ '(setq v2 (or (and (featurep 'magit) (magit-get "user.email"))
+ (user-mail-address)))
+ (or (format "%s <%s>" v1 v2) str)
comment-end)
;;; copyright.el ends here
base-commit: b212e6934643e085f168a5364cb593f61aa616ba
--
2.41.0