[PATCH] gnu: Add rust-hexf-parse-0.2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Troy Figiel
Owner
unassigned
Submitted by
Troy Figiel
Severity
normal

Debbugs page

Troy Figiel wrote 1 years ago
(address . guix-patches@gnu.org)
87ederiyoj.fsf@troyfigiel.com
* gnu/packages/crates-io.scm (rust-hexf-parse-0.2): New variable.
---
gnu/packages/crates-io.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1bfd8fb143..0806a18b88 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -35213,6 +35213,25 @@ (define-public rust-hex-literal-impl-0.1
`(#:cargo-inputs
(("rust-proc-macro-hack" ,rust-proc-macro-hack-0.4))))))
+(define-public rust-hexf-parse-0.2
+ (package
+ (name "rust-hexf-parse")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "hexf-parse" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1pr3a3sk66ddxdyxdxac7q6qaqjcn28v0njy22ghdpfn78l8d9nz"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/lifthrasiir/hexf")
+ (synopsis "Hexadecimal float support for Rust")
+ (description "This library provides parsing functionality for hexadecimal
+float literals. Two functions @code{parse_hexf32} and @code{parse_hexf64} are
+provided for each type.")
+ (license license:cc0)))
+
(define-public rust-hkdf-0.12
(package
(name "rust-hkdf")

base-commit: 5f8a993aa85554ca09bd27139230d7664107e1b6
--
2.42.0
Efraim Flashner wrote 1 years ago
(name . Troy Figiel)(address . troy@troyfigiel.com)(address . 68326-done@debbugs.gnu.org)
ZapDB5xffj8A1qx1@3900XT
Thanks. Patch pushed to the rust-team branch

--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmWqQwcACgkQQarn3Mo9
g1GRlxAAo7b9IV8LQxVewvH6DjqIdWopxQGrAWEFLfysfoBKb3oKZ3OZNLiRVHC6
goBc6RpeNg4/7Zxj+esgkSVIIvl+55cGLpdPdIbwir+p7t4qC13vaOz88k4r1B1Q
KUnYMUhml81SiLLlju9FnTbLiRbeZQ8M2umIy5uUe7xkxOJEuWnzJgtMPDrghmEn
Ee12J4qqskiwnmIJNaDBIMg842HFsXO+pGPOrdegtkJYLi2WRsloLLhoQ2T8bfN+
XxaczOmegTdmfrqdpjiWBTKK7QNkj2WKZ2YkevLMOpBaTOv1Sj1N0tqjO0hsXuwF
e3QBOdmYMXXyWUom+bKgCF+R/NI6OCI413AS+3488rFEMDLh1KFnjC0m1pyUig1f
TmxAXSQWF2lGouiyzVKj1P3Cl2n5MvL7hpg1SAFnma1MHrrmY6MiOa4wkCKWpmJV
RmYlY3pysVaE2LWDeqThnPy1F0JZvVNiUeNfiHKdRdU5IvDzoW72Tctc/r9WFNfw
OMSCgAwV3guuVdH6k0QO+x5LG6HlVij7w+sJfKfxL8znxdciNl1qG4acNUJTPM6/
YWdwa7nW21HhBbY6CagALP31juTOJhCj7XnDCUIdhdp2JjKIVUF4s5sPiFSHU0qf
41WYhErNjf2n/5UBSHFgwAxGFAfOHSGflz9K/0Yfi3YJP+dWR40=
=KpYq
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68326@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68326
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help