[PATCH] gnu: gnupg: Fix cross-compilation.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Mathieu Othacehe
Severity
normal
M
M
Mathieu Othacehe wrote on 8 Jan 15:56 +0100
(address . guix-patches@gnu.org)
e4c359500a04bef3333bc413aaf73ef9497cb34c.1704725707.git.othacehe@gnu.org
* gnu/packages/gnupg.scm (gnupg)[arguments]: Pass libraries prefixes when
cross-crompiling.

Change-Id: I461ba02ddf5bb23277bd6685c2106e4ad37e2184
Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
---
gnu/packages/gnupg.scm | 32 +++++++++++++++++++++++++++-----
1 file changed, 27 insertions(+), 5 deletions(-)

Toggle diff (47 lines)
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index a6ba57d7f3..a67eb5c691 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -345,11 +345,33 @@ (define-public gnupg
zlib))
(arguments
(list
- #:configure-flags #~'(;; Otherwise, the test suite looks for the `gpg`
- ;; executable in its installation directory in
- ;; /gnu/store before it has been installed.
- "--enable-gnupg-builddir-envvar"
- "--enable-all-tests")
+ #:configure-flags
+ ;; Always use quasiquote on the next core-updates cycle.
+ #~(#$(if (%current-target-system)
+ #~quasiquote
+ #~quote)
+ (#$@(if (%current-target-system)
+ #~(,(string-append
+ "--with-libgpg-error-prefix="
+ #$(this-package-input "libgpg-error"))
+ ,(string-append
+ "--with-libgcrypt-prefix="
+ #$(this-package-input "libgcrypt"))
+ ,(string-append
+ "--with-libassuan-prefix="
+ #$(this-package-input "libassuan"))
+ ,(string-append
+ "--with-ksba-prefix="
+ #$(this-package-input "libksba"))
+ ,(string-append
+ "--with-npth-prefix="
+ #$(this-package-input "npth")))
+ #~())
+ ;; Otherwise, the test suite looks for the `gpg`
+ ;; executable in its installation directory in
+ ;; /gnu/store before it has been installed.
+ "--enable-gnupg-builddir-envvar"
+ "--enable-all-tests"))
#:phases
#~(modify-phases %standard-phases
(add-before 'configure 'patch-paths

base-commit: 9018c6af4907c4532a95017df9f45d9439c30064
--
2.41.0
M
M
Mathieu Othacehe wrote on 10 Feb 21:08 +0100
control message for bug #68323
(address . control@debbugs.gnu.org)
877cjcm69t.fsf@meije.mail-host-address-is-not-set
close 68323
quit
?