[PATCH] gnu: go-github-com-charmbracelet-glamour: Fix build.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 1 years ago
(address . guix-patches@gnu.org)
87ttnopycp.fsf@gmail.com
Hello,

this patch fixes 'go-github-com-charmbracelet-glamour' build.
From f579a9338598e2a947e5b37b8248acf7d17f13d5 Mon Sep 17 00:00:00 2001
Message-ID: <f579a9338598e2a947e5b37b8248acf7d17f13d5.1704666787.git.poptsov.artyom@gmail.com>
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Mon, 8 Jan 2024 01:30:11 +0300
Subject: [PATCH] gnu: go-github-com-charmbracelet-glamour: Fix build.

* gnu/packages/golang.scm (go-github-com-charmbracelet-glamour): Fix build.

Change-Id: I14ce450360e684c4c1ac324e77b47771bbdf1410
---
gnu/packages/golang.scm | 17 +++++++++++++++--
1 file changed, 15 insertions(+), 2 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 58681af958..baa6e631d6 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -41,7 +41,7 @@
;;; Copyright © 2022 Christopher Howard <christopher@librehacker.com>
;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
-;;; Copyright © 2023 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2023-2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -9004,7 +9004,20 @@ (define-public go-github-com-charmbracelet-glamour
"1idq8d13rp1hx2a1xak31fwl9fmi09p2x4ymvzl7aj850saw5w0z"))))
(build-system go-build-system)
(arguments
- `(#:import-path "github.com/charmbracelet/glamour"))
+ (list #:import-path "github.com/charmbracelet/glamour"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-tests
+ (lambda _
+ ;; Some tests fail due to different number of '^[0m' symbols at
+ ;; the beginning and the end of paragraphs. To fix that we
+ ;; re-generate 'readme.test' so the test output will match the
+ ;; 'readme.test' contents.
+ (chmod "src/github.com/charmbracelet/glamour/testdata/readme.test"
+ #o644)
+ (substitute* "src/github.com/charmbracelet/glamour/glamour_test.go"
+ ((" generate = false")
+ " generate = true")))))))
(native-inputs
(list go-github-com-alecthomas-chroma
go-github-com-danwakefield-fnmatch

base-commit: 5f8a993aa85554ca09bd27139230d7664107e1b6
--
2.41.0
- avp

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQJNBAEBCgA3FiEEAf2F9Bp7f4IFgwalk16+BzbchX4FAmWbJtYZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRCTXr4HNtyFfr3nEACBBew71dJrWJdyef9RWoi9
nr95O7M+7uTYqsWZjVy+qndjsb2EtuKg2rcprQvR/EaXpOQZ/LirHGO+1Bn42u7l
34qRROhpsBgnh8+ddzYFM6r414P7XTwQrj19fn6+xO1NOxG27/6hHeG2y6EM7dEy
5TeMwfwu3sYNq1MW8FH+GZGw8cdrs9E9TjzJk3Ebw1ThAcSvVYDFmiESmNevFkEp
M+Al7fA1AA/26GY6n/wckgeNiniUiV0JmNLkBFB/JqlmVORHvjNnEgD13YVDX5DS
lE3p5uOppR7Md5zZNYnsfsZLqSBuuuOwcWP6uR9OL/pZf0SsPkflmbfRcSxH5z1f
tsqC9ynWryaP1qQoeGWTuxd/sVCEpk4h4ZvMhm2rVVNZgn/dr0iEv8HtXvcH6FhH
FjAAxx9ZDH+VoD0YihXk8GJbEeDRbUibVBQ5+ypAaKChVef6SK5JZ0tw5Zmenn7K
PJPy77J9wyBZYde4NpmcYNe1u1mcC6ZTc3+JJfAk13r/53LElKwLxyIy5EgStxH5
VNrC1a/ezKtLIiBZdYLGGh+s9NGpA1nydGCcZR3agHN7UxgQhq7W6wZ/5m276v1T
s3ku/sMmrOAFunPaZINZvijZGj6SdCmZ4SgGauTxLSs5fs1GShjDJvM+Re8uxZb/
soWgpcLm4bfa/QMnlamIqQ==
=xuDh
-----END PGP SIGNATURE-----

Mathieu Othacehe wrote 1 years ago
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)(address . 68311-done@debbugs.gnu.org)
87wmseplax.fsf@gnu.org
Hello,

Toggle quote (2 lines)
> +;;; Copyright © 2023-2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>

',' instead of '-'

Applied, thanks,

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68311@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68311
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help