[PATCH] gnu: Add rust-pbr-1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Troy Figiel
Owner
unassigned
Submitted by
Troy Figiel
Severity
normal

Debbugs page

Troy Figiel wrote 1 years ago
(address . guix-patches@gnu.org)
87le904vub.fsf@troyfigiel.com
* gnu/packages/crates-io.scm (rust-pbr-1): New variable.
---
gnu/packages/crates-io.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1bfd8fb143..1144d36878 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -35,6 +35,7 @@
;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
;;; Copyright © 2023 Steve George <steve@futurile.net>
+;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -53949,6 +53950,34 @@ (define-public rust-pbkdf2-0.4
("rust-sha-1" ,rust-sha-1-0.9)
("rust-sha2" ,rust-sha2-0.9))))))
+(define-public rust-pbr-1
+ (package
+ (name "rust-pbr")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "pbr" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "056mqvw168ziig1dgl2kq4vmkamv6gk3hv1x9696r6ynl3gjfn7d"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-test-flags
+ '("--release" "--"
+ ;; This test requires /dev/stderr
+ "--skip=tty::unix::compare_with_stty")
+ #:cargo-inputs
+ (("rust-crossbeam-channel" ,rust-crossbeam-channel-0.5)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-winapi" ,rust-winapi-0.3))
+ #:cargo-development-inputs
+ (("rust-rand" ,rust-rand-0.8))))
+ (home-page "https://github.com/a8m/pb")
+ (synopsis "Console progress bar for Rust")
+ (description "This package provides a console progress bar for Rust.")
+ (license license:expat)))
+
(define-public rust-pcap-sys-0.1
(package
(name "rust-pcap-sys")

base-commit: 5f8a993aa85554ca09bd27139230d7664107e1b6
--
2.42.0
Nicolas Goaziou wrote 2 weeks ago
(address . 68310-done@debbugs.gnu.org)(name . Troy Figiel)(address . troy@troyfigiel.com)
87tt8bbxhy.fsf@nicolasgoaziou.fr
Hello,

Toggle quote (2 lines)
> * gnu/packages/crates-io.scm (rust-pbr-1): New variable.

Thank you. However, this package is alreay in the code base. Sorry for
the duplicate work.

Closing.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 68310@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68310
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help