[PATCH] gnu: tractor: Update to 4.3.0.

  • Open
  • quality assurance status badge
Details
2 participants
  • Danial Behzadi
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Danial Behzadi
Severity
normal
D
D
Danial Behzadi wrote on 7 Jan 14:20 +0100
(address . guix-patches@gnu.org)(name . Danial Behzadi)(address . dani.behzi@ubuntu.com)
20240107132014.82266-1-dani.behzi@ubuntu.com
---
gnu/packages/tor.scm | 24 ++++++++++--------------
1 file changed, 10 insertions(+), 14 deletions(-)

Toggle diff (71 lines)
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index b81944ee6b..06b0746670 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 André Batista <nandre@riseup.net>
-;;; Copyright © 2021-2023 Danial Behzadi <dani.behzi@ubuntu.com>
+;;; Copyright © 2021-2024 Danial Behzadi <dani.behzi@ubuntu.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Jim Newsome <jnewsome@torproject.org>
;;; Copyright © 2023 Clément Lassieur <clement@lassieur.org>
@@ -443,20 +443,20 @@ (define-public nyx
(define-public tractor
(package
(name "tractor")
- (version "4.1.1")
+ (version "4.3.0")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "traxtor" version))
+ (uri (string-append "https://framagit.org/tractor/tractor/-/archive/"
+ version "/tractor-" version ".tar.bz2"))
(sha256
(base32
- "1542g6alycwlmvndxcijzn4d5lgycmxxb78gqd8qwgm9kw0fnr3q"))))
+ "1kal71hh8wbar19785b86q62rcilxrma8ldjjk258vf7lr1w12dv"))))
(build-system pyproject-build-system)
(native-inputs
(list (list glib "bin"))) ; for glib-compile-schemas.
(inputs
(list python-fire
- python-psutil
python-pygobject
python-requests
python-stem
@@ -464,25 +464,21 @@ (define-public tractor
(arguments
(list
#:tests? #f ; no test suite.
- #:phases
- #~(modify-phases %standard-phases
+ #:phases #~(modify-phases %standard-phases
(add-after 'install 'install-man-page
(lambda _
(let ((man1 (string-append #$output "/share/man/man1")))
- (install-file "tractor/man/tractor.1" man1))))
+ (install-file "data/tractor.1" man1))))
(add-after 'install 'install-bash-completion
(lambda _
- (mkdir "bash-completion")
- (rename-file "tractor/tractor-completion"
- "bash-completion/tractor")
(let ((bash-completion
(string-append #$output "/share/bash-completion/completions")))
- (install-file "bash-completion/tractor" bash-completion))))
+ (install-file "data/completion/bash/tractor" bash-completion))))
(add-after 'install 'install-gschema
(lambda _
(let ((schemas (string-append #$output "/share/glib-2.0/schemas")))
- (install-file "tractor/tractor.gschema.xml" schemas)))))))
- (home-page "https://framagit.org/tractor")
+ (install-file "src/tractor/tractor.gschema.xml" schemas)))))))
+ (home-page "https://tractor.frama.io/tractor/")
(synopsis "Setup an onion routing proxy")
(description
"This package uses Python stem library to provide a connection through
--
2.39.2
M
D
D
Danial Behzadi wrote on 8 Jan 12:09 +0100
[PATCH] gnu: tractor: Update to 4.3.0.
(address . 68303@debbugs.gnu.org)(name . Danial Behzadi)(address . dani.behzi@ubuntu.com)
20240108110949.116518-1-dani.behzi@ubuntu.com
* gnu/packages/tor.scm (tractor): Update to 4.3.0.
[source]: The new primary download link is from Framagit.
[inputs]: Remove python-psutil as no longer needed.
[phases]: Upstream is now in src-layout. data is excluded.
[home-page]: The new home is hosted on tractor.frama.io.
---
gnu/packages/tor.scm | 24 ++++++++++--------------
1 file changed, 10 insertions(+), 14 deletions(-)

Toggle diff (71 lines)
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index b81944ee6b..06b0746670 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 André Batista <nandre@riseup.net>
-;;; Copyright © 2021-2023 Danial Behzadi <dani.behzi@ubuntu.com>
+;;; Copyright © 2021-2024 Danial Behzadi <dani.behzi@ubuntu.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Jim Newsome <jnewsome@torproject.org>
;;; Copyright © 2023 Clément Lassieur <clement@lassieur.org>
@@ -443,20 +443,20 @@ (define-public nyx
(define-public tractor
(package
(name "tractor")
- (version "4.1.1")
+ (version "4.3.0")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "traxtor" version))
+ (uri (string-append "https://framagit.org/tractor/tractor/-/archive/"
+ version "/tractor-" version ".tar.bz2"))
(sha256
(base32
- "1542g6alycwlmvndxcijzn4d5lgycmxxb78gqd8qwgm9kw0fnr3q"))))
+ "1kal71hh8wbar19785b86q62rcilxrma8ldjjk258vf7lr1w12dv"))))
(build-system pyproject-build-system)
(native-inputs
(list (list glib "bin"))) ; for glib-compile-schemas.
(inputs
(list python-fire
- python-psutil
python-pygobject
python-requests
python-stem
@@ -464,25 +464,21 @@ (define-public tractor
(arguments
(list
#:tests? #f ; no test suite.
- #:phases
- #~(modify-phases %standard-phases
+ #:phases #~(modify-phases %standard-phases
(add-after 'install 'install-man-page
(lambda _
(let ((man1 (string-append #$output "/share/man/man1")))
- (install-file "tractor/man/tractor.1" man1))))
+ (install-file "data/tractor.1" man1))))
(add-after 'install 'install-bash-completion
(lambda _
- (mkdir "bash-completion")
- (rename-file "tractor/tractor-completion"
- "bash-completion/tractor")
(let ((bash-completion
(string-append #$output "/share/bash-completion/completions")))
- (install-file "bash-completion/tractor" bash-completion))))
+ (install-file "data/completion/bash/tractor" bash-completion))))
(add-after 'install 'install-gschema
(lambda _
(let ((schemas (string-append #$output "/share/glib-2.0/schemas")))
- (install-file "tractor/tractor.gschema.xml" schemas)))))))
- (home-page "https://framagit.org/tractor")
+ (install-file "src/tractor/tractor.gschema.xml" schemas)))))))
+ (home-page "https://tractor.frama.io/tractor/")
(synopsis "Setup an onion routing proxy")
(description
"This package uses Python stem library to provide a connection through
--
2.39.2
D
D
Danial Behzadi wrote on 9 Jan 17:05 +0100
[PATCH v2 2/2] gnu: tractor: Update to 4.3.1.
(address . 68303@debbugs.gnu.org)(name . Danial Behzadi)(address . dani.behzi@ubuntu.com)
20240109160538.251432-2-dani.behzi@ubuntu.com
* gnu/packages/tor.scm (tractor): Update to 4.3.1.
[inputs]: Remove python-requests as no longer needed.
[inputs]: Add python-pysock connection check needs it.
---
gnu/packages/tor.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index 6045b29bf4..f697cd8c06 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -443,7 +443,7 @@ (define-public nyx
(define-public tractor
(package
(name "tractor")
- (version "4.3.0")
+ (version "4.3.1")
(source
(origin
(method url-fetch)
@@ -451,14 +451,14 @@ (define-public tractor
version "/tractor-" version ".tar.bz2"))
(sha256
(base32
- "1kal71hh8wbar19785b86q62rcilxrma8ldjjk258vf7lr1w12dv"))))
+ "1qqivzv65ckhk7nz6vcgchqwkxdmh2sdmkgvv8phqb1c4mzp48ip"))))
(build-system pyproject-build-system)
(native-inputs
(list (list glib "bin"))) ; for glib-compile-schemas.
(inputs
(list python-fire
python-pygobject
- python-requests
+ python-pysocks
python-stem
python-termcolor))
(arguments
--
2.39.2
D
D
Danial Behzadi wrote on 9 Jan 17:05 +0100
[PATCH v2 1/2] gnu: tractor: Update to 4.3.0.
(address . 68303@debbugs.gnu.org)(name . Danial Behzadi)(address . dani.behzi@ubuntu.com)
20240109160538.251432-1-dani.behzi@ubuntu.com
* gnu/packages/tor.scm (tractor): Update to 4.3.0.
[source]: The new primary download link is from Framagit.
[inputs]: Remove python-psutil as no longer needed.
[phases]: Upstream is now in src-layout. data is excluded.
[home-page]: The new home is hosted on tractor.frama.io.
---
gnu/packages/tor.scm | 24 ++++++++++--------------
1 file changed, 10 insertions(+), 14 deletions(-)

Toggle diff (71 lines)
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index b81944ee6b..6045b29bf4 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 André Batista <nandre@riseup.net>
-;;; Copyright © 2021-2023 Danial Behzadi <dani.behzi@ubuntu.com>
+;;; Copyright © 2021-2024 Danial Behzadi <dani.behzi@ubuntu.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Jim Newsome <jnewsome@torproject.org>
;;; Copyright © 2023 Clément Lassieur <clement@lassieur.org>
@@ -443,20 +443,20 @@ (define-public nyx
(define-public tractor
(package
(name "tractor")
- (version "4.1.1")
+ (version "4.3.0")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "traxtor" version))
+ (uri (string-append "https://framagit.org/tractor/tractor/-/archive/"
+ version "/tractor-" version ".tar.bz2"))
(sha256
(base32
- "1542g6alycwlmvndxcijzn4d5lgycmxxb78gqd8qwgm9kw0fnr3q"))))
+ "1kal71hh8wbar19785b86q62rcilxrma8ldjjk258vf7lr1w12dv"))))
(build-system pyproject-build-system)
(native-inputs
(list (list glib "bin"))) ; for glib-compile-schemas.
(inputs
(list python-fire
- python-psutil
python-pygobject
python-requests
python-stem
@@ -464,25 +464,21 @@ (define-public tractor
(arguments
(list
#:tests? #f ; no test suite.
- #:phases
- #~(modify-phases %standard-phases
+ #:phases #~(modify-phases %standard-phases
(add-after 'install 'install-man-page
(lambda _
(let ((man1 (string-append #$output "/share/man/man1")))
- (install-file "tractor/man/tractor.1" man1))))
+ (install-file "data/tractor.1" man1))))
(add-after 'install 'install-bash-completion
(lambda _
- (mkdir "bash-completion")
- (rename-file "tractor/tractor-completion"
- "bash-completion/tractor")
(let ((bash-completion
(string-append #$output "/share/bash-completion/completions")))
- (install-file "bash-completion/tractor" bash-completion))))
+ (install-file "data/completion/bash/tractor" bash-completion))))
(add-after 'install 'install-gschema
(lambda _
(let ((schemas (string-append #$output "/share/glib-2.0/schemas")))
- (install-file "tractor/tractor.gschema.xml" schemas)))))))
- (home-page "https://framagit.org/tractor")
+ (install-file "src/tractor/tractor.gschema.xml" schemas)))))))
+ (home-page "https://tractor.frama.io/tractor")
(synopsis "Setup an onion routing proxy")
(description
"This package uses Python stem library to provide a connection through
--
2.39.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 68303@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68303
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch