[PATCH gnome-team] gnu: dbus-service: only symlink /run/dbus the first time

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Vivien Kraus
Owner
unassigned
Submitted by
Vivien Kraus
Severity
normal
V
V
Vivien Kraus wrote on 5 Jan 09:56 +0100
(address . guix-patches@gnu.org)
ca5302001b635655827dde819a962cbaf124cdfa.camel@planete-kraus.eu
Due to an error in the nesting of S-Expressions, the re-linking of
/var/run/dbus to /run/dbus would occur even if it was already a
correct symlink. It should only happen if the symlink is different.

* gnu/services/dbus.scm (dbus-activation): Adjust accordingly.
---
gnu/services/dbus.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (21 lines)
diff --git a/gnu/services/dbus.scm b/gnu/services/dbus.scm
index 1edcc6eb9e..8dee91a3f7 100644
--- a/gnu/services/dbus.scm
+++ b/gnu/services/dbus.scm
@@ -210,9 +210,9 @@ (define (dbus-activation config)
(begin
(rename-file (string-append "/var/run/dbus/" next)
(string-append "/run/dbus/" next))
- (loop (readdir dir))))))))
- (rmdir "/var/run/dbus")
- (symlink "/run/dbus" "/var/run/dbus")))
+ (loop (readdir dir)))))))
+ (rmdir "/var/run/dbus")
+ (symlink "/run/dbus" "/var/run/dbus"))))
(else
(format (current-error-port)
"Failed to symlink /run/dbus to /var/run/dbus: ~s~%"

base-commit: 1cd97066c2dc84c6e538cfa63820e18f6c12a414
--
2.41.0
L
L
Liliana Marie Prikler wrote on 7 Jan 18:39 +0100
71d650bb003f4b72c90c9337cfb5ccfc1b308959.camel@gmail.com
Am Freitag, dem 05.01.2024 um 09:56 +0100 schrieb Vivien Kraus:
Toggle quote (6 lines)
> Due to an error in the nesting of S-Expressions, the re-linking of
> /var/run/dbus to /run/dbus would occur even if it was already a
> correct symlink.  It should only happen if the symlink is different.
>
> * gnu/services/dbus.scm (dbus-activation): Adjust accordingly.
> ---
Yeah, that LGTM.

Pushed
Closed
?