[PATCH 0/3] gnu: yggdrasil: Fix build.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andrew Tropin
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 1 years ago
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
cover.1704423368.git.sharlatanus@gmail.com
Hi Guix,

The merge of the patch series from https://issues.guix.gnu.org/issue/66827
introduced some inconsistencie with updated version of
go-github-com-hjson-hjson-go.

This small patch set has fixed it.

Toggle quote (1 lines)
> ./pre-inst-env guix build yggdrasil
/gnu/store/42n899nzfng6ybnjh41115y6vaa5w30v-yggdrasil-0.5.2

Sharlatan Hellseher (3):
gnu: go-github-com-hjson-hjson-go: Fix commit.
gnu: yggdrasil: Sort inputs alphabetically.
gnu: yggdrasil: Remove duplicated input.

gnu/packages/golang-web.scm | 5 +++--
gnu/packages/networking.scm | 39 ++++++++++++++++++-------------------
2 files changed, 22 insertions(+), 22 deletions(-)


base-commit: be1d05c10766a979dd0720b677889ed950d3b895
--
2.41.0
Sharlatan Hellseher wrote 1 years ago
[PATCH 2/3] gnu: yggdrasil: Sort inputs alphabetically.
(address . 68247@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
848e5cd33de854b56fc898cb7d861d4ee1d0ab5e.1704423368.git.sharlatanus@gmail.com
* gnu/packages/networking.scm (yggdrasil)[propagated-inputs]: Sort
alphabetically to ease maintenance.

Change-Id: I336307433842bd1dce0cfb62d93be767e0a92dbb
---
gnu/packages/networking.scm | 40 ++++++++++++++++++-------------------
1 file changed, 20 insertions(+), 20 deletions(-)

Toggle diff (58 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index c3796f7328..bf72fd7de2 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -4450,31 +4450,31 @@ (define-public yggdrasil
#:deep? #true)))
(cons go-golang-org-x-sys-0.8
(map p
- (list go-golang-zx2c4-com-wireguard
- go-golang-org-x-text
- go-golang-org-x-net
- go-golang-org-x-crypto
- go-golang-org-x-tools
- go-netns
- go-netlink
+ (list go-github-com-arceliar-ironwood
+ go-github-com-arceliar-phony
go-github-com-bits-and-blooms-bitset
go-github-com-bits-and-blooms-bloom
- go-github-com-quic-go-quic-go
+ go-github-com-cheggaaa-pb-v3
+ go-github-com-fatih-color
+ go-github-com-gologme-log
+ go-github-com-hashicorp-go-syslog
go-github-com-hjson-hjson-go
- go-github-com-olekukonko-tablewriter
- go-github-com-mitchellh-mapstructure
- go-github-com-mattn-go-runewidth
- go-github-com-mattn-go-isatty
- go-github-com-mattn-go-colorable
- go-github-com-kardianos-minwinsvc
go-github-com-hjson-hjson-go
- go-github-com-hashicorp-go-syslog
- go-github-com-gologme-log
- go-github-com-fatih-color
- go-github-com-cheggaaa-pb-v3
+ go-github-com-kardianos-minwinsvc
+ go-github-com-mattn-go-colorable
+ go-github-com-mattn-go-isatty
+ go-github-com-mattn-go-runewidth
+ go-github-com-mitchellh-mapstructure
+ go-github-com-olekukonko-tablewriter
+ go-github-com-quic-go-quic-go
go-github-com-vividcortex-ewma
- go-github-com-arceliar-phony
- go-github-com-arceliar-ironwood)))))
+ go-golang-org-x-crypto
+ go-golang-org-x-net
+ go-golang-org-x-text
+ go-golang-org-x-tools
+ go-golang-zx2c4-com-wireguard
+ go-netlink
+ go-netns)))))
(home-page "https://yggdrasil-network.github.io/blog.html")
(synopsis
"Experiment in scalable routing as an encrypted IPv6 overlay network")
--
2.41.0
Sharlatan Hellseher wrote 1 years ago
[PATCH 1/3] gnu: go-github-com-hjson-hjson-go: Fix commit.
(address . 68247@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
14d8ca115cca04b29c8b0cfcdda42197e000fdd8.1704423368.git.sharlatanus@gmail.com
This package was updated in ada2152893eda2301890e6a438c3e9fb4e0f190d and
moved with lower version which broke yggdrasil.

Author: Artyom V. Poptsov <poptsov.artyom@gmail.com>
AuthorDate: Wed Nov 1 00:15:16 2023 +0300
Commit: Christopher Baines <mail@cbaines.net>
CommitDate: Fri Nov 3 10:14:06 2023 +0000

gnu: go-github-com-hjson-hjson-go: Update to 4.3.1.

* gnu/packages/golang.scm (go-github-com-hjson-hjson-go): Update to 4.3.1.

Change-Id: Iee2aef614686cbf79f388e2dd9435745d5502e2a
---
gnu/packages/golang-web.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 7759916c35..3e60bfaf33 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2023 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2023 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -870,7 +871,7 @@ (define-public go-github-com-gorilla-websocket
(define-public go-github-com-hjson-hjson-go
(package
(name "go-github-com-hjson-hjson-go")
- (version "3.1.0")
+ (version "4.3.1")
(source
(origin
(method git-fetch)
@@ -879,7 +880,7 @@ (define-public go-github-com-hjson-hjson-go
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1dfdiahimg6z9idg8jiqxwnlwjnmasbjccx8gnag49cz4yfqskaz"))))
+ (base32 "138vmbnrwzxf64cia27k407clrydvs2jx927dlv6ziydiqyvy7m3"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/hjson/hjson-go"))
--
2.41.0
Sharlatan Hellseher wrote 1 years ago
[PATCH 3/3] gnu: yggdrasil: Remove duplicated input.
(address . 68247@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
71ae6585d041679e17bcfd2acebb184602b5843d.1704423368.git.sharlatanus@gmail.com
* gnu/packages/networking.scm (yggdrasil)[propagated-inputs]: Remove
duplicated go-github-com-hjson-hjson-go.

Change-Id: I13b1808ffcbf80a2b4fd17188a8b62557a943d24
---
gnu/packages/networking.scm | 1 -
1 file changed, 1 deletion(-)

Toggle diff (14 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index bf72fd7de2..9844430656 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -4459,7 +4459,6 @@ (define-public yggdrasil
go-github-com-gologme-log
go-github-com-hashicorp-go-syslog
go-github-com-hjson-hjson-go
- go-github-com-hjson-hjson-go
go-github-com-kardianos-minwinsvc
go-github-com-mattn-go-colorable
go-github-com-mattn-go-isatty
--
2.41.0
Andrew Tropin wrote 1 years ago
Re: [bug#68247] [PATCH 0/3] gnu: yggdrasil: Fix build.
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
87le925yk4.fsf@trop.in
On 2024-01-05 02:58, Sharlatan Hellseher wrote:

Toggle quote (23 lines)
> Hi Guix,
>
> The merge of the patch series from https://issues.guix.gnu.org/issue/66827
> introduced some inconsistencie with updated version of
> go-github-com-hjson-hjson-go.
>
> This small patch set has fixed it.
>
>> ./pre-inst-env guix build yggdrasil
> /gnu/store/42n899nzfng6ybnjh41115y6vaa5w30v-yggdrasil-0.5.2
>
> Sharlatan Hellseher (3):
> gnu: go-github-com-hjson-hjson-go: Fix commit.
> gnu: yggdrasil: Sort inputs alphabetically.
> gnu: yggdrasil: Remove duplicated input.
>
> gnu/packages/golang-web.scm | 5 +++--
> gnu/packages/networking.scm | 39 ++++++++++++++++++-------------------
> 2 files changed, 22 insertions(+), 22 deletions(-)
>
>
> base-commit: be1d05c10766a979dd0720b677889ed950d3b895

Hi Sharlatan!

Applied, pushed as

Thank you for the prompt fix! Much appreciate! :)

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmWZYswACgkQIgjSCVjB
3rBEgg/9HlDOFUG0iXQNptXAS6NKJ7eoScwxHmzYKrXvFURDp28L6Rrqi/2xIipw
IuJmSiNek1ytS50LI42Gc3eep7Up+qkfiA7VBpb5RHVHObVqGbp60TSjMRk5F4nA
aTVSVl8Wsha0+fbvOQkJiC+fDZuoSJTfd6AOv7W0Wlx2GxGAvS7VaHJDz0J9qx2/
5cMswa17XhzrOdeUObB4YsZLbXnk1ndXDy8MHAsUDe16aTyGb8P/6YF+UuYHWWNp
x5C9UUbf8TNIrgGawyj2mFMz3kgD9UWPFfc4N7dVKc9KRHFbzThKaY89BRUtx4O0
cVFKacGgP1J8ENYZwhowoDnxN95F5yBxPFI1E6ZOrxnGAIP/+XQpepgaL06Jcv7v
XZYwGXbM+cOB+2jDEhBtN+jWkDvCnkcZWS7oj1AWs+Bobgo0/iFOToW9Fh6FV5JV
MwvaW5UyK9TdgjKm9JlorIIuZAw7htvy5gViHnNrI6xG9WWL1Bv7wlw7+9wI60vX
jKZkmwhNbIfOmGIDkz+ByYfPlEyJEVtYameUiyjxwJJoG4Dfc4freum+uMTlkovu
HTeaIADGYjsceNq7WrteL3tXnYlamx/pwwPky4rvUP4Bslnf867hUzqTjyndmCOJ
cF9S/ZN1INwAn4OCr/RRrw9rT7EEn0Nsd7h+CKmPoqORvQcBj10=
=Nvtk
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68247@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68247
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help