[PATCH] gnu: docker: Update to 20.10.27.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christian Miller
  • Hilton Chain
Owner
unassigned
Submitted by
Christian Miller
Severity
normal
C
C
Christian Miller wrote on 4 Jan 07:51 +0100
(address . guix-patches@gnu.org)(name . Christian Miller)(address . christian.miller@dadoes.de)
9aeba68acd04e2396e6864228deddfded0d8a234.1704351066.git.christian.miller@dadoes.de

* gnu/packages/docker.scm (%docker-version): Update to 20.10.27.
(docker-libnetwork): Update to 20.10-3.3797618.

Change-Id: Ie4cc54f62c89f3a6c83969d1e7e425189c370482
---
gnu/packages/docker.scm | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index a69bbac168..e74115c4c5 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -54,7 +54,7 @@ (define-module (gnu packages docker)
;; Note - when changing Docker versions it is important to update the versions
;; of several associated packages (docker-libnetwork and go-sctp).
-(define %docker-version "20.10.25")
+(define %docker-version "20.10.27")
(define-public python-docker
(package
@@ -264,9 +264,9 @@ (define docker-libnetwork
;; the branch that Docker uses, as can be seen in the 'vendor.conf' Docker
;; source file. NOTE - It is important that this version is kept in sync
;; with the version of Docker being used.
- (let ((commit "3f0048413d95802b9c6c836eba06bfc54f9dbd03")
+ (let ((commit "3797618f9a38372e8107d8c06f6ae199e1133ae8")
(version (version-major+minor %docker-version))
- (revision "2"))
+ (revision "3"))
(package
(name "docker-libnetwork")
(version (git-version version revision commit))
@@ -279,7 +279,7 @@ (define docker-libnetwork
(file-name (git-file-name name version))
(sha256
(base32
- "185i5ji7dwkv41zmb8s3d7i5gg72wivcj1l4bhr1lb3a1vy2hcxc"))
+ "1km3p6ya9az0ax2zww8wb5vbifr1gj5n9l82i273m9f3z9f2mq2p"))
;; Delete bundled ("vendored") free software source code.
(modules '((guix build utils)))
(snippet '(delete-file-recursively "vendor"))))
@@ -333,7 +333,7 @@ (define-public docker
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1q5vc6f5fzzxsvv1kwdky56fr1jiy9199m3vxqh4mz85qr067cmn"))))
+ (base32 "017frilx35w3m4dz3n6m2f293q4fq4jrk6hl8f7wg5xs3r8hswvq"))))
(build-system gnu-build-system)
(arguments
(list
@@ -615,7 +615,7 @@ (define-public docker-cli
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0qy35vvnl4lf9w6dr9n7yfqvzhzm7m3sl2ai275apbhygwgcsbss"))))
+ (base32 "0szwaxiasy77mm90wj2qg747zb9lyiqndg5halg7qbi41ng6ry0h"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/docker/cli"

base-commit: 7b0863f07a113caef26fea13909bd97d250b629e
--
2.41.0
H
H
Hilton Chain wrote on 13 Jan 12:18 +0100
(name . Christian Miller)(address . christian.miller@dadoes.de)(address . 68240-done@debbugs.gnu.org)
87r0il4h3a.wl-hako@ultrarare.space
Hi Christian,

On Thu, 04 Jan 2024 14:51:06 +0800,
Christian Miller via Guix-patches via wrote:
Toggle quote (11 lines)
>
> Fixes <https://issues.guix.gnu.org/68053>.
>
> * gnu/packages/docker.scm (%docker-version): Update to 20.10.27.
> (docker-libnetwork): Update to 20.10-3.3797618.
>
> Change-Id: Ie4cc54f62c89f3a6c83969d1e7e425189c370482
> ---
> gnu/packages/docker.scm | 12 ++++++------
> 1 file changed, 6 insertions(+), 6 deletions(-)

Applied as 0869b0e6a35851d17dd876fcd517eb8e7b017238, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68240@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68240
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch