[PATCH] gnu: Add kvirc.

  • Open
  • quality assurance status badge
Details
One participant
  • Christian Miller
Owner
unassigned
Submitted by
Christian Miller
Severity
normal
C
C
Christian Miller wrote on 4 Jan 06:02 +0100
(address . guix-patches@gnu.org)(name . Christian Miller)(address . christian.miller@dadoes.de)
71df36b335bc02ca56364a2f29ea471ca8b50268.1704344551.git.christian.miller@dadoes.de
* gnu/packages/irc.scm (kvirc): New variable.

Change-Id: I35c284aed0176232a31d01821cdb7be4e5646140
---
gnu/packages/irc.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (77 lines)
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 46961ccb7e..483ecc94d5 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2024 Christian Miller <christian.miller@dadoes.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -60,6 +61,8 @@ (define-module (gnu packages irc)
#:use-module (gnu packages curl)
#:use-module (gnu packages cyrus-sasl)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages documentation)
+ #:use-module (gnu packages enchant)
#:use-module (gnu packages file)
#:use-module (gnu packages gettext)
#:use-module (gnu packages geo)
@@ -68,6 +71,7 @@ (define-module (gnu packages irc)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages golang)
#:use-module (gnu packages golang-check)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
#:use-module (gnu packages guile-xyz)
@@ -629,6 +633,43 @@ (define-public kirc
(home-page "http://kirc.io/index.html")
(license license:expat)))
+(define-public kvirc
+ (package
+ (name "kvirc")
+ (version "5.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kvirc/KVIrc")
+ (commit (string-append version "-beta3"))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0qs419jk875sz9r8492m6cz23axd93qhgf3h6k6766kiqv7aahys"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f)) ;no tests
+ (native-inputs (list pkg-config doxygen graphviz))
+ (inputs (list zlib
+ qtbase-5
+ qtmultimedia-5
+ qtwebengine-5
+ qtsvg-5
+ qtx11extras
+ openssl
+ perl
+ enchant
+ python
+ gettext-minimal))
+ (home-page "https://www.kvirc.net/")
+ (synopsis "IRC client based on QT GUI toolkit")
+ (description
+ "KVIrc is a free portable IRC client based on the excellent Qt GUI
+toolkit. KVirc is being written by Szymon Stefanek and the KVIrc Development
+Team with the contribution of many IRC addicted developers around the world.")
+ (license license:gpl2)))
+
(define-public limnoria
(package
(name "limnoria")

base-commit: 7b0863f07a113caef26fea13909bd97d250b629e
--
2.41.0
?