[PATCH] gnu: Add gnome-software.

  • Open
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • Justin Veilleux
Owner
unassigned
Submitted by
Justin Veilleux
Severity
normal
J
J
Justin Veilleux wrote on 3 Jan 07:30 +0100
(address . guix-patches@gnu.org)
87edez3p4h.fsf@cock.li
Hi. This is a patch for gnome-software.

Cheers.
From c8c61e3b4c3b30c2b28c7fed971e19d7bea4cf46 Mon Sep 17 00:00:00 2001
Message-ID: <c8c61e3b4c3b30c2b28c7fed971e19d7bea4cf46.1704263261.git.terramorpha@cock.li>
From: terramorpha <terramorpha@cock.li>
Date: Wed, 3 Jan 2024 01:23:36 -0500
Subject: [PATCH] gnu: Add gnome-software.

* gnu/packages/gnome.scm (gnome-software): New variable.

Change-Id: I5838a581d8612eed0697c801fff0e241256ce558
---
gnu/packages/gnome.scm | 71 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 71 insertions(+)

Toggle diff (90 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b2d4b73088..fe507d5b2d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -77,6 +77,7 @@
;;; Copyright © 2023 Juliana Sims <juli@incana.org>
;;; Copyright © 2023 Dominik Delgado Steuter <d@delgado.nrw>
;;; Copyright © 2023 Zhu Zihao <all_but_last@163.com>
+;;; Copyright © 2024 Justin Veilleux <terramorpha@cock.li>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -13459,3 +13460,73 @@ (define-public xffm+
(home-page "http://xffm.org/")
(license license:gpl3+)
(properties '((upstream-name . "xffm")))))
+
+(define-public gnome-software
+ (package
+ (name "gnome-software")
+ (version "42.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "mirror://gnome/sources/"
+ name "/"
+ (version-major version) "/"
+ name "-" version ".tar.xz"))
+ (sha256 (base32 "091jc82450lsrm0l8wi2byh1317abwp5c32wrrk0hpbz59iljhz8"))))
+
+ (native-inputs
+ (list
+ pkg-config
+ (list glib "bin")
+ gnu-gettext
+ gtk-doc
+ (list gtk "bin")
+ desktop-file-utils))
+
+ (inputs
+ (list
+ appstream
+ gdk-pixbuf
+ libxmlb
+ gtk
+ json-glib
+ libsoup
+ libadwaita
+ valgrind
+ gsettings-desktop-schemas
+ polkit
+ packagekit
+ flatpak
+ libostree
+ libsoup-minimal-2
+ malcontent
+ libgudev))
+ (build-system meson-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after
+ 'unpack
+ 'patch-iso-codes
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ (with-directory-excursion
+ "src"
+ (substitute* "./gs-language.c"
+ (("DATADIR")
+ (format #f "\"~a/share\"" #$iso-codes)))
+ (invoke "cat" "gs-language.c")))))
+
+ #:configure-flags
+ ''("-Dfwupd=false"
+ "-Dsoup2=true"
+ ;; tries to download something over the internet, makes the build fail
+ "-Dman=false")
+ #:tests? #f
+ #:validate-runpath? #f))
+ (synopsis "Graphical software manager for gnome")
+ (description "Software allows you to find and install new apps and system
+extensions and remove existing installed apps.")
+ (license license:gpl2)
+ (home-page "https://apps.gnome.org/en/Software/")))

base-commit: f4628000024219bf373922ff4a6fa752eb821797
--
2.41.0
M
M
Mathieu Othacehe wrote on 4 Jan 13:41 +0100
(name . Justin Veilleux)(address . terramorpha@cock.li)(address . 68228@debbugs.gnu.org)
87wmsp1da8.fsf@gnu.org
Hello,

Toggle quote (2 lines)
> Hi. This is a patch for gnome-software.

I tried out this package but it complains about a missing .service for
PackageKit. Have you fixed that issue locally?

Is there any software that can be installed using the gnome-software
on Guix System in the first place?

Thanks,

Mathieu
J
J
Justin Veilleux wrote on 4 Jan 18:36 +0100
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 68228@debbugs.gnu.org)
8497E26D-608A-434E-8B8B-48F921A7FC48@cock.li
Hello. For it to work, it needs to be installed in a profile.

For now, it can be used to install flatpaks

Cheers.

On January 4, 2024 7:41:35 a.m. EST, Mathieu Othacehe <othacehe@gnu.org> wrote:
Toggle quote (14 lines)
>
>Hello,
>
>> Hi. This is a patch for gnome-software.
>
>I tried out this package but it complains about a missing .service for
>PackageKit. Have you fixed that issue locally?
>
>Is there any software that can be installed using the gnome-software
>on Guix System in the first place?
>
>Thanks,
>
>Mathieu
Attachment: file
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 68228@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68228
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch