Ekaitz Zarraga wrote 1 years ago
(address . guix-patches@gnu.org)
* gnu/packages/commencement.scm(mes-boot): Update to 0.25.1.
[supported-systems]: Add riscv64-linux
Change-Id: I262a8b6855e8c6528969d0c4b69a42cd2f477f2d
---
gnu/packages/commencement.scm | 13 +++++++++----
1 file changed, 9 insertions(+), 4 deletions(-)
Toggle diff (44 lines)
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 1ef0b2e757..5a0d33bf0f 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -375,7 +375,7 @@ (define mes-boot
(package
(inherit mes)
(name "mes-boot")
- (version "0.24.2")
+ (version "0.25.1")
(source (origin
(method url-fetch)
(uri (list (string-append "mirror://gnu/mes/"
@@ -384,10 +384,10 @@ (define mes-boot
"mes-" version ".tar.gz")))
(sha256
(base32
- "0vp8v88zszh1imm3dvdfi3m8cywshdj7xcrsq4cgmss69s2y1nkx"))))
+ "03np6h4qx94givjdvq2rmhvab38y5f91254n0avg4vq2j0cx78in"))))
(inputs '())
(propagated-inputs '())
- (supported-systems '("i686-linux" "x86_64-linux"))
+ (supported-systems '("i686-linux" "x86_64-linux" "riscv64-linux"))
(native-inputs
`(("m2-planet" ,stage0-posix)
("nyacc-source" ,(bootstrap-origin
@@ -416,9 +416,14 @@ (define mes-boot
dir "/nyacc-1.00.2/module"))
(invoke "gash" "configure.sh"
(string-append "--prefix=" out)
- "--host=i686-linux-gnu"))))
+ "--host=" #$(or (%current-target-system)
+ (%current-system))))))
(replace 'build
(lambda _
+ ;; TODO: GUILE_LOAD_PATH is leaking. We need to clean it.
+ (substitute* "kaem.run"
+ (("cp bin/mes-m2 bin/mes" all)
+ (string-append "GUILE_LOAD_PATH=/fubar\n" all)))
(invoke "gash" "bootstrap.sh")))
(delete 'check)
(replace 'install
--
2.41.0