[PATCH] enchant: update to 2.6.2

  • Open
  • quality assurance status badge
Details
One participant
  • Benjamin Slade
Owner
unassigned
Submitted by
Benjamin Slade
Severity
normal
B
B
Benjamin Slade wrote on 2 Jan 16:13 +0100
(address . guix-patches@gnu.org)
87cyuj6a3h.fsf@lambda-y.net
--

'(Dr Benjamin Slade (he/him)
     (website . https://lambda-y.net)
     `(pgp_fp: ,(B20E 444C FA80 B5F8 15FA 4AD8 6FBF CD68 3B05 2B84))
       "sent by mu4e 1.10.8 in Emacs 30.0.50 with org-msg on GNU Guix (Linux)")
From 280b0adac0ea44b0dbc8581816222e6a6965daeb Mon Sep 17 00:00:00 2001
From: Benjamin Slade <slade@lambda-y.net>
Date: Tue, 2 Jan 2024 09:08:45 -0600
Subject: [PATCH] enchant: update to 2.6.2

- [emacs-jinx](gnu/packages/emacs-xyz.scm:10649:2) complains if `enchant` is
not at least v.2.3.
- the latest release (2.6.4) fails to build on Guix due to an added check for
a particular version of
[Grimpper reports: "for some reason the .pc genersted for UnitTest++ is lacking the version number. The PKG_CONFIG_PATH is set correctly but since it's checking for version >= 1.6, it cannot find it (it's empty, the field)."]
---
gnu/packages/enchant.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

Toggle diff (49 lines)
diff --git a/gnu/packages/enchant.scm b/gnu/packages/enchant.scm
index 015af0d..e9909b8 100644
--- a/gnu/packages/enchant.scm
+++ b/gnu/packages/enchant.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2024 Benjamin Slade <slade@lambda-y.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,6 +26,7 @@ (define-module (gnu packages enchant)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages groff)
#:use-module (gnu packages hunspell)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages man)
@@ -79,7 +81,7 @@ (define-public nuspell
(define-public enchant
(package
(name "enchant")
- (version "2.2.15")
+ (version "2.6.2")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/AbiWord/enchant/releases"
@@ -87,7 +89,7 @@ (define-public enchant
version ".tar.gz"))
(sha256
(base32
- "00vcykbb7lxh51prvmsb62a06q18a6rlk9ba5a7g45c1awaj43rv"))))
+ "07byzy5nanmkbfgcyr3xpsfywiivnl7jz8h9xs6hyxkfwllag1k6"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--disable-static"
@@ -97,7 +99,7 @@ (define-public enchant
(list aspell hunspell))
(propagated-inputs
;; Required by enchant.pc.
- (list glib))
+ (list glib groff))
(native-inputs
`(("glib:bin" ,glib "bin")
("pkg-config" ,pkg-config)
--
2.41.0
?