* gnu/packages/python-xyz.scm (python-click-default-group): Update to 1.2.4.
[source]: Download from gitlab, because pypi package does not include
tests.
[build-system]: Change to pyproject-build-system.
[arguments]: Enable tests.
[native-inputs]: Add python-flit-core and python-pytest.
Change-Id: I7f3758066d167d28de2cc1214091a8a502ab4215
---
gnu/packages/python-xyz.scm | 25 ++++++++++++++-----------
1 file changed, 14 insertions(+), 11 deletions(-)
Toggle diff (47 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2afce6c667..77751a8d53 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -108,7 +108,7 @@
;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
;;; Copyright © 2021, 2022, 2023 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
;;; Copyright © 2021, 2022 Pradana Aumars <paumars@courrier.dev>
-;;; Copyright © 2021, 2022, 2023 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2021–2024 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Sébastien Lerique <sl@eauchat.org>
;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
;;; Copyright © 2021 ZmnSCPxj <ZmnSCPxj@protonmail.com>
@@ -16422,18 +16422,21 @@ (define-public python-click-log
(define-public python-click-default-group
(package
(name "python-click-default-group")
- (version "1.2.2")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "click-default-group" version))
- (sha256
- (base32
- "015r78jk8gznfw0dphpwaqcx5mhg5822b55w5xbb6i7sin70wmnr"))))
- (build-system python-build-system)
- (arguments
- `(#:tests? #f)) ; no target
+ (version "1.2.4")
+ (source
+ (origin
+ (method git-fetch) ; no tests in PyPI release
+ (uri (git-reference
+ (url "https://github.com/click-contrib/click-default-group")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06h12qwg0lhvxlgfm9768afibwp8j6r3r440v630a30bv0nkhngm"))))
+ (build-system pyproject-build-system)
(propagated-inputs
(list python-click))
+ (native-inputs
+ (list python-flit-core python-pytest))
(synopsis "Extends click.Group")
(description "This package extends click.Group to invoke a command without
explicit subcommand name.")
--
2.43.0