* gnu/packages/python-web.scm (python-urllib3-2): New variable.
* gnu/packages/python-web.scm (python-urllib3): Inherit python-urllib3-2.
Change-Id: Ib96504a72eb6f4485a777854bd7580c4b092756a
---
gnu/packages/python-web.scm | 35 ++++++++++++++++++++++++++---------
1 file changed, 26 insertions(+), 9 deletions(-)
Toggle diff (73 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 06b578dac7..cd5cac4f44 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -60,6 +60,7 @@
;;; Copyright © 2022 Baptiste Strazzulla <bstrazzull@hotmail.fr>
;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2023 Ivan Vilata-i-Balaguer <ivan@selidor.net>
+;;; Copyright © 2024 Jaeme Sifat <jaeme@runbox.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3597,8 +3598,31 @@ (define-public python-unalix
addon for removing tracking fields from URLs.")
(license license:lgpl3+)))
+(define-public python-urllib3-2
+ (package
+ (name "python-urllib3")
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "urllib3" version))
+ (sha256
+ (base32
+ "0m1dnpbw2dyxp7658v1fm37zzx5mb4n9p2g7i22ag3qln2pshynz"))))
+ (build-system pyproject-build-system)
+ (arguments `(#:tests? #f))
+ (native-inputs (list python-hatchling))
+ (home-page "https://urllib3.readthedocs.io/")
+ (synopsis "HTTP library with thread-safe connection pooling")
+ (description
+ "Urllib3 supports features left out of urllib and urllib2 libraries. It
+can reuse the same socket connection for multiple requests, it can POST files,
+supports url redirection and retries, and also gzip and deflate decoding.")
+ (license license:expat)))
+
(define-public python-urllib3
(package
+ (inherit python-urllib3-2)
(name "python-urllib3")
(version "1.26.15")
(source
@@ -3609,7 +3633,7 @@ (define-public python-urllib3
(base32
"01dkqv0rsjqyw4wrp6yj8h3bcnl7c678qkj845596vs7p4bqff4a"))))
(build-system python-build-system)
- (arguments `(#:tests? #f))
+ (native-inputs '())
(propagated-inputs
(append
;; These 5 inputs are used to build urrlib3[secure]
@@ -3623,14 +3647,7 @@ (define-public python-urllib3
(package-transitive-supported-systems python-pyopenssl))
(list python-pyopenssl)
'())
- (list python-pysocks)))
- (home-page "https://urllib3.readthedocs.io/")
- (synopsis "HTTP library with thread-safe connection pooling")
- (description
- "Urllib3 supports features left out of urllib and urllib2 libraries. It
-can reuse the same socket connection for multiple requests, it can POST files,
-supports url redirection and retries, and also gzip and deflate decoding.")
- (license license:expat)))
+ (list python-pysocks)))))
(define-public awscli
(package
base-commit: ee0cf3b9ff4cd5a9d3637d09677195ea9ee1a8c0
--
2.41.0