[PATCH 0/5] gnu: yt-dlp: Update to 2023.12.30

  • Open
  • quality assurance status badge
Details
2 participants
  • Ian Eure
  • Jaeme Sifat
Owner
unassigned
Submitted by
Jaeme Sifat
Severity
normal
J
J
Jaeme Sifat wrote on 2 Jan 00:14 +0100
(address . guix-patches@gnu.org)(name . Jaeme Sifat)(address . jaeme@runbox.com)
cover.1704150597.git.jaeme@runbox.com
This patchset updates yt-dlp to version 2023.11.16 and to version
2023.12.30. It adds three new packages: python-urllib3-2, python-requests-2.31
and python-websockets-12 to avoid mass rebuilds.

Happy new years!

Jaeme Sifat (5):
gnu: Add python-urllib3-2.
gnu: Add python-requests-2.31.
gnu: yt-dlp: Update to 2023.11.16.
gnu: Add python-websockets-12.
gnu: yt-dlp: Update to 2023.12.30.

gnu/packages/python-web.scm | 100 ++++++++++++++++++++++++++----------
gnu/packages/video.scm | 8 +--
2 files changed, 78 insertions(+), 30 deletions(-)


base-commit: 86b5fa100992527c434616482ba9cfd92b636d12
--
2.41.0
J
J
Jaeme Sifat wrote on 2 Jan 00:21 +0100
[PATCH 2/5] gnu: Add python-requests-2.31.
(address . 68197@debbugs.gnu.org)(name . Jaeme Sifat)(address . jaeme@runbox.com)
560be5dbf9d29cb5910c542b93292b8585bcc73c.1704150597.git.jaeme@runbox.com
* gnu/packages/python-web.scm (python-requests-2.31): New variable.
* gnu/packages/python-web.scm (python-requests): Inherit from
python-requests-2.31.

Change-Id: I63aa988a03d198bbc010b56e8742b5d000caeaeb
---
gnu/packages/python-web.scm | 30 +++++++++++++++++++++++-------
1 file changed, 23 insertions(+), 7 deletions(-)

Toggle diff (62 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b2d67996a7..92d041e794 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3211,25 +3211,23 @@ (define-public python-beren
"@code{beren} provides a REST client for Orthanc, a DICOM server.")
(license license:gpl3+)))
-(define-public python-requests
+(define-public python-requests-2.31
(package
(name "python-requests")
- (version "2.28.1")
+ (version "2.31.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "requests" version))
(sha256
(base32
- "10vrr7bijzrypvms3g2sgz8vya7f9ymmcv423ikampgy0aqrjmbw"))))
- (build-system python-build-system)
+ "1qfidaynsrci4wymrw3srz8v1zy7xxpcna8sxpm91mwqixsmlb4l"))))
+ (build-system pyproject-build-system)
(propagated-inputs
(list python-certifi
python-charset-normalizer
python-idna
python-urllib3))
- (arguments
- ;; FIXME: Some tests require network access.
- '(#:tests? #f))
+ (arguments (list #:tests? #f))
(home-page "http://python-requests.org/")
(synopsis "Python HTTP library")
(description
@@ -3237,6 +3235,24 @@ (define-public python-requests
than Python’s urllib2 library.")
(license license:asl2.0)))
+(define-public python-requests
+ (package
+ (inherit python-requests-2.31)
+ (name "python-requests")
+ (version "2.28.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "requests" version))
+ (sha256
+ (base32
+ "10vrr7bijzrypvms3g2sgz8vya7f9ymmcv423ikampgy0aqrjmbw"))))
+ (build-system python-build-system) ; Tests require network access.
+ (propagated-inputs
+ (list python-certifi
+ python-charset-normalizer
+ python-idna
+ python-urllib3))))
+
(define-public python-requests-kerberos
(package
(name "python-requests-kerberos")
--
2.41.0
J
J
Jaeme Sifat wrote on 2 Jan 00:21 +0100
[PATCH 1/5] gnu: Add python-urllib3-2.
(address . 68197@debbugs.gnu.org)(name . Jaeme Sifat)(address . jaeme@runbox.com)
5de6a72f6c1c4f5a1d7af7f3b5416f20ca585e4f.1704150597.git.jaeme@runbox.com
* gnu/packages/python-web.scm (python-urllib3-2): New variable.
* gnu/packages/python-web.scm (python-urllib3): Inherit python-urllib3-2.

Change-Id: Ib96504a72eb6f4485a777854bd7580c4b092756a
---
gnu/packages/python-web.scm | 34 +++++++++++++++++++++++++---------
1 file changed, 25 insertions(+), 9 deletions(-)

Toggle diff (63 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 06b578dac7..b2d67996a7 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3597,8 +3597,31 @@ (define-public python-unalix
addon for removing tracking fields from URLs.")
(license license:lgpl3+)))
+(define-public python-urllib3-2
+ (package
+ (name "python-urllib3")
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "urllib3" version))
+ (sha256
+ (base32
+ "0m1dnpbw2dyxp7658v1fm37zzx5mb4n9p2g7i22ag3qln2pshynz"))))
+ (build-system pyproject-build-system)
+ (arguments `(#:tests? #f))
+ (native-inputs (list python-hatchling))
+ (home-page "https://urllib3.readthedocs.io/")
+ (synopsis "HTTP library with thread-safe connection pooling")
+ (description
+ "Urllib3 supports features left out of urllib and urllib2 libraries. It
+can reuse the same socket connection for multiple requests, it can POST files,
+supports url redirection and retries, and also gzip and deflate decoding.")
+ (license license:expat)))
+
(define-public python-urllib3
(package
+ (inherit python-urllib3-2)
(name "python-urllib3")
(version "1.26.15")
(source
@@ -3609,7 +3632,7 @@ (define-public python-urllib3
(base32
"01dkqv0rsjqyw4wrp6yj8h3bcnl7c678qkj845596vs7p4bqff4a"))))
(build-system python-build-system)
- (arguments `(#:tests? #f))
+ (native-inputs '())
(propagated-inputs
(append
;; These 5 inputs are used to build urrlib3[secure]
@@ -3623,14 +3646,7 @@ (define-public python-urllib3
(package-transitive-supported-systems python-pyopenssl))
(list python-pyopenssl)
'())
- (list python-pysocks)))
- (home-page "https://urllib3.readthedocs.io/")
- (synopsis "HTTP library with thread-safe connection pooling")
- (description
- "Urllib3 supports features left out of urllib and urllib2 libraries. It
-can reuse the same socket connection for multiple requests, it can POST files,
-supports url redirection and retries, and also gzip and deflate decoding.")
- (license license:expat)))
+ (list python-pysocks)))))
(define-public awscli
(package
--
2.41.0
J
J
Jaeme Sifat wrote on 2 Jan 00:21 +0100
[PATCH 3/5] gnu: yt-dlp: Update to 2023.11.16.
(address . 68197@debbugs.gnu.org)(name . Jaeme Sifat)(address . jaeme@runbox.com)
752aa1d5e4f9bb2b24d3d7600d1d158965ed14a5.1704150597.git.jaeme@runbox.com
* gnu/packages/video.scm (yt-dlp): Update to 2023.11.16.

Change-Id: Iae2428e13073bd43ec17dd30f6937d9fe4e96726
---
gnu/packages/video.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 6da4897a57..a234c7e6b9 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2753,7 +2753,7 @@ (define-public youtube-dl
(define-public yt-dlp
(package/inherit youtube-dl
(name "yt-dlp")
- (version "2023.10.13")
+ (version "2023.11.16")
(source
(origin
(method git-fetch)
@@ -2762,7 +2762,7 @@ (define-public yt-dlp
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1cy8cpqwq6yfsbrnln3qqp9lsjckn20m6w7b890ha7jahyir5m1n"))))
+ (base32 "0p6fx5dpd9za2xmqd35qimcmdpziiq26f3n58s14vly6jx5h5j31"))))
(arguments
(substitute-keyword-arguments (package-arguments youtube-dl)
((#:tests? _) (not (%current-target-system)))
@@ -2807,6 +2807,8 @@ (define-public yt-dlp
python-certifi
python-mutagen
python-pycryptodomex
+ python-requests-2.31
+ python-urllib3-2
python-websockets)))
(native-inputs
(append
--
2.41.0
J
J
Jaeme Sifat wrote on 2 Jan 00:21 +0100
[PATCH 5/5] gnu: yt-dlp: Update to 2023.12.30.
(address . 68197@debbugs.gnu.org)(name . Jaeme Sifat)(address . jaeme@runbox.com)
ba1bf214811fe98cb53ec796a55a02db422d0b0a.1704150597.git.jaeme@runbox.com
* gnu/packages/video.scm (yt-dlp): Update to 2023.12.30.

Change-Id: Ib9f7cc4894259628097f298c042a6a2c44482e2a
---
gnu/packages/video.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index a234c7e6b9..93f0ac70b1 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2753,7 +2753,7 @@ (define-public youtube-dl
(define-public yt-dlp
(package/inherit youtube-dl
(name "yt-dlp")
- (version "2023.11.16")
+ (version "2023.12.30")
(source
(origin
(method git-fetch)
@@ -2762,7 +2762,7 @@ (define-public yt-dlp
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0p6fx5dpd9za2xmqd35qimcmdpziiq26f3n58s14vly6jx5h5j31"))))
+ (base32 "0dyw158daziglwk102czvscfpcqkyqg0lfh9v81qxvsk9qr9ms82"))))
(arguments
(substitute-keyword-arguments (package-arguments youtube-dl)
((#:tests? _) (not (%current-target-system)))
@@ -2809,7 +2809,7 @@ (define-public yt-dlp
python-pycryptodomex
python-requests-2.31
python-urllib3-2
- python-websockets)))
+ python-websockets-12)))
(native-inputs
(append
;; To generate the manpage.
--
2.41.0
J
J
Jaeme Sifat wrote on 2 Jan 00:21 +0100
[PATCH 4/5] gnu: Add python-websockets-12.
(address . 68197@debbugs.gnu.org)(name . Jaeme Sifat)(address . jaeme@runbox.com)
53b0dff03e4b9107facb8da9a29075b9d4725d24.1704150597.git.jaeme@runbox.com
* gnu/packages/python-web.scm (python-websockets-12): New variable.

Change-Id: I5e4555098039d17db87f16f488e302cc27668898
---
gnu/packages/python-web.scm | 36 +++++++++++++++++++++++++-----------
1 file changed, 25 insertions(+), 11 deletions(-)

Toggle diff (58 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 92d041e794..35e9a027e9 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6335,8 +6335,32 @@ (define-public python-warcio
files.")
(license license:asl2.0))))
+(define-public python-websockets-12
+ (package
+ (name "python-websockets")
+ (version "12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "websockets" version))
+ (sha256
+ (base32 "06wbik9ksfbzafq0fla3r2pjvgpy3c0qrr87w3hhs9kcpfy9rpw1"))))
+ (build-system pyproject-build-system)
+ (arguments (list #:tests? #f))
+ (home-page "https://github.com/aaugustin/websockets")
+ (synopsis
+ "Python implementation of the WebSocket Protocol (RFC 6455 & 7692)")
+ (description
+ "@code{websockets} is a library for building WebSocket servers and clients
+in Python with a focus on correctness and simplicity.
+
+Built on top of @code{asyncio}, Python's standard asynchronous I/O framework,
+it provides an elegant coroutine-based API.")
+ (license license:bsd-3)))
+
(define-public python-websockets
(package
+ (inherit python-websockets-12)
(name "python-websockets")
(version "11.0.3")
(source
@@ -6355,17 +6379,7 @@ (define-public python-websockets
#~(modify-phases %standard-phases
(add-before 'check 'extend-test-timeout
(lambda _
- (setenv "WEBSOCKETS_TESTS_TIMEOUT_FACTOR" "10"))))))
- (home-page "https://github.com/aaugustin/websockets")
- (synopsis
- "Python implementation of the WebSocket Protocol (RFC 6455 & 7692)")
- (description
- "@code{websockets} is a library for building WebSocket servers and clients
-in Python with a focus on correctness and simplicity.
-
-Built on top of @code{asyncio}, Python's standard asynchronous I/O framework,
-it provides an elegant coroutine-based API.")
- (license license:bsd-3)))
+ (setenv "WEBSOCKETS_TESTS_TIMEOUT_FACTOR" "10"))))))))
(define-public python-selenium
(package
--
2.41.0
J
J
Jaeme Sifat wrote on 2 Jan 02:25 +0100
[PATCH v2REVISION 4/5] gnu: Add python-websockets-12.
(address . 68197@debbugs.gnu.org)(name . Jaeme Sifat)(address . jaeme@runbox.com)
eb44de1436b4c65e74f0610de2bbd89b16c885c1.1704158704.git.jaeme@runbox.com
* gnu/packages/python-web.scm (python-websockets-12): New variable.

Change-Id: I5e4555098039d17db87f16f488e302cc27668898
---
gnu/packages/python-web.scm | 36 +++++++++++++++++++++++++-----------
1 file changed, 25 insertions(+), 11 deletions(-)

Toggle diff (58 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 261277155a..2797f9ff49 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6336,8 +6336,32 @@ (define-public python-warcio
files.")
(license license:asl2.0))))
+(define-public python-websockets-12
+ (package
+ (name "python-websockets")
+ (version "12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "websockets" version))
+ (sha256
+ (base32 "06wbik9ksfbzafq0fla3r2pjvgpy3c0qrr87w3hhs9kcpfy9rpw1"))))
+ (build-system pyproject-build-system)
+ (arguments (list #:tests? #f))
+ (home-page "https://github.com/aaugustin/websockets")
+ (synopsis
+ "Python implementation of the WebSocket Protocol (RFC 6455 & 7692)")
+ (description
+ "@code{websockets} is a library for building WebSocket servers and clients
+in Python with a focus on correctness and simplicity.
+
+Built on top of @code{asyncio}, Python's standard asynchronous I/O framework,
+it provides an elegant coroutine-based API.")
+ (license license:bsd-3)))
+
(define-public python-websockets
(package
+ (inherit python-websockets-12)
(name "python-websockets")
(version "11.0.3")
(source
@@ -6356,17 +6380,7 @@ (define-public python-websockets
#~(modify-phases %standard-phases
(add-before 'check 'extend-test-timeout
(lambda _
- (setenv "WEBSOCKETS_TESTS_TIMEOUT_FACTOR" "10"))))))
- (home-page "https://github.com/aaugustin/websockets")
- (synopsis
- "Python implementation of the WebSocket Protocol (RFC 6455 & 7692)")
- (description
- "@code{websockets} is a library for building WebSocket servers and clients
-in Python with a focus on correctness and simplicity.
-
-Built on top of @code{asyncio}, Python's standard asynchronous I/O framework,
-it provides an elegant coroutine-based API.")
- (license license:bsd-3)))
+ (setenv "WEBSOCKETS_TESTS_TIMEOUT_FACTOR" "10"))))))))
(define-public python-selenium
(package
--
2.41.0
J
J
Jaeme Sifat wrote on 2 Jan 02:25 +0100
[PATCH v2REVISION 1/5] gnu: Add python-urllib3-2.
(address . 68197@debbugs.gnu.org)(name . Jaeme Sifat)(address . jaeme@runbox.com)
c547466449ecde7781a423d604afd3b8327e419f.1704158703.git.jaeme@runbox.com
* gnu/packages/python-web.scm (python-urllib3-2): New variable.
* gnu/packages/python-web.scm (python-urllib3): Inherit python-urllib3-2.

Change-Id: Ib96504a72eb6f4485a777854bd7580c4b092756a
---
gnu/packages/python-web.scm | 35 ++++++++++++++++++++++++++---------
1 file changed, 26 insertions(+), 9 deletions(-)

Toggle diff (73 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 06b578dac7..cd5cac4f44 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -60,6 +60,7 @@
;;; Copyright © 2022 Baptiste Strazzulla <bstrazzull@hotmail.fr>
;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2023 Ivan Vilata-i-Balaguer <ivan@selidor.net>
+;;; Copyright © 2024 Jaeme Sifat <jaeme@runbox.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3597,8 +3598,31 @@ (define-public python-unalix
addon for removing tracking fields from URLs.")
(license license:lgpl3+)))
+(define-public python-urllib3-2
+ (package
+ (name "python-urllib3")
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "urllib3" version))
+ (sha256
+ (base32
+ "0m1dnpbw2dyxp7658v1fm37zzx5mb4n9p2g7i22ag3qln2pshynz"))))
+ (build-system pyproject-build-system)
+ (arguments `(#:tests? #f))
+ (native-inputs (list python-hatchling))
+ (home-page "https://urllib3.readthedocs.io/")
+ (synopsis "HTTP library with thread-safe connection pooling")
+ (description
+ "Urllib3 supports features left out of urllib and urllib2 libraries. It
+can reuse the same socket connection for multiple requests, it can POST files,
+supports url redirection and retries, and also gzip and deflate decoding.")
+ (license license:expat)))
+
(define-public python-urllib3
(package
+ (inherit python-urllib3-2)
(name "python-urllib3")
(version "1.26.15")
(source
@@ -3609,7 +3633,7 @@ (define-public python-urllib3
(base32
"01dkqv0rsjqyw4wrp6yj8h3bcnl7c678qkj845596vs7p4bqff4a"))))
(build-system python-build-system)
- (arguments `(#:tests? #f))
+ (native-inputs '())
(propagated-inputs
(append
;; These 5 inputs are used to build urrlib3[secure]
@@ -3623,14 +3647,7 @@ (define-public python-urllib3
(package-transitive-supported-systems python-pyopenssl))
(list python-pyopenssl)
'())
- (list python-pysocks)))
- (home-page "https://urllib3.readthedocs.io/")
- (synopsis "HTTP library with thread-safe connection pooling")
- (description
- "Urllib3 supports features left out of urllib and urllib2 libraries. It
-can reuse the same socket connection for multiple requests, it can POST files,
-supports url redirection and retries, and also gzip and deflate decoding.")
- (license license:expat)))
+ (list python-pysocks)))))
(define-public awscli
(package

base-commit: ee0cf3b9ff4cd5a9d3637d09677195ea9ee1a8c0
--
2.41.0
J
J
Jaeme Sifat wrote on 2 Jan 02:25 +0100
[PATCH v2REVISION 5/5] gnu: yt-dlp: Update to 2023.12.30.
(address . 68197@debbugs.gnu.org)(name . Jaeme Sifat)(address . jaeme@runbox.com)
b3fb23fe9f19efe9fda0d450ce3628e865f69f9c.1704158704.git.jaeme@runbox.com
* gnu/packages/video.scm (yt-dlp): Update to 2023.12.30.

Change-Id: Ib9f7cc4894259628097f298c042a6a2c44482e2a
---
gnu/packages/video.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index ca1904614c..d0647adf5b 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2753,7 +2753,7 @@ (define-public youtube-dl
(define-public yt-dlp
(package/inherit youtube-dl
(name "yt-dlp")
- (version "2023.11.16")
+ (version "2023.12.30")
(source
(origin
(method git-fetch)
@@ -2762,7 +2762,7 @@ (define-public yt-dlp
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0p6fx5dpd9za2xmqd35qimcmdpziiq26f3n58s14vly6jx5h5j31"))))
+ (base32 "0dyw158daziglwk102czvscfpcqkyqg0lfh9v81qxvsk9qr9ms82"))))
(arguments
(substitute-keyword-arguments (package-arguments youtube-dl)
((#:tests? _) (not (%current-target-system)))
@@ -2809,7 +2809,7 @@ (define-public yt-dlp
python-pycryptodomex
python-requests-2.31
python-urllib3-2
- python-websockets)))
+ python-websockets-12)))
(native-inputs
(append
;; To generate the manpage.
--
2.41.0
J
J
Jaeme Sifat wrote on 2 Jan 02:25 +0100
[PATCH v2REVISION 3/5] gnu: yt-dlp: Update to 2023.11.16.
(address . 68197@debbugs.gnu.org)(name . Jaeme Sifat)(address . jaeme@runbox.com)
8842418a3657fa3d2053d361d9d731fc4651dfbd.1704158703.git.jaeme@runbox.com
* gnu/packages/video.scm (yt-dlp): Update to 2023.11.16.

Change-Id: Iae2428e13073bd43ec17dd30f6937d9fe4e96726
---
gnu/packages/video.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 6da4897a57..ca1904614c 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -66,7 +66,7 @@
;;; Copyright © 2023 Ott Joon <oj@vern.cc>
;;; Copyright © 2023 Dominik Delgado Steuter <dds@disroot.org>
;;; Copyright © 2023 Saku Laesvuori <saku@laesvuori.fi>
-;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
+;;; Copyright © 2023, 2024 Jaeme Sifat <jaeme@runbox.com>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
@@ -2753,7 +2753,7 @@ (define-public youtube-dl
(define-public yt-dlp
(package/inherit youtube-dl
(name "yt-dlp")
- (version "2023.10.13")
+ (version "2023.11.16")
(source
(origin
(method git-fetch)
@@ -2762,7 +2762,7 @@ (define-public yt-dlp
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1cy8cpqwq6yfsbrnln3qqp9lsjckn20m6w7b890ha7jahyir5m1n"))))
+ (base32 "0p6fx5dpd9za2xmqd35qimcmdpziiq26f3n58s14vly6jx5h5j31"))))
(arguments
(substitute-keyword-arguments (package-arguments youtube-dl)
((#:tests? _) (not (%current-target-system)))
@@ -2807,6 +2807,8 @@ (define-public yt-dlp
python-certifi
python-mutagen
python-pycryptodomex
+ python-requests-2.31
+ python-urllib3-2
python-websockets)))
(native-inputs
(append
--
2.41.0
J
J
Jaeme Sifat wrote on 2 Jan 02:25 +0100
[PATCH v2REVISION 2/5] gnu: Add python-requests-2.31.
(address . 68197@debbugs.gnu.org)(name . Jaeme Sifat)(address . jaeme@runbox.com)
3381e1e549e5aec6f4c8c95c98edbf4faa081f71.1704158703.git.jaeme@runbox.com
* gnu/packages/python-web.scm (python-requests-2.31): New variable.
* gnu/packages/python-web.scm (python-requests): Inherit from
python-requests-2.31.

Change-Id: I63aa988a03d198bbc010b56e8742b5d000caeaeb
---
gnu/packages/python-web.scm | 30 +++++++++++++++++++++++-------
1 file changed, 23 insertions(+), 7 deletions(-)

Toggle diff (62 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index cd5cac4f44..261277155a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3212,25 +3212,23 @@ (define-public python-beren
"@code{beren} provides a REST client for Orthanc, a DICOM server.")
(license license:gpl3+)))
-(define-public python-requests
+(define-public python-requests-2.31
(package
(name "python-requests")
- (version "2.28.1")
+ (version "2.31.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "requests" version))
(sha256
(base32
- "10vrr7bijzrypvms3g2sgz8vya7f9ymmcv423ikampgy0aqrjmbw"))))
- (build-system python-build-system)
+ "1qfidaynsrci4wymrw3srz8v1zy7xxpcna8sxpm91mwqixsmlb4l"))))
+ (build-system pyproject-build-system)
(propagated-inputs
(list python-certifi
python-charset-normalizer
python-idna
python-urllib3))
- (arguments
- ;; FIXME: Some tests require network access.
- '(#:tests? #f))
+ (arguments (list #:tests? #f))
(home-page "http://python-requests.org/")
(synopsis "Python HTTP library")
(description
@@ -3238,6 +3236,24 @@ (define-public python-requests
than Python’s urllib2 library.")
(license license:asl2.0)))
+(define-public python-requests
+ (package
+ (inherit python-requests-2.31)
+ (name "python-requests")
+ (version "2.28.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "requests" version))
+ (sha256
+ (base32
+ "10vrr7bijzrypvms3g2sgz8vya7f9ymmcv423ikampgy0aqrjmbw"))))
+ (build-system python-build-system) ; Tests require network access.
+ (propagated-inputs
+ (list python-certifi
+ python-charset-normalizer
+ python-idna
+ python-urllib3))))
+
(define-public python-requests-kerberos
(package
(name "python-requests-kerberos")
--
2.41.0
I
I
Ian Eure wrote on 13 Mar 00:23 +0100
Re: [PATCH 0/5] gnu: yt-dlp: Update to 2023.12.30
87v85rui2c.fsf@meson
Hi, thanks for doing this.

Few things:

I don’t think it makes sense to add version 2023.11.16 in one
patch, then replace it with 2023.12.13 in the next. I’d go
straight to 2023.03.10, which was just released.

Do you know how many packages python-requests would require
rebuilding? Since it’s a minor version bump, I’d expect it
wouldn’t break builds, just require a lot of rebuilds, since it’s
a fairly popular library. If possible, I think we should update
and rebuild instead of adding a second version.

It’s not clear to me why urllib3 2.x is getting added. The
requirements for 2023.12.13[1] say that 1.26.17 or newer is
acceptable; 1.26.15 is in Guix presently. It seems inadvisable to
use a library with a major version greater than yt-dlp expects. I
think it’d be simpler to update to 1.26.18 (the latest 1.x
release) and not maintain two versions. It looks like this was
last updated around a year ago, in commit
3e8d608dac2eb9f387431bd8976f78de9ea7a701, and I don’t see anything
special about that, so that makes me think this would be a
relatively safe course.

Toggle quote (20 lines)
> - (arguments
> - ;; FIXME: Some tests require network access.
> - '(#:tests? #f))
> + (arguments (list #:tests? #f))

> +(define-public python-requests
> + (package
> + (inherit python-requests-2.31)
> + (name "python-requests")
> + (version "2.28.1")
> + (source (origin
> + (method url-fetch)
> + (uri (pypi-uri "requests" version))
> + (sha256
> + (base32
> +
> "10vrr7bijzrypvms3g2sgz8vya7f9ymmcv423ikampgy0aqrjmbw"))))
> + (build-system python-build-system) ; Tests require network
> access.

Looks like this comment migrated away from the context it’s
helpful for.


Toggle quote (7 lines)
> @@ -3609,7 +3632,7 @@ (define-public python-urllib3
> (base32
> "01dkqv0rsjqyw4wrp6yj8h3bcnl7c678qkj845596vs7p4bqff4a"))))
> (build-system python-build-system)
> - (arguments `(#:tests? #f))
> + (native-inputs '())

A comment on the empty (native-inputs) would be good, I think.

(I’m not a Guix committer, so I can’t actually move this forward /
my thoughts are just my own. I’d just like to see a yt-dlp
update.)

Thanks,

— Ian

[1]:
?