[PATCH] gnu: Add python-portend.

  • Done
  • quality assurance status badge
Details
3 participants
  • Mathieu Othacehe
  • Sharlatan Hellseher
  • Troy Figiel
Owner
unassigned
Submitted by
Troy Figiel
Severity
normal
T
T
Troy Figiel wrote on 1 Jan 18:53 +0100
(address . guix-patches@gnu.org)
87zfxpdje3.fsf@troyfigiel.com
* gnu/packages/python-web.scm (python-portend): New variable.
---
gnu/packages/python-web.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 06b578dac7..8eed01c3e2 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -60,6 +60,7 @@
;;; Copyright © 2022 Baptiste Strazzulla <bstrazzull@hotmail.fr>
;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2023 Ivan Vilata-i-Balaguer <ivan@selidor.net>
+;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -201,6 +202,38 @@ (define-public python-lazr-uri
reusable library for parsing, manipulating, and generating URIs.")
(license license:lgpl3)))
+(define-public python-portend
+ (package
+ (name "python-portend")
+ (version "3.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "portend" version))
+ (sha256
+ (base32 "0wpvixicc3d0lack65554mvdrrckkn18p1xcgiv9v5cwq59a6l2j"))))
+ (build-system pyproject-build-system)
+ ;; Do not test pyproject.toml with python-pytest-checkdocs as it tries to
+ ;; download dependencies.
+ (arguments
+ '(#:test-flags '("-k" "not project")))
+ (propagated-inputs (list python-tempora))
+ ;; TODO: Add python-pytest-ruff to native-inputs once it has been packaged.
+ (native-inputs (list python-pytest
+ python-pytest-black
+ python-pytest-checkdocs
+ python-pytest-cov
+ python-pytest-enabler
+ python-pytest-mypy))
+ (home-page "https://github.com/jaraco/portend")
+ (synopsis "Monitor TCP ports for bound or unbound states")
+ (description
+ "@code{python-portend} can be used to monitor TCP ports for bound or
+unbound states. For example, waiting for a port to be occupied or freed
+within a set timeout. @code{python-portend} can also be used directly from
+the command line.")
+ (license license:expat)))
+
(define-public python-prawcore
(package
(name "python-prawcore")

base-commit: ff586211aaf0e3b468ff3cedc5ede18e8ab529dd
--
2.40.1
S
S
Sharlatan Hellseher wrote on 4 Jan 17:10 +0100
(address . 68191@debbugs.gnu.org)
CAO+9K5o70Jadbkg3XH7jZPSD5f17B_4NvrCpLXG825M5FR93sA@mail.gmail.com
Hi,
It looks good to me, passed all phases from comiit:
guix describe
Generation 498 Jan 04 2024 10:55:58 (current)
guix 7b0863f
branch: master
commit: 7b0863f07a113caef26fea13909bd97d250b629e
guix build --quiet --rounds=2 -L . python-portend
/gnu/store/gl6n6pbk5y1hxv6s8xrj02j0lw41a4ll-python-portend-3.2.0
guix lint -L . python-portend
etching CVE database for 2024...e]...
fetching CVE database for 2023...
fetching CVE database for 2022...
./ffab/packages/python-xyz.scm:557:5: python-portend@3.2.0: source not
archived on Software Heritage and missing from the Disarchive database
It would be nice to start packing python-ruff as it's required for
python-huggingface-hub
which I try to bring to Guix.
Thanks,
Oleg
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
T
T
Troy Figiel wrote on 7 Jan 11:33 +0100
(address . 68191@debbugs.gnu.org)
878r51xwkb.fsf@troyfigiel.com
Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (28 lines)
> Hi,
>
> It looks good to me, passed all phases from comiit:
>
> guix describe
> Generation 498 Jan 04 2024 10:55:58 (current)
> guix 7b0863f
> repository URL: https://git.savannah.gnu.org/git/guix.git
> branch: master
> commit: 7b0863f07a113caef26fea13909bd97d250b629e
>
> guix build --quiet --rounds=2 -L . python-portend
> /gnu/store/gl6n6pbk5y1hxv6s8xrj02j0lw41a4ll-python-portend-3.2.0
>
> guix lint -L . python-portend
> etching CVE database for 2024...e]...
> fetching CVE database for 2023...
> fetching CVE database for 2022...
> ./ffab/packages/python-xyz.scm:557:5: python-portend@3.2.0: source not
> archived on Software Heritage and missing from the Disarchive database
>
> It would be nice to start packing python-ruff as it's required for
> python-huggingface-hub
> which I try to bring to Guix.
>
> Thanks,
> Oleg

Hi Oleg,

I have been looking at python-ruff for a bit now. Since it is a Python
package with Rust bindings, it will require a bit more experience
packaging Rust from my side. Plus, we will likely have to add a fair
number of Rust crates first, due to the sheer amount of dependencies.

I was planning to start packaging some of these Rust dependencies, since
we would need these anyway for a recent version of Ruff and the Rust
ecosystem might benefit along the way.

Best wishes,

Troy
S
S
Sharlatan Hellseher wrote on 7 Jan 16:51 +0100
(address . 68191@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
CAO+9K5qe7M3f+YDffoF_YzpK6-a4QJ5P_vcPQ+5zogHdnsrcuQ@mail.gmail.com
Pinging Rust-team here, some of the packages might be coveted already.

Thanks,
Oleg
Attachment: file
M
M
Mathieu Othacehe wrote on 9 Jan 10:06 +0100
(name . Troy Figiel)(address . troy@troyfigiel.com)(address . 68191-done@debbugs.gnu.org)
87sf36dgfn.fsf@gnu.org
Toggle quote (2 lines)
> * gnu/packages/python-web.scm (python-portend): New variable.

Applied, thanks,

Mathieu
Closed
?