(address . bug-guix@gnu.org)
Hello Guix!
Running 'guix lint somepackage' fails on new years day with the below
backtrace. It seems like it's trying to download the CVE database for
2024, which doesn't exist yet.
==== Backtrace ====
user@PC ~/Devel/Scheme/Guix/guix [env]$ ./pre-inst-env guix lint durden
;;; note: source file
/home/user/Devel/Scheme/Guix/guix/gnu/packages/arcan.scm
;;; newer than compiled
/home/user/Devel/Scheme/Guix/guix/gnu/packages/arcan.go
checking durden@0.6.1-1.a8938b9 [source]...
Backtrace:urden@0.6.1-1.a8938b9 [cve]...
In ice-9/boot-9.scm:
724:2 19 (call-with-prompt _ _ #<procedure default-prompt-handle?>)
In ice-9/eval.scm:
619:8 18 (_ #(#(#<directory (guile-user) 7f8f4e5fcc80>)))
In guix/ui.scm:
2324:7 17 (run-guix . _)
2287:10 16 (run-guix-command _ . _)
In ice-9/boot-9.scm:
1752:10 15 (with-exception-handler _ _ #:unwind? _ # _)
1752:10 14 (with-exception-handler _ _ #:unwind? _ # _)
In guix/store.scm:
661:37 13 (thunk)
In srfi/srfi-1.scm:
634:9 12 (for-each #<procedure 7f8f2f135180 at guix/scripts/lin?> ?)
In guix/scripts/lint.scm:
65:4 11 (run-checkers _ _ #:store _)
In srfi/srfi-1.scm:
634:9 10 (for-each #<procedure 7f8f2f12e780 at guix/scripts/lin?> ?)
In guix/scripts/lint.scm:
74:21 9 (_ _)
In guix/lint.scm:
1547:4 8 (check-vulnerabilities #<package durden@0.6.1-1.a8938b?> ?)
1536:10 7 (_ _)
In unknown file:
6 (force #<promise #<procedure 7f8f43960138 at guix/lint.?>)
In guix/lint.scm:
1519:2 5 (_)
877:2 4 (call-with-networking-fail-safe _ _ _)
In ice-9/boot-9.scm:
1752:10 3 (with-exception-handler _ _ #:unwind? _ # _)
1685:16 2 (raise-exception _ #:continuable? _)
1683:16 1 (raise-exception _ #:continuable? _)
1685:16 0 (raise-exception _ #:continuable? _)
ice-9/boot-9.scm:1685:16: In procedure raise-exception:
ERROR:
1. &http-get-error:
uri: #<<uri> scheme: https userinfo: #f host: "nvd.nist.gov"
port: #f path: "/feeds/json/cve/1.1/nvdcve-1.1-2024.json.gz" query: #f
fragment: #f>
code: 404
reason: "Not Found"
headers: ((x-frame-options . "SAMEORIGIN")
(content-security-policy . "frame-ancestors 'self'") (date . #<date
nanosecond: 0 second: 2 minute: 10 hour: 6 day: 1 month: 1 year: 2024
zone-offset: 0>) (content-length . 0) (strict-transport-security .
"max-age=31536000") (connection close))
2. &message:
download failed: 404 (\"Not Found\")"
user@PC ~/Devel/Scheme/Guix/guix [env]$
==== Backtrace End ====