[PATCH] gnu: swig-next: Update to 4.2.0

  • Done
  • quality assurance status badge
Details
2 participants
  • Andy Tai
  • Andy Tai
Owner
unassigned
Submitted by
Andy Tai
Severity
normal

Debbugs page

Andy Tai wrote 1 years ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
7542ab97dce90e01b16b1e698247f5607fd02922.1704057359.git.atai@atai.org
* gnu/packages/swig.scm (swig-next): Update to 4.2.0

Change-Id: Ic6580f0d2c3ab578de6bc0bd9a98c61b28cc1cd6
---
gnu/packages/swig.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/swig.scm b/gnu/packages/swig.scm
index 3f38cd9f9f..7025d05038 100644
--- a/gnu/packages/swig.scm
+++ b/gnu/packages/swig.scm
@@ -79,7 +79,7 @@ (define-public swig-next
(package
(inherit swig)
(name "swig")
- (version "4.1.1")
+ (version "4.2.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/" name "/" name "/"
@@ -87,5 +87,5 @@ (define-public swig-next
name "-" version ".tar.gz"))
(sha256
(base32
- "16xc767gf5ip40jh698wbdrxrghli5v2c966bkdmrmpwv378mw1a"))))
+ "15wwh9215rdkflpr85r7zxr2nmrib03jr4bvh5i0f9lyb3bs4716"))))
(inputs (list pcre2))))

base-commit: 2a242e86379ebddbdddf2927f26e5e27a98fc605
--
2.41.0
Andy Tai wrote 1 years ago
[PATCH v3] gnu: inkscape: Update to 1.2.2
(address . 68184@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
7509c2b015d9b8a44cbab1329c24a83c65b1cb97.1707808025.git.atai@atai.org
* gnu/packages/inkscape.scm (inkscape): Update to 1.2.2
[sources](patches): Redefine to empty
[inputs]: Add gspell, lib2geom, readline

Change-Id: Ief74d289365f818e28f7afc02faea782e49d1c02
---
gnu/packages/inkscape.scm | 16 +++++++++++++---
1 file changed, 13 insertions(+), 3 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index aa2c6419a0..8a107301ac 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -50,6 +50,7 @@ (define-module (gnu packages inkscape)
#:use-module (gnu packages python)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages readline)
#:use-module (gnu packages xml)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages fontutils)
@@ -286,7 +287,7 @@ (define-public inkscape
(package
(inherit inkscape/stable)
(name "inkscape")
- (version "1.2.1")
+ (version "1.2.2")
(source
(origin
(inherit (package-source inkscape/stable))
@@ -294,13 +295,18 @@ (define-public inkscape
(uri (string-append "https://media.inkscape.org/dl/"
"resources/file/"
"inkscape-" version ".tar.xz"))
+ (patches '()) ; does not use patch from inkscape/stable; redefine to empty list
(sha256
- (base32 "06scilds4p4bw337ss22nfdxy2kynv5yjw6vq6nlpjm7xfh7vkj6"))))
+ (base32 "1i55x0zbmwgvcl8fai9m3zy7rpc0rwfk1vs8wqsib8n00c6zvix0"))))
(build-system cmake-build-system)
(arguments
(substitute-keyword-arguments (package-arguments inkscape/stable)
((#:phases phases)
`(modify-phases ,phases
+ (add-after 'unpack 'fix-unaliased-2geom-reference
+ (lambda _
+ (substitute* (find-files "." "CMakeLists.txt")
+ (("2Geom::2geom") "2geom"))))
(replace 'wrap-program
;; Ensure Python is available at runtime.
(lambda* (#:key outputs #:allow-other-keys)
@@ -313,5 +319,9 @@ (define-public inkscape
`("GDK_PIXBUF_MODULE_FILE" =
(,(getenv "GDK_PIXBUF_MODULE_FILE")))))))))))
(inputs (modify-inputs (package-inputs inkscape/stable)
- (append python-cssselect))) ;to render qrcode
+ (append
+ gspell
+ lib2geom
+ python-cssselect ;to render qrcode
+ readline)))
(properties (alist-delete 'hidden? (package-properties inkscape/stable)))))

base-commit: 5f86eebd240958001ab4f178005f355d24d9b7f1
--
2.34.1
Andy Tai wrote 1 years ago
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
CAJsg1E8Q4rBzRPqtLRF=RWb3uaAgC+-OfNOQiO1v_9Zp7JLuMA@mail.gmail.com
close 68184
thanks
patch applied already
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68184@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68184
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help