[PATCH 0/9] Add guix-home config to /etc/skel

  • Done
  • quality assurance status badge
Details
One participant
  • Efraim Flashner
Owner
unassigned
Submitted by
Efraim Flashner
Severity
normal

Debbugs page

Efraim Flashner wrote 1 years ago
(address . guix-patches@gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
cover.1704021933.git.efraim@flashner.co.il
A couple of things happening in this patchset:

* Extracting the config files from (default-skeletons) and exposing them
so they can be exported. This allows people to add them directly to
their home configs without re-defining them.

* Syncs .zprofile between (gnu system shadow) and (gnu home services
shell) so there's no surprises about the contents of the config.

Remove duplicate lines which exist in .bashrc/.zprofile and /etc/profile

add an extremely basic guix-home.scm to /etc/skel so it's available as a
starting point if people want to use it.

Efraim Flashner (9):
system: Export default bash-profile.
system: Export default zprofile.
system: Export default xdefaults.
system: Export default gdbinit.
system: Export default nanorc.
system: Export default guile config.
system: Add default guix-home-config.
system: default-zprofile: Sync with home zprofile.
home: services: zsh: Use unified zprofile.

gnu/home/services/shells.scm | 8 +--
gnu/system/shadow.scm | 116 +++++++++++++++++++++++++----------
2 files changed, 85 insertions(+), 39 deletions(-)


base-commit: 9d148d08be9d77781e8103915b1f498b03fd3dd2
prerequisite-patch-id: ebb16926043f4377669a042730dddd7e9c4d7a39
--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
Efraim Flashner wrote 1 years ago
[PATCH 1/9] system: Export default bash-profile.
(address . 68169@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
46f070e31135c8fe39b28cef4c58e54ec99d5f13.1704021933.git.efraim@flashner.co.il
gnu/system/shadow.scm (%default-bash-profile): Extract from
default-skeletons, export.
(default-skeletons): Use %default-bash-profile.

Change-Id: I45641b1091daee3495a5f92bdc1a63050e0cc59e
---
gnu/system/shadow.scm | 14 +++++++++-----
1 file changed, 9 insertions(+), 5 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/system/shadow.scm b/gnu/system/shadow.scm
index 47f19551b6..cd4e1a9156 100644
--- a/gnu/system/shadow.scm
+++ b/gnu/system/shadow.scm
@@ -64,6 +64,7 @@ (define-module (gnu system shadow)
user-group-system?)
#:export (%default-bashrc
+ %default-bash-profile
default-skeletons
skeleton-directory
%base-groups
@@ -147,11 +148,8 @@ (define %default-bashrc
alias grep='grep --color=auto'
alias ip='ip -color=auto'\n"))
-(define (default-skeletons)
- "Return the default skeleton files for /etc/skel. These files are copied by
-'useradd' in the home directory of newly created user accounts."
-
- (let ((profile (plain-file "bash_profile" "\
+(define %default-bash-profile
+ (plain-file "bash_profile" "\
# Set up Guix Home profile
if [ -f ~/.profile ]; then . ~/.profile; fi
@@ -167,6 +165,12 @@ (define (default-skeletons)
# Prepend setuid programs.
export PATH=/run/setuid-programs:$PATH
"))
+
+(define (default-skeletons)
+ "Return the default skeleton files for /etc/skel. These files are copied by
+'useradd' in the home directory of newly created user accounts."
+
+ (let ((profile %default-bash-profile)
(bashrc %default-bashrc)
(zprofile (plain-file "zprofile" "\
# Honor system-wide environment variables
--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
Efraim Flashner wrote 1 years ago
[PATCH 2/9] system: Export default zprofile.
(address . 68169@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
89274dd664f5c6316dfbb387e6e39e11ad96efa6.1704021933.git.efraim@flashner.co.il
* gnu/system/shadow.scm (%default-zprofile): Extract from
default-skeletons, export.
(default-skeletons): Use %default-zprofile.

Change-Id: I6c6e158bca2e462a2eae709fbc2c25a2c7f3f8b4
---
gnu/system/shadow.scm | 34 +++++++++++++++++++---------------
1 file changed, 19 insertions(+), 15 deletions(-)

Toggle diff (60 lines)
diff --git a/gnu/system/shadow.scm b/gnu/system/shadow.scm
index cd4e1a9156..9b1678c54d 100644
--- a/gnu/system/shadow.scm
+++ b/gnu/system/shadow.scm
@@ -65,6 +65,7 @@ (define-module (gnu system shadow)
#:export (%default-bashrc
%default-bash-profile
+ %default-zprofile
default-skeletons
skeleton-directory
%base-groups
@@ -166,25 +167,28 @@ (define %default-bash-profile
export PATH=/run/setuid-programs:$PATH
"))
+(define %default-zprofile
+ (plain-file "zprofile" "\
+# Honor system-wide environment variables
+source /etc/profile
+
+# Merge search-paths from multiple profiles, the order matters.
+eval \"$(guix package --search-paths \\
+-p $HOME/.config/guix/current \\
+-p $HOME/.guix-profile \\
+-p /run/current-system/profile)\"
+
+# Prepend setuid programs.
+export PATH=/run/setuid-programs:$PATH
+"))
+
(define (default-skeletons)
"Return the default skeleton files for /etc/skel. These files are copied by
'useradd' in the home directory of newly created user accounts."
- (let ((profile %default-bash-profile)
- (bashrc %default-bashrc)
- (zprofile (plain-file "zprofile" "\
-# Honor system-wide environment variables
-source /etc/profile
-
-# Merge search-paths from multiple profiles, the order matters.
-eval \"$(guix package --search-paths \\
--p $HOME/.config/guix/current \\
--p $HOME/.guix-profile \\
--p /run/current-system/profile)\"
-
-# Prepend setuid programs.
-export PATH=/run/setuid-programs:$PATH
-"))
+ (let ((profile %default-bash-profile)
+ (bashrc %default-bashrc)
+ (zprofile %default-zprofile)
(xdefaults (plain-file "Xdefaults" "\
XTerm*utf8: always
XTerm*metaSendsEscape: true\n"))
--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
Efraim Flashner wrote 1 years ago
[PATCH 3/9] system: Export default xdefaults.
(address . 68169@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
0a965b5c16b336d01eeb78d2a997a6d81fad6167.1704021933.git.efraim@flashner.co.il
* gnu/system/shadow.scm (%default-xdefaults): Extract from
default-skeletons, export.
(default-skeletons): Use %default-xdefaults.

Change-Id: I44018516ec3687a68d32ca5c86c41bc29507a273
---
gnu/system/shadow.scm | 10 +++++++---
1 file changed, 7 insertions(+), 3 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/system/shadow.scm b/gnu/system/shadow.scm
index 9b1678c54d..be7c4370a2 100644
--- a/gnu/system/shadow.scm
+++ b/gnu/system/shadow.scm
@@ -66,6 +66,7 @@ (define-module (gnu system shadow)
#:export (%default-bashrc
%default-bash-profile
%default-zprofile
+ %default-xdefaults
default-skeletons
skeleton-directory
%base-groups
@@ -182,6 +183,11 @@ (define %default-zprofile
export PATH=/run/setuid-programs:$PATH
"))
+(define %default-xdefaults
+ (plain-file "Xdefaults" "\
+XTerm*utf8: always
+XTerm*metaSendsEscape: true\n"))
+
(define (default-skeletons)
"Return the default skeleton files for /etc/skel. These files are copied by
'useradd' in the home directory of newly created user accounts."
@@ -189,9 +195,7 @@ (define (default-skeletons)
(let ((profile %default-bash-profile)
(bashrc %default-bashrc)
(zprofile %default-zprofile)
- (xdefaults (plain-file "Xdefaults" "\
-XTerm*utf8: always
-XTerm*metaSendsEscape: true\n"))
+ (xdefaults %default-xdefaults)
(gdbinit (plain-file "gdbinit" "\
# Tell GDB where to look for separate debugging files.
guile
--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
Efraim Flashner wrote 1 years ago
[PATCH 4/9] system: Export default gdbinit.
(address . 68169@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
d55f9ce186a2e406af46cf83346db825db7e9452.1704021933.git.efraim@flashner.co.il
* gnu/system/shadow.scm (%default-gdbinit): Extract from
default-skeletons, export.
(default-skeletons): Use %default-gdbinit.

Change-Id: Ia5188f8083a83ad4cdb96e234dbd730b1bfe0072
---
gnu/system/shadow.scm | 26 +++++++++++++++-----------
1 file changed, 15 insertions(+), 11 deletions(-)

Toggle diff (55 lines)
diff --git a/gnu/system/shadow.scm b/gnu/system/shadow.scm
index be7c4370a2..e1dd31262a 100644
--- a/gnu/system/shadow.scm
+++ b/gnu/system/shadow.scm
@@ -67,6 +67,7 @@ (define-module (gnu system shadow)
%default-bash-profile
%default-zprofile
%default-xdefaults
+ %default-gdbinit
default-skeletons
skeleton-directory
%base-groups
@@ -188,16 +189,9 @@ (define %default-xdefaults
XTerm*utf8: always
XTerm*metaSendsEscape: true\n"))
-(define (default-skeletons)
- "Return the default skeleton files for /etc/skel. These files are copied by
-'useradd' in the home directory of newly created user accounts."
-
- (let ((profile %default-bash-profile)
- (bashrc %default-bashrc)
- (zprofile %default-zprofile)
- (xdefaults %default-xdefaults)
- (gdbinit (plain-file "gdbinit" "\
-# Tell GDB where to look for separate debugging files.
+(define %default-gdbinit
+ (plain-file "gdbinit"
+ "# Tell GDB where to look for separate debugging files.
guile
(use-modules (gdb))
(execute (string-append \"set debug-file-directory \"
@@ -215,7 +209,17 @@ (define (default-skeletons)
# Authorize extensions found in the store, such as the
# pretty-printers of libstdc++.
-set auto-load safe-path /gnu/store/*/lib\n")))
+set auto-load safe-path /gnu/store/*/lib\n"))
+
+(define (default-skeletons)
+ "Return the default skeleton files for /etc/skel. These files are copied by
+'useradd' in the home directory of newly created user accounts."
+
+ (let ((profile %default-bash-profile)
+ (bashrc %default-bashrc)
+ (zprofile %default-zprofile)
+ (xdefaults %default-xdefaults)
+ (gdbinit %default-gdbinit))
`((".bash_profile" ,profile)
(".bashrc" ,bashrc)
;; Zsh sources ~/.zprofile before ~/.zshrc, and it sources ~/.zlogin
--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
Efraim Flashner wrote 1 years ago
[PATCH 5/9] system: Export default nanorc.
(address . 68169@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
edf6700d0d6ae3a403a826dd08507916eb284f6e.1704021933.git.efraim@flashner.co.il
* gnu/system/shadow.scm (%default-nanorc): Extract from
default-skeletons, export.
(default-skeletons): Use %default-nanorc.

Change-Id: I0d07b13ed4894b1152a08b96d9ef8527dde073ce
---
gnu/system/shadow.scm | 10 +++++++---
1 file changed, 7 insertions(+), 3 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/system/shadow.scm b/gnu/system/shadow.scm
index e1dd31262a..a8bc2d9567 100644
--- a/gnu/system/shadow.scm
+++ b/gnu/system/shadow.scm
@@ -68,6 +68,7 @@ (define-module (gnu system shadow)
%default-zprofile
%default-xdefaults
%default-gdbinit
+ %default-nanorc
default-skeletons
skeleton-directory
%base-groups
@@ -211,6 +212,11 @@ (define %default-gdbinit
# pretty-printers of libstdc++.
set auto-load safe-path /gnu/store/*/lib\n"))
+(define %default-nanorc
+ (plain-file "nanorc"
+ "# Include all the syntax highlighting modules.
+include /run/current-system/profile/share/nano/*.nanorc\n"))
+
(define (default-skeletons)
"Return the default skeleton files for /etc/skel. These files are copied by
'useradd' in the home directory of newly created user accounts."
@@ -226,9 +232,7 @@ (define (default-skeletons)
;; after ~/.zshrc. To avoid interfering with any customizations a user
;; may have made in their ~/.zshrc, put this in .zprofile, not .zlogin.
(".zprofile" ,zprofile)
- (".nanorc" ,(plain-file "nanorc" "\
-# Include all the syntax highlighting modules.
-include /run/current-system/profile/share/nano/*.nanorc\n"))
+ (".nanorc" ,%default-nanorc)
(".Xdefaults" ,xdefaults)
(".guile" ,(plain-file "dot-guile"
"(cond ((false-if-exception (resolve-interface '(ice-9 readline)))
--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
Efraim Flashner wrote 1 years ago
[PATCH 6/9] system: Export default guile config.
(address . 68169@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
06d01fdafe2fd52169e57943843e4a49b9dc4d77.1704021933.git.efraim@flashner.co.il
* gnu/system/shadow.scm (%default-dotguile): Extract from
default-skeletons, export.
(default-skeletons): Use %default-dotguile.

Change-Id: Ibe91b3b517ae542bd28070a08e14152f87ed75ec
---
gnu/system/shadow.scm | 42 +++++++++++++++++++++++-------------------
1 file changed, 23 insertions(+), 19 deletions(-)

Toggle diff (71 lines)
diff --git a/gnu/system/shadow.scm b/gnu/system/shadow.scm
index a8bc2d9567..ca9c65e6d4 100644
--- a/gnu/system/shadow.scm
+++ b/gnu/system/shadow.scm
@@ -69,6 +69,7 @@ (define-module (gnu system shadow)
%default-xdefaults
%default-gdbinit
%default-nanorc
+ %default-dotguile
default-skeletons
skeleton-directory
%base-groups
@@ -217,25 +218,9 @@ (define %default-nanorc
"# Include all the syntax highlighting modules.
include /run/current-system/profile/share/nano/*.nanorc\n"))
-(define (default-skeletons)
- "Return the default skeleton files for /etc/skel. These files are copied by
-'useradd' in the home directory of newly created user accounts."
-
- (let ((profile %default-bash-profile)
- (bashrc %default-bashrc)
- (zprofile %default-zprofile)
- (xdefaults %default-xdefaults)
- (gdbinit %default-gdbinit))
- `((".bash_profile" ,profile)
- (".bashrc" ,bashrc)
- ;; Zsh sources ~/.zprofile before ~/.zshrc, and it sources ~/.zlogin
- ;; after ~/.zshrc. To avoid interfering with any customizations a user
- ;; may have made in their ~/.zshrc, put this in .zprofile, not .zlogin.
- (".zprofile" ,zprofile)
- (".nanorc" ,%default-nanorc)
- (".Xdefaults" ,xdefaults)
- (".guile" ,(plain-file "dot-guile"
- "(cond ((false-if-exception (resolve-interface '(ice-9 readline)))
+(define %default-dotguile
+ (plain-file "dot-guile"
+ "(cond ((false-if-exception (resolve-interface '(ice-9 readline)))
=>
(lambda (module)
;; Enable completion and input history at the REPL.
@@ -253,6 +238,25 @@ (define (default-skeletons)
(else
(display \"Consider installing the 'guile-colorized' package
for a colorful Guile experience.\\n\\n\"))))\n"))
+
+(define (default-skeletons)
+ "Return the default skeleton files for /etc/skel. These files are copied by
+'useradd' in the home directory of newly created user accounts."
+
+ (let ((profile %default-bash-profile)
+ (bashrc %default-bashrc)
+ (zprofile %default-zprofile)
+ (xdefaults %default-xdefaults)
+ (gdbinit %default-gdbinit))
+ `((".bash_profile" ,profile)
+ (".bashrc" ,bashrc)
+ ;; Zsh sources ~/.zprofile before ~/.zshrc, and it sources ~/.zlogin
+ ;; after ~/.zshrc. To avoid interfering with any customizations a user
+ ;; may have made in their ~/.zshrc, put this in .zprofile, not .zlogin.
+ (".zprofile" ,zprofile)
+ (".nanorc" ,%default-nanorc)
+ (".Xdefaults" ,xdefaults)
+ (".guile" ,%default-dotguile)
(".gdbinit" ,gdbinit))))
(define (skeleton-directory skeletons)
--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
Efraim Flashner wrote 1 years ago
[PATCH 7/9] system: Add default guix-home-config.
(address . 68169@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
f47f86fa42f25a4e454de2626205b41347995c1c.1704021933.git.efraim@flashner.co.il
* gnu/system/shadow.scm (%deafult-skeleton-home-config): New variable.
(default-skeletons): Add it.

Change-Id: Ida4cca8b1b3674491a4f18d94bc1b12d426575ba
---
gnu/system/shadow.scm | 35 ++++++++++++++++++++++++++++++++++-
1 file changed, 34 insertions(+), 1 deletion(-)

Toggle diff (64 lines)
diff --git a/gnu/system/shadow.scm b/gnu/system/shadow.scm
index ca9c65e6d4..6c8e02953a 100644
--- a/gnu/system/shadow.scm
+++ b/gnu/system/shadow.scm
@@ -70,6 +70,7 @@ (define-module (gnu system shadow)
%default-gdbinit
%default-nanorc
%default-dotguile
+ %default-skeleton-home-config
default-skeletons
skeleton-directory
%base-groups
@@ -239,6 +240,37 @@ (define %default-dotguile
(display \"Consider installing the 'guile-colorized' package
for a colorful Guile experience.\\n\\n\"))))\n"))
+(define %default-skeleton-home-config
+ (plain-file "default-home-config" "\
+;; This is a sample Guix Home configuration which can help setup your
+;; home directory in the same declarative manner as Guix System.
+;; For more information, see the Home Configuration section of the manual.
+(define-module (guix-home-config)
+ #:use-module (gnu home)
+ #:use-module (gnu home services)
+ #:use-module (gnu home services shells)
+ #:use-module (gnu services)
+ #:use-module (gnu system shadow))
+
+(define home-config
+ (home-environment
+ (services
+ (list
+ ;; Uncomment the shell you wish to use for your user:
+ ;(service home-bash-service-type)
+ ;(service home-fish-service-type)
+ ;(service home-zsh-service-type)
+
+ (service home-files-service-type
+ `((\".guile\" ,%default-dotguile)
+ (\".Xdefaults\" ,%default-xdefaults)))
+
+ (service home-xdg-configuration-files-service-type
+ `((\"gdb/gdbinit\" ,%default-gdbinit)
+ (\"nano/nanorc\" ,%default-nanorc)))))))
+
+home-config"))
+
(define (default-skeletons)
"Return the default skeleton files for /etc/skel. These files are copied by
'useradd' in the home directory of newly created user accounts."
@@ -257,7 +289,8 @@ (define (default-skeletons)
(".nanorc" ,%default-nanorc)
(".Xdefaults" ,xdefaults)
(".guile" ,%default-dotguile)
- (".gdbinit" ,gdbinit))))
+ (".gdbinit" ,gdbinit)
+ ("guix-home-config.scm" ,%default-skeleton-home-config))))
(define (skeleton-directory skeletons)
"Return a directory containing SKELETONS, a list of name/derivation tuples."
--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
Efraim Flashner wrote 1 years ago
[PATCH 8/9] system: default-zprofile: Sync with home zprofile.
(address . 68169@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
cb19b41bd5b44a26594983e7e1080d9297dd32a6.1704021933.git.efraim@flashner.co.il
The removed fields are already sourced in /etc/profile.

* gnu/system/shadow.scm (%default-zprofile): Sync with default zprofile
from (gnu home services shells).

Change-Id: I419eadf636344e23e8fd2f7006efa81f45527756
---
gnu/system/shadow.scm | 13 +++----------
1 file changed, 3 insertions(+), 10 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/system/shadow.scm b/gnu/system/shadow.scm
index 6c8e02953a..8b3958ba5c 100644
--- a/gnu/system/shadow.scm
+++ b/gnu/system/shadow.scm
@@ -174,17 +174,10 @@ (define %default-bash-profile
(define %default-zprofile
(plain-file "zprofile" "\
-# Honor system-wide environment variables
+# Set up the system, user profile, and related variables.
source /etc/profile
-
-# Merge search-paths from multiple profiles, the order matters.
-eval \"$(guix package --search-paths \\
--p $HOME/.config/guix/current \\
--p $HOME/.guix-profile \\
--p /run/current-system/profile)\"
-
-# Prepend setuid programs.
-export PATH=/run/setuid-programs:$PATH
+# Set up the home environment profile.
+source ~/.profile
"))
(define %default-xdefaults
--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
Efraim Flashner wrote 1 years ago
[PATCH 9/9] home: services: zsh: Use unified zprofile.
(address . 68169@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
0ca8780eb30164f4fbdb058e8f1c30c8a387eafb.1704021933.git.efraim@flashner.co.il
* gnu/home/services/shells.scm (zsh-file-zprofile): Use the zprofile
defined in (gnu system shadow) as a base.

Change-Id: Iaf4c4f66d1ccbc0bd0166136b3d082229bdec201
---
gnu/home/services/shells.scm | 8 ++------
1 file changed, 2 insertions(+), 6 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/home/services/shells.scm b/gnu/home/services/shells.scm
index 9dd56f634a..db82a7cff3 100644
--- a/gnu/home/services/shells.scm
+++ b/gnu/home/services/shells.scm
@@ -20,7 +20,7 @@
(define-module (gnu home services shells)
#:use-module (gnu services configuration)
- #:autoload (gnu system shadow) (%default-bashrc)
+ #:autoload (gnu system shadow) (%default-bashrc %default-zprofile)
#:use-module (gnu home services utils)
#:use-module (gnu home services)
#:use-module (gnu packages shells)
@@ -189,12 +189,8 @@ (define (zsh-file-zshenv config)
(define (zsh-file-zprofile config)
(mixed-text-file
"zprofile"
+ (plain-file-content %default-zprofile)
"\
-# Set up the system, user profile, and related variables.
-source /etc/profile
-# Set up the home environment profile.
-source ~/.profile
-
# It's only necessary if zsh is a login shell, otherwise profiles will
# be already sourced by bash
"
--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
Efraim Flashner wrote 1 years ago
Re: [PATCH 0/9] Add guix-home config to /etc/skel
(address . 68169-done@debbugs.gnu.org)
Zaebs73ZfT4DHKqt@3900XT
Patches pushed

--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmWnm7MACgkQQarn3Mo9
g1FmQA/9FIBInxoJC6TiERM6OXNW2Yu3b0iP0LxaMLOyib80Iswx8bvDki5MPfxE
HbmcjxtJyZlVc8v7F282C7PkolSHkoev1ZSq6zcE787ttdlT0f16e2quDO9Mi3GJ
t1GPTfneoDU6OmBOLlTfxrTcYy3bEX/lLitx7KAMrcUFAi9s/U5HI+TOZxIlqKSy
x96juAwr9WiPZ1SdDOkjgnL4OWWvuu/khVfFzosJa8U1o3cABoPXCLHpdrui5f/j
tP8Y1XntM3sQ1A5LGaWnhEGyQnYd6qTDjAav2nD0cZ2DmtrTQRG6ET+Fb7XPzUBn
2rA54lfxDcVAiOeIxvWTngeMXH3VUUEDUdBBb3F2muv/4ndxWwlJdRZm182W3SAy
VLJkdj+u+vEOOAzuxTdMfeXtyXCzsCopJ2SBmyb/O1Y5QWaK0S0BDGzFRI21uZLe
//QZyveOVdOrudwxTxQXqSRJnVrVyPih5bHz7a8Swfpnkmd7mcekMqE7rOOw9tHe
/97MSzvaVx+vsOTmMRoO9NJSYvGS+QrotYT+sRPXl8R8wFs2whPAUuStlTwk8oZI
GiUnoVF2MPGpTcSg/t7YKZux6XIP0+i9V+WxgG3dRYygEhUCxYDQpKnwd8jEWBcI
q18Nssl/Kc34DYzwesIylYNAk5NQjXSb0MV7RuzNADypU+DyAUQ=
=FNXo
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68169@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68169
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help