[PATCH] gnu: Add "go-github-com-google-btree" and "go-github-com-peterbourgon-diskv"

  • Done
  • quality assurance status badge
Details
2 participants
  • Artyom V. Poptsov
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 1 years ago
(address . guix-patches@gnu.org)
877ckv1r60.fsf@gmail.com
Hello,

this patch series adds "go-github-com-google-btree" and
"go-github-com-peterbourgon-diskv".
From f6b9da71abd070f8c6a1a77374a4017b24b7f8d8 Mon Sep 17 00:00:00 2001
Message-ID: <f6b9da71abd070f8c6a1a77374a4017b24b7f8d8.1703960709.git.poptsov.artyom@gmail.com>
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sat, 30 Dec 2023 21:20:43 +0300
Subject: [PATCH 1/2] gnu: Add go-github-com-google-btree.

* gnu/packages/golang.scm (go-github-com-google-btree): New variable.

Change-Id: Ibe7ce2c457153e40539bb26e0fcaf0bec79ed253
---
gnu/packages/golang.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 476edf6b4d..4d8dee6d3c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -12931,6 +12931,29 @@ (define-public go-github-com-google-shlex
using shell-style rules for quoting and commenting.")
(license license:asl2.0)))
+(define-public go-github-com-google-btree
+ (package
+ (name "go-github-com-google-btree")
+ (version "1.1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/btree")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0cqa8ck26p3wqz877hcvmfss17xm8wcbwd68shxv795ppahpdd9b"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/google/btree"))
+ (home-page "https://github.com/google/btree")
+ (synopsis "Simple, ordered, in-memory data structure for Go programs")
+ (description
+ "This package provides an in-memory B-Tree implementation for Go, useful as an
+ordered, mutable data structure.")
+ (license license:asl2.0)))
+
(define-public go-github-com-gorilla-websocket
(package
(name "go-github-com-gorilla-websocket")

base-commit: 375200111db1c90dcb3cd179609f0aab96360bed
--
2.41.0
From 7a80edcbdd789d80fd6065e97e79c710626e41c5 Mon Sep 17 00:00:00 2001
Message-ID: <7a80edcbdd789d80fd6065e97e79c710626e41c5.1703960709.git.poptsov.artyom@gmail.com>
In-Reply-To: <f6b9da71abd070f8c6a1a77374a4017b24b7f8d8.1703960709.git.poptsov.artyom@gmail.com>
References: <f6b9da71abd070f8c6a1a77374a4017b24b7f8d8.1703960709.git.poptsov.artyom@gmail.com>
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sat, 30 Dec 2023 21:24:42 +0300
Subject: [PATCH 2/2] gnu: Add go-github-com-peterbourgon-diskv.

* gnu/packages/golang.scm (go-github-com-peterbourgon-diskv): New variable.

Change-Id: I0292404c636c42389c11c0ed552bacbf02178f7c
---
gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4d8dee6d3c..81771b1788 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -12954,6 +12954,33 @@ (define-public go-github-com-google-btree
ordered, mutable data structure.")
(license license:asl2.0)))
+(define-public go-github-com-peterbourgon-diskv
+ (package
+ (name "go-github-com-peterbourgon-diskv")
+ (version "3.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/peterbourgon/diskv")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0pdy8f7bkm65gx4vknwcvfa619hknflqxkdlvmf427k2mzm91gmh"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/peterbourgon/diskv"
+ #:go ,go-1.18))
+ (propagated-inputs (list go-github-com-google-btree))
+ (home-page "https://github.com/peterbourgon/diskv")
+ (synopsis "Disk-backed key-value store")
+ (description
+ "Diskv (disk-vee) is a simple, persistent key-value store written in the Go
+language. It starts with a simple API for storing arbitrary data on a filesystem by
+key, and builds several layers of performance-enhancing abstraction on top. The end
+result is a conceptually simple, but highly performant, disk-backed storage system.")
+ (license license:expat)))
+
(define-public go-github-com-gorilla-websocket
(package
(name "go-github-com-gorilla-websocket")
--
2.41.0
- avp

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQJMBAEBCgA3FiEEAf2F9Bp7f4IFgwalk16+BzbchX4FAmWQYTcZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRCTXr4HNtyFfjH4D/d1tMnxJdNeJSnSDPyYB9I2
aap5IjDk4jLawsLZfB1g5PtacHdidJU48V3tw7lWChacBSJz/ReVMQUrbwOMVbEB
eAJ0XVHWU+XVOgCnIB2pHZXX69eJBUPXyIl4CNDt3VXllR0uxq2dVq/1OfAejH6A
n5ti+V3lb3Ur/Lsrcv/iDpKw+ZfKU1Ba7mFPkB3TCRV7DxlZaEBwHo94rLIB5z19
TdFqnvReJzAjD5k5Ff0rjzmZBBN5E36pJIFqmVDzjXub2BLcGs4+xr/PRHjsXrHE
kw4pyi32U2ba5ceKu7ZUYJvftWPay9bGtIGsdi3kB08dv/Lue+buD2UImBpidf+B
o4AWtDdMDNbi7yRnU0UBGnuRzTprk8/+vA6RHjRDLO3ilOuTwM849IEpQIqhYXEC
9U76rtDHeOxrRyZfUJwKUzz7X0xYmGj3jYvcSy8/tty//qCxMqSk+jI7PFqAcxZ1
6+C50K2EvqvloRuOGOE/zpqRTEAhNsfWyvSYiaL00NZhAZA7LnCYH76LLXzHSj2x
h2jIU9aUTJXZxcfl2P37xT1QznZbrO4ZhqoGvf/FEjxXEf34lwPMeAvwHCwLzj1d
17B26ly8AjbWtIBA+LNv0xVQoEd00OHL/bt1pJTY6oQ0gyqrDgHqC0IlFO0FL23U
C73LdXYQAi7LDyVb56Td
=IG0p
-----END PGP SIGNATURE-----

Sharlatan Hellseher wrote 1 years ago
(address . 68152-done@debbugs.gnu.org)(address . poptsov.artyom@gmail.com)
CAO+9K5qRonT2Kx0GQkZtPxuu6nYSwJGjQvY-Fq3knsXzAo+nWA@mail.gmail.com
Hi

I've re-based patches from the latest master commit and resolved conflict. Lint
and build passed successfully.

[env: /gnu/store/vpzdg6vmqja1xdsdfs84jm9py4qmf6xf-profile]
Toggle quote (1 lines)
> ./pre-inst-env guix build --rounds=2 go-github-com-peterbourgon-diskv go-github-com-google-btree
/gnu/store/kh1gcimdv45f44d6xh25dknn5lp4j2a9-go-github-com-google-btree-1.1.2
/gnu/store/3z4ccdw2jlz2blzqr9ibm07syh7wajhx-go-github-com-peterbourgon-diskv-3.0.0
[env: /gnu/store/vpzdg6vmqja1xdsdfs84jm9py4qmf6xf-profile]
Toggle quote (1 lines)
> ./pre-inst-env guix lint go-github-com-peterbourgon-diskv go-github-com-google-btree
fetching CVE database for 2024...on-diskv@3.0.0 [cve]...
fetching CVE database for 2023...
fetching CVE database for 2022...
fetching CVE database for 2021...
gnu/packages/golang.scm:12059:13:
go-github-com-peterbourgon-diskv@3.0.0: can be upgraded to 3.0.1

This warning is irrelevant, and may be ignored:
gnu/packages/golang.scm:12059:13:
go-github-com-peterbourgon-diskv@3.0.0: can be upgraded to 3.0.1

Upstream has an issue with tagging and release:

If it's chunk of long patch series, please let me know which project are you
trying to pack, let's share efforts :-)

Pushed to master as 0edf8a2eabd386d209d4b32aca599ce22a3a7533
--
VCS: https://github.incerto.xyz/;https://git.sr.ht/~hellseher/
GPG: 9847 81DE 689C 21C2 6418 0867 76D7 27BF F62C D2B5

… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68152@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68152
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help