[PATCH] gnu: Add lazygit.

  • Open
  • quality assurance status badge
Details
2 participants
  • abr
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
abr
Severity
normal
A
(address . guix-patches@gnu.org)(name . abr)(address . abr@cock.li)
90a350fa48d10df25ac383687417a15c75722dba.1703942665.git.abr@cock.li
* gnu/packages/version-control.scm (lazygit): New variable

Change-Id: I2d986f7519b27a389b74d9c87c31ce3f2d58b860
---
gnu/packages/version-control.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 013504875b..050e4220a1 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -3949,3 +3949,26 @@ (define-public commit-patch
comes as a command line app and also an Emacs interface.")
(home-page "https://porkrind.org/commit-patch/")
(license license:gpl2+)))
+
+(define-public lazygit
+ (package
+ (name "lazygit")
+ (version "0.40.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jesseduffield/lazygit")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "049gdbhsaqdpj4bn0k4dbzvwaig40p5vhmnqvj09as3f0wl5cgn6"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/jesseduffield/lazygit"
+ #:go ,go-1.20))
+ (synopsis "Simple terminal UI for git commands")
+ (description
+ "Lazygit is an interactive terminal user interface (TUI) for git.")
+ (home-page "https://github.com/jesseduffield/lazygit")
+ (license license:expat)))
+

base-commit: f76ca2b0e894c244d5011a32b30dee8fd874e322
--
2.39.2
S
S
Sharlatan Hellseher wrote on 12 Jan 23:40 +0100
(address . 68149@debbugs.gnu.org)(address . abr@cock.li)
CAO+9K5rv4Q+1bR+0o0ycJcJFp0aRMTNko5=A_BaaoYA53t2GKQ@mail.gmail.com
Hi,
LazyGit has quite a massive list of vendored packages in:
I've tried to pack it a year ago and nearly archived it :-)
wip-golang ref:
Mirror
How hard would it be to review/prepare all missing packages?
Thanks,
Oleg
--
VCS: https://github.incerto.xyz/;https://git.sr.ht/~hellseher/
GPG: 9847 81DE 689C 21C2 6418 0867 76D7 27BF F62C D2B5
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 68149@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68149
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch