Add a package definition for Michelangelo Rodriguez's greader (gnamù reader) Emacs package.

  • Open
  • quality assurance status badge
Details
One participant
  • Yuval Langer
Owner
unassigned
Submitted by
Yuval Langer
Severity
normal
Y
Y
Yuval Langer wrote on 30 Dec 2023 01:34
Add a package definition for Michelangelo Rodriguez' s greader (gnamù reader) Emacs package.
(address . guix-patches@gnu.org)
CAK0OjG0GdipkczdSq5R+0rKDJe-dTzLRNA=38iRDvDkMT06e-w@mail.gmail.com
I have written a package definition for this text-to-speech Emacs
minor mode package.

It is extremely useful and I use it every day.

Thank you,
Yuval Langer.
From 5740ce7b4231cd66a3d82211308fbe7f968c806d Mon Sep 17 00:00:00 2001
Message-Id: <5740ce7b4231cd66a3d82211308fbe7f968c806d.1703896207.git.yuval.langer@gmail.com>
From: Yuval Langer <yuval.langer@gmail.com>
Date: Sat, 30 Dec 2023 02:29:56 +0200
Subject: [PATCH] Add a package definition for Michelangelo Rodriguez's greader
Emacs package.

---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6bec2bca46..86bd70875d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1400,6 +1400,30 @@ configuration files, such as @file{.gitattributes}, @file{.gitignore}, and
(define-deprecated/public-alias git-modes emacs-git-modes)
+(define-public emacs-greader-mode
+ (let ((commit "fe5df5a83932acccf3407d67c59c131be058d6c4")
+ (base32-string "02b2p2y10gwkddka905skz812d73n3l6nvqnq5pzas2a7wfw7jzq")
+ (git-repository-url "https://gitlab.com/michelangelo-rodriguez/greader"))
+ (package
+ (name "emacs-greader-mode")
+ (version "0.8.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url git-repository-url)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 base32-string))))
+ (build-system emacs-build-system)
+ (inputs (list espeak-ng))
+ (home-page git-repository-url)
+ (synopsis "greader - gnamù reader, send buffer contents to a speech engine")
+ (description
+ "")
+ (license license:gpl3+))))
+
(define-public emacs-with-editor
(package
(name "emacs-with-editor")
--
2.30.2
Y
Y
Yuval Langer wrote on 4 Jan 15:47 +0100
Add description to the package definition.
(address . 68116@debbugs.gnu.org)
CAK0OjG06cK0cTrBhHV52RABc-QbD8MVUhrd4R_E_dNJ0Fh_YHw@mail.gmail.com

From 64767f87333d5f0a84e0ff628ab04d7bfe9dd46a Mon Sep 17 00:00:00 2001
Message-Id: <64767f87333d5f0a84e0ff628ab04d7bfe9dd46a.1704379533.git.yuval.langer@gmail.com>
From: Yuval Langer <yuval.langer@gmail.com>
Date: Thu, 4 Jan 2024 16:45:01 +0200
Subject: [PATCH] Add Michelangelo Rodriguez's description of his package.

---
gnu/packages/emacs-xyz.scm | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 86bd70875d..dd4036125e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1421,7 +1421,13 @@ configuration files, such as @file{.gitattributes}, @file{.gitignore}, and
(home-page git-repository-url)
(synopsis "greader - gnamù reader, send buffer contents to a speech engine")
(description
- "")
+ "Greader is a module that allows you to send any emacs buffer to a TTS.
+A text-to-speech like engine `espeak-ng' or `speech-dispatcher'are
+already supported, plus limited bakend support native to macOS. The
+mode supports timer reading, automatic scrolling of buffers in modes
+like `info-mode', repeating reading of regions or the whole buffer,
+includes a feature to facilitate the compilation of espeak-ng
+pronunciations, and other features.")
(license license:gpl3+))))
(define-public emacs-with-editor
--
2.30.2
?