[PATCH] gnu: Add python-pytest-cookies.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • Troy Figiel
Owner
unassigned
Submitted by
Troy Figiel
Severity
normal

Debbugs page

Troy Figiel wrote 1 years ago
(address . guix-patches@gnu.org)
87tto3comb.fsf@troyfigiel.com
* gnu/packages/python-check.scm (python-pytest-cookies): New variable.

Change-Id: I0b085d345bf1bce5fc9c03315da06954cf2125cb
---
gnu/packages/python-check.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index ea74472270..f02ca10298 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -583,6 +583,38 @@ (define-public python-pytest-arraydiff
are too large to conveniently hard-code them in the tests.")
(license license:bsd-3)))
+(define-public python-pytest-cookies
+ (package
+ (name "python-pytest-cookies")
+ (version "0.7.0")
+ (source
+ (origin
+ ;; No tests in the PyPI tarball.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hackebrot/pytest-cookies")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1x7ny6mx1siy9law1cv1i63nvv9ds2g1dlagm40l8qymxry43mjn"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
+ (native-inputs (list python-pytest))
+ (propagated-inputs (list python-cookiecutter))
+ (home-page "https://github.com/hackebrot/pytest-cookies")
+ (synopsis "Pytest plugin for Cookiecutter templates")
+ (description
+ "This Pytest plugin adds a @code{cookies} fixture, which is a
+wrapper for the Cookiecutter API. This fixture helps you verify that
+your template is working as expected and takes care of cleaning up after
+running the tests.")
+ (license license:expat)))
+
(define-public python-pytest-doctestplus
(package
(name "python-pytest-doctestplus")

base-commit: 5bd80ccd69047b1777749e24d4adf2c951b5d14b
--
2.40.1
Mathieu Othacehe wrote 1 years ago
(name . Troy Figiel)(address . troy@troyfigiel.com)(address . 68069-done@debbugs.gnu.org)
87y1de7kbc.fsf@gnu.org
Toggle quote (2 lines)
> * gnu/packages/python-check.scm (python-pytest-cookies): New variable.

Applied, thanks,

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68069@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68069
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help