[PATCH] gnu: syndication: Add newsraft.

  • Done
  • quality assurance status badge
Details
3 participants
  • lgcoelho
  • Sharlatan Hellseher
  • Steve George
Owner
unassigned
Submitted by
lgcoelho
Severity
normal
L
L
lgcoelho wrote on 27 Dec 2023 18:14
(address . guix-patches@gnu.org)
45e980f94aaeb3b045169ad0192029ce@disroot.org
This patch adds newsraft, a feed reader greatly inspired by newsboat, to
(gnu packages syndication).
Attachment: file
From 681472429c1f325aaa004ebbedd359df2676e344 Mon Sep 17 00:00:00 2001
From: Luis Guilherme Coelho <lgcoelho@disroot.org>
Date: Wed, 27 Dec 2023 14:12:06 -0300
Subject: [PATCH] gnu: syndication: Add newsraft

---
gnu/packages/syndication.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index a9e5b80bbf..411bf57a0f 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -50,6 +50,7 @@ (define-module (gnu packages syndication)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
#:use-module (gnu packages kde-frameworks)
+ #:use-module (gnu packages man)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pretty-print)
@@ -335,6 +336,37 @@ (define-public newsboat
(license (list license:gpl2+ ; filter/*
license:expat)))) ; everything else
+;; Thanks to nckx, rekado and lechner for the help :)
+(define-public newsraft
+ (package
+ (name "newsraft")
+ (version "0.21")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://codeberg.org/grisha/newsraft/"
+ "archive/newsraft-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1dbyg0qy2kw4fjb6hi8ad4jiji9z0wl97aizd3gp68ch1cn7ban2"))))
+ (build-system gnu-build-system)
+ (native-inputs (list gnu-make pkg-config scdoc))
+ (inputs (list curl expat gumbo-parser ncurses sqlite yajl))
+ (arguments
+ (list #:tests? #f
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output)
+ "CFLAGS=-DCURL_WRITEFUNC_ERROR=0xFFFFFFFF")
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://codeberg.org/grisha/newsraft")
+ (synopsis
+ "Newsraft is a ncurses feed reader greatly inspired by newsboat.")
+ (description
+ "Newsraft is a feed reader with ncurses user interface. It is
+greatly inspired by Newsboat and tries to be its lightweight counterpart.")
+ (license license:isc)))
+
(define-public liferea
(package
(name "liferea")
--
2.41.0
S
S
Sharlatan Hellseher wrote on 4 Nov 00:46 +0100
(address . 68063-done@debbugs.gnu.org)
87bjyvubi6.fsf@gmail.com
Hi,

I've applied some modifications:

- adjustments
- Adjust commit message header and body
- Set author to Luis Guilherme Coelho <lgcoelho@disroot.org>
- Add copyright
- Adjust fields sequence and package indentation
- Remove gnu-make from native inputs
- Adjust synopsis, taken from upstream home page
- Re-indent description, add feature list
- Swap source from tarbal to git checkout (there are tags)
- Update to 0.27
- Enable tests

Toggle snippet (77 lines)
--- #<buffer *new*<14>>
+++ #<buffer *new*<13>>
@@ -1,30 +1,47 @@
-;; Thanks to nckx, rekado and lechner for the help :)
(define-public newsraft
(package
(name "newsraft")
- (version "0.21")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://codeberg.org/grisha/newsraft/"
- "archive/newsraft-" version ".tar.gz"))
- (sha256
- (base32
- "1dbyg0qy2kw4fjb6hi8ad4jiji9z0wl97aizd3gp68ch1cn7ban2"))))
+ (version "0.27")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/newsraft/newsraft")
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "170dwv6v9755mdy4w91r4mk6r5d713rxi71hppqws3bsh2g4bmrj"))))
(build-system gnu-build-system)
- (native-inputs (list gnu-make pkg-config scdoc))
- (inputs (list curl expat gumbo-parser ncurses sqlite yajl))
(arguments
- (list #:tests? #f
- #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
- (string-append "PREFIX=" #$output)
- "CFLAGS=-DCURL_WRITEFUNC_ERROR=0xFFFFFFFF")
- #:phases #~(modify-phases %standard-phases
- (delete 'configure))))
+ (list
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output)
+ "CFLAGS=-DCURL_WRITEFUNC_ERROR=0xFFFFFFFF")
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)))) ; no configure
+ (native-inputs
+ (list pkg-config scdoc))
+ (inputs
+ (list curl expat gumbo-parser ncurses sqlite yajl))
(home-page "https://codeberg.org/grisha/newsraft")
- (synopsis
- "Newsraft is a ncurses feed reader greatly inspired by newsboat.")
+ (synopsis "Feed reader for termnial")
(description
- "Newsraft is a feed reader with ncurses user interface. It is
-greatly inspired by Newsboat and tries to be its lightweight counterpart.")
+ "Newsraft is a feed reader with ncurses user interface. It is greatly
+inspired by Newsboat and tries to be its lightweight counterpart.
+
+Features:
+@itemize
+@item parallel downloads
+@item section-based feeds grouping
+@item opening links in any program
+@item viewing news from all feeds with explore mode
+@item automatic updates for feeds and sections
+@item per-feed settings and key bindings
+@item assigning multiple actions to key bindings
+@item processing feeds from command output
+@item text searching by news titles and content
+@item interactive news content viewing
+@end itemize")
(license license:isc)))
\ No newline at end of file

Diff finished. Sun Nov 3 20:36:46 2024

Pushed as 2ef5e0cd89 to master.

--
Thanks,
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmcoC0EACgkQdtcnv/Ys
0rUHkw//WNlQqKl2VHPoWfoMmTm9EQyKmQUDd0Rtt0dpANkauMzDx4XFY0sgn7UJ
djrmeuFeFVjNFwfqIa5OcNWexwFDunVn6f0J4WMMd/7T0pmWEd41c5HaGkEYkp/L
MvnDPc0Eu1iojZ5gSaEM+L7TQcm+3lIatUPRcSSMR//SGTshNAxXy2C6eKNwoG3O
46wu6P9jQvRavZb7N3mRfHl8G8TOZUjOcvTJCHOe4ksNsvelmlMAe4piVYfzXh1d
p6Dh5FCxFbrfJMu1rPDzwf9IRGj8oSBePtF0MBVVbJFfH+Qfy2DnqhmzypjqngW+
r6ZQnS9XlADN7x8SBx+7nGZdR3Lwvxn64oW5XJt5iYe21sJvoBfiKj8+dqg3cALk
rth+4PQ00ftbmgXaNijqMg1Eb9rbSnO5C1exO1zoZGhzClG/al+gGk4Pt8Uon2Kx
WTEtEWEN8Ftl7/5H0HzQHBTryy/MkRJ7ahGJpdP/eUbLKoOqQgcRf+OZyTtgwq3r
jGDb3ow75bEhtus0rMz+nnI/+atwsWZLCaQag4Ib7hoiCZ5Bu/TKJxu3d6aUh68q
bdNo5tL1qsoVCqPA34t+PkNliSxhoDNKE1/6aBxZfLpseRPCFrKDoma70LPkyZua
bQOe0ERl91don0vXpM59DKmlwQOqW2yu5FBLjeIrPBVQHFzYnyA=
=b9gc
-----END PGP SIGNATURE-----

Closed
S
S
Steve George wrote on 4 Nov 14:25 +0100
closing 68063
(address . control@debbugs.gnu.org)(address . 68063-submitter@debbugs.gnu.org)
1730726445-3911-bts-steve@futurile.net
close 68063
# Hi there - your patch to add Newscraft to Guix has been applied and you
# should see it in the archive! Thanks for sendig it
# As a tip - when you send future patches please send them as 'inline' not
# attachments as this one was - it's easier for the CI system and devs to
# download and apply them. The easiest way is to use `git send-email` for more
# info see the manual:
#
thanks
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 68063@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68063
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch