[PATCH] gnu: syndication: Add newsraft.

  • Open
  • quality assurance status badge
Details
One participant
  • lgcoelho
Owner
unassigned
Submitted by
lgcoelho
Severity
normal
L
L
lgcoelho wrote on 27 Dec 2023 18:14
(address . guix-patches@gnu.org)
45e980f94aaeb3b045169ad0192029ce@disroot.org
This patch adds newsraft, a feed reader greatly inspired by newsboat, to
(gnu packages syndication).
Attachment: file
From 681472429c1f325aaa004ebbedd359df2676e344 Mon Sep 17 00:00:00 2001
From: Luis Guilherme Coelho <lgcoelho@disroot.org>
Date: Wed, 27 Dec 2023 14:12:06 -0300
Subject: [PATCH] gnu: syndication: Add newsraft

---
gnu/packages/syndication.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index a9e5b80bbf..411bf57a0f 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -50,6 +50,7 @@ (define-module (gnu packages syndication)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
#:use-module (gnu packages kde-frameworks)
+ #:use-module (gnu packages man)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pretty-print)
@@ -335,6 +336,37 @@ (define-public newsboat
(license (list license:gpl2+ ; filter/*
license:expat)))) ; everything else
+;; Thanks to nckx, rekado and lechner for the help :)
+(define-public newsraft
+ (package
+ (name "newsraft")
+ (version "0.21")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://codeberg.org/grisha/newsraft/"
+ "archive/newsraft-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1dbyg0qy2kw4fjb6hi8ad4jiji9z0wl97aizd3gp68ch1cn7ban2"))))
+ (build-system gnu-build-system)
+ (native-inputs (list gnu-make pkg-config scdoc))
+ (inputs (list curl expat gumbo-parser ncurses sqlite yajl))
+ (arguments
+ (list #:tests? #f
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output)
+ "CFLAGS=-DCURL_WRITEFUNC_ERROR=0xFFFFFFFF")
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://codeberg.org/grisha/newsraft")
+ (synopsis
+ "Newsraft is a ncurses feed reader greatly inspired by newsboat.")
+ (description
+ "Newsraft is a feed reader with ncurses user interface. It is
+greatly inspired by Newsboat and tries to be its lightweight counterpart.")
+ (license license:isc)))
+
(define-public liferea
(package
(name "liferea")
--
2.41.0
?