[PATCH] gnu: Add r-scgate, r-stacas and r-projectils.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 1 years ago
(address . guix-patches@gnu.org)
dcc6dea5-a444-4218-a3d7-959906aaa7f4@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-scgate, r-stacas and r-projectils):
New variables.
Mădălin Ionel Patrașcu wrote 1 years ago
[PATCH 1/3] gnu: Add r-scgate.
(address . 68056@debbugs.gnu.org)
dce9fb4afc7cc569984b722a43f51388bbb5a69f.1703671356.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-scgate): New variable.

Change-Id: Ibcf9eaef67398aa00473d29d651c6d32e425d989
---
gnu/packages/bioinformatics.scm | 41 +++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 3e7b99ee61..d572980965 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10301,6 +10301,47 @@ (define-public r-sccustomize
visualization and analysis of single-cell data using R.")
(license license:gpl3+))))
+(define-public r-scgate
+ (package
+ (name "r-scgate")
+ (version "1.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "scGate" version))
+ (sha256
+ (base32 "0h12d36zjc6fvxbhkxrzbpvw49z9fgyn1jc941q70ajw1yqi2hhh"))))
+ (properties `((upstream-name . "scGate")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biocparallel
+ r-dplyr
+ r-ggplot2
+ r-ggridges
+ r-patchwork
+ r-reshape2
+ r-seurat
+ r-ucell))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/carmonalab/scGate")
+ (synopsis
+ "Marker-based cell type purification for single-cell sequencing data")
+ (description
+ "This package provides a method to purify a cell type or cell population of
+interest from heterogeneous datasets. scGate package automatizes marker-based
+purification of specific cell populations, without requiring training data or
+reference gene expression profiles. scGate takes as input a gene expression
+matrix stored in a Seurat object and a @acronym{GM, gating model}, consisting of
+a set of marker genes that define the cell population of interest. It evaluates
+the strength of signature marker expression in each cell using the rank-based
+method UCell, and then performs @acronym{kNN, k-nearest neighbor} smoothing by
+calculating the mean UCell score across neighboring cells. kNN-smoothing aims
+at compensating for the large degree of sparsity in scRNAseq data. Finally, a
+universal threshold over kNN-smoothed signature scores is applied in binary
+decision trees generated from the user-provided gating model, to annotate cells
+as either “pure” or “impure”, with respect to the cell population of interest.")
+ (license license:gpl3)))
+
(define-public r-markdownhelpers
(let ((commit "793372d28ebed607cc1d35f909a1caedb2b41ffe")
(revision "1"))

base-commit: 0d13d095420861022e68e87ceebd5e037e12a8b3
--
2.41.0
Mădălin Ionel Patrașcu wrote 1 years ago
[PATCH 2/3] gnu: Add r-stacas.
(address . 68056@debbugs.gnu.org)
f8637e701714926d5ee5265758fe977dad296d0e.1703671356.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-stacas): New variable.

Change-Id: I258a315465ed88b8013d26a36718250c950aa107
---
gnu/packages/bioinformatics.scm | 36 +++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index d572980965..d736abe07e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1069,6 +1069,42 @@ (define-public r-singlet
similar.")
(license license:gpl2+))))
+(define-public r-stacas
+ (package
+ (name "r-stacas")
+ (version "2.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/carmonalab/STACAS")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13i0h5i6vlbrb8ndq9gr81560z9d74b2c7m3rjfzls01irjza9hm"))))
+ (properties `((upstream-name . "STACAS")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biocneighbors
+ r-biocparallel
+ r-ggplot2
+ r-ggridges
+ r-pbapply
+ r-r-utils
+ r-seurat))
+ (home-page "https://github.com/carmonalab/STACAS")
+ (synopsis "Sub-type anchoring correction for alignment in Seurat")
+ (description
+ "This package implements methods for batch correction and integration of
+scRNA-seq datasets, based on the Seurat anchor-based integration framework. In
+particular, STACAS is optimized for the integration of heterogenous datasets with
+only limited overlap between cell sub-types (e.g. TIL sets of CD8 from tumor with
+CD8/CD4 T cells from lymphnode), for which the default Seurat alignment methods
+would tend to over-correct biological differences. The 2.0 version of the package
+allows the users to incorporate explicit information about cell-types in order
+to assist the integration process.")
+ (license license:gpl3)))
+
(define-public r-stringendo
(let ((commit "15594b1bba11048a812874bafec0eea1dcc8618a")
(revision "1"))
--
2.41.0
Mădălin Ionel Patrașcu wrote 1 years ago
[PATCH 3/3] gnu: Add r-projectils.
(address . 68056@debbugs.gnu.org)
94e8ffe4bb3d6ae0530bc6da99989f39a79f5f5c.1703671356.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-projectils): New variable.

Change-Id: Ia975cfcb9c79e59b029c6839dc87b5dcb89bf72a
---
gnu/packages/bioinformatics.scm | 45 +++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index d736abe07e..f959de7cd6 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10247,6 +10247,51 @@ (define-public r-premessa
bead-based normalization and debarcoding.")
(license license:gpl3))))
+(define-public r-projectils
+ (let ((commit "cc73b97471b4b6eea11ce779b5c4a7dc5c3e1709")
+ (revision "1"))
+ (package
+ (name "r-projectils")
+ (version (git-version "3.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/carmonalab/ProjecTILs")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0dpzvbhhb9andnj7angpj32cgkwd6rs6qgpl6i21pqzcn6vqqhqw"))))
+ (properties `((upstream-name . "ProjecTILs")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biocneighbors
+ r-biocparallel
+ r-dplyr
+ r-ggplot2
+ r-matrix
+ r-patchwork
+ r-pheatmap
+ r-pracma
+ r-purrr
+ r-rcolorbrewer
+ r-reshape2
+ r-scales
+ r-scgate
+ r-seurat
+ r-seuratobject
+ r-stacas
+ r-ucell
+ r-umap
+ r-uwot))
+ (home-page "https://github.com/carmonalab/ProjecTILs")
+ (synopsis "Reference-based analysis of scRNA-seq data")
+ (description
+ "This package implements methods to project single-cell RNA-seq data onto
+a reference atlas, enabling interpretation of unknown cell transcriptomic states
+in the the context of known, reference states.")
+ (license license:gpl3))))
+
(define-public r-presto
(let ((commit "052085db9c88aa70a28d11cc58ebc807999bf0ad")
(revision "0"))
--
2.41.0
Ricardo Wurmus wrote 1 years ago
[PATCH] gnu: Add r-scgate, r-stacas and r-projectils.
(address . 68056-done@debbugs.gnu.org)
874jeuhjjj.fsf@elephly.net
Thanks for the patches.

For r-stacas and r-scgate we already have Bioconductor packages. Since
we also have a package for r-projectils I’m closing this issue.

--
Ricardo
Closed
Ricardo Wurmus wrote 1 years ago
(address . 68056-done@debbugs.gnu.org)
87zfwmg38h.fsf@elephly.net
Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (5 lines)
> Thanks for the patches.
>
> For r-stacas and r-scgate we already have Bioconductor packages. Since
> we also have a package for r-projectils I’m closing this issue.

Turns out that *I* actually applied them about a month ago, but I had
edited the package definitions to use bioconductor-uri instead of an
arbitrary git checkout. Sorry for the confusion!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68056@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68056
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help