[PATCH] gnu: libjxl: Fix build on riscv64-linux.

  • Open
  • quality assurance status badge
Details
One participant
  • Zheng Junjie
Owner
unassigned
Submitted by
Zheng Junjie
Severity
normal
Z
Z
Zheng Junjie wrote on 26 Dec 2023 13:43
(address . guix-patches@gnu.org)
d99269bcffc8a7e7165be8b24e39da1b7d225e98.1703594598.git.zhengjunjie@iscas.ac.cn
* gnu/packages/image.scm (libjxl)
[arguments]: Add fix-atomic phase when target riscv64-linux.

Change-Id: I442c668c3d52c241f0d405f51ea8d995bfefd3fd
---
gnu/packages/image.scm | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index ebabd1c973..babaf9e625 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -2547,7 +2547,16 @@ (define-public libjxl
"-DJPEGXL_FORCE_SYSTEM_BROTLI=true"
"-DJPEGXL_FORCE_SYSTEM_LCMS2=true"
"-DJPEGXL_FORCE_SYSTEM_HWY=true"
- "-DJPEGXL_BUNDLE_LIBPNG=false")))
+ "-DJPEGXL_BUNDLE_LIBPNG=false")
+ ,@(if (target-riscv64?)
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-atomic
+ (lambda _
+ (substitute* "lib/jxl/enc_xyb.cc"
+ (("#include \"lib/jxl/enc_xyb.h\"" a)
+ (string-append a "\n#include <atomic>")))))))
+ '())))
(native-inputs
(list asciidoc doxygen googletest pkg-config python))
(inputs

base-commit: 0d13d095420861022e68e87ceebd5e037e12a8b3
--
2.41.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 68040@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68040
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch