pcb2gcode does not build

  • Open
  • quality assurance status badge
Details
2 participants
  • Evgeny Pisemsky
  • Evgeny Pisemsky
Owner
unassigned
Submitted by
Evgeny Pisemsky
Severity
normal
E
E
E
Evgeny Pisemsky wrote on 3 Jul 15:50 +0200
pcb2gcode build fix
(address . 68036@debbugs.gnu.org)
87plruvb32.fsf@pisemsky.site
Found two issues - unspecified version in pkgconfig of gerbv and some
incompatibility with optional geos library.

Related discussions:


The attached patch fixes those problems.
From 2f73c340abf3df2690b3778cbf0eb1de7a63ab33 Mon Sep 17 00:00:00 2001
Message-ID: <2f73c340abf3df2690b3778cbf0eb1de7a63ab33.1720013503.git.mail@pisemsky.site>
From: Evgeny Pisemsky <mail@pisemsky.site>
Date: Wed, 3 Jul 2024 15:15:25 +0300
Subject: [PATCH] gnu: pcb2gcode: Fix build.

* gnu/packages/engineering.scm (pcb2gcode): Fix build.

Change-Id: Id9a167c8859520f6e051c9b5efb4b960d50e4b7b
---
gnu/packages/engineering.scm | 13 +++++++++++--
1 file changed, 11 insertions(+), 2 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 64335d89f7..0855f44d13 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -844,7 +844,15 @@ (define-public gerbv
"06bcm5zw7whsnnmfld3gl2j907lxc68gnsbzr2pc4w6qc923rgmj"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("CFLAGS=-fcommon")))
+ (list
+ #:configure-flags '(list "CFLAGS=-fcommon")
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'fix-pkg-config-version
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* (string-append (assoc-ref outputs "out")
+ "/lib/pkgconfig/libgerbv.pc")
+ (("^Version:.*$")
+ (string-append "Version: " #$version "\n"))))))))
(native-inputs (list autoconf
automake
desktop-file-utils
@@ -3257,7 +3265,8 @@ (define-public pcb2gcode
(build-system gnu-build-system)
(inputs
(list boost
- geos
+ ;; TODO: Try to build with geos in the following revisions.
+ ;; geos
gerbv
glibmm
gtkmm-2

base-commit: bab73e413b3421f4aa051e9438d147040a52e1be
--
2.45.2
E
E
Evgeny Pisemsky wrote on 4 Jul 09:00 +0200
Sorry
(address . 68036@debbugs.gnu.org)
87cynt4p64.fsf@pisemsky.site
Looks like I accidentally spammed bug tracker:


My previous message to this report did not show up for a long time, so
I created a new one, but screwed up subject and thought it was a
reason for not receiving acknowledgement, so I filed another one.

And now all three of them suddenly appeared.
E
E
Evgeny Pisemsky wrote on 9 Aug 16:23 +0200
Re: pcb2gcode does not build
(address . 68036@debbugs.gnu.org)
87o761ojve.fsf@pisemsky.site
I've found a cause of missing version in gerbv and sent a new patch:


Also geos can be downgraded to 3.11.4 to successfully build pcb2gcode.

So the patch proposed here is not valid for now - I'll send a new one.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 68036@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68036
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch