On Mon, Dec 25, 2023 at 03:02:22PM -0500, Jaeme Sifat wrote:
Toggle quote (29 lines)
> The culprit to your problem is `rust-ffmpeg-sys-the-third-1', which requires
> all the packages you just mentioned for building. `rust-av1an-core` requires
> `rust-ffmpeg-the-third-1' which in turn requires the sys libraries as well.
>
> --8<---------------cut here---------------start------------->8---
>
> rust-ffmpeg-sys-the-third-1 -> Requires vapoursynth ffmpeg clang nasm
> pkg-config
>
> rust-ffmpeg-the-third-1 -> Requires rust-ffmpeg-sys-the-third-1
>
> rust-av1an-core -> Requires rust-ffmpeg-the-third-1
>
> rust-av1an -> Requires rust-av1an-core
>
> --8<---------------cut here---------------end--------------->8---
>
> Thus, the native-inputs and inputs of rust-ffmpeg-sys-the-third are required
> for any packages that depend on it in #:cargo-inputs.
>
> I see your point now, it would be very helpful if cargo-build-system could
> grab the inputs and native-inputs of dependent packages in the case of
> crates like `rust-ffmpeg-sys-the-third-1.' That way the dependencies
> wouldn't have to be duplicated across packages.
>
> This sounds like a good suggestion, I can bring this up to Efraim, who is on
> the Rust team, about this who is much more knowledgeable about the
> implementation of the cargo-build-system than me.
I haven't looked too closely at that part of the cargo-build-system but
in general my mental model is that it grabs the sources of the named
packages in the cargo{,-development}-inputs. I suppose we could tell the
crates to also grab the {propagated-,native-,}inputs also and carry
those forward to the next crate. I suppose in theory we might end up
with multiple versions of libgit2 or other packages, and I'm not sure if
that'd point to various packages having the wrong inputs or needing to
adjust it somehow to prefer one version over another.
A similar issue is the perl dependency for rust-ring. I've finally fixed
it on the rust-team branch using a computed-origin but I think both are
the type of thing the antioxidant build system would help solve.
I suppose we could end up with using propagated-inputs for things like
perl or ffmpeg (in your package above) like we do with the python build
systems and adjusting the cargo-build-system to grab those when it
traverses the tree.
--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----
iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmWL/9oACgkQQarn3Mo9
g1Gn8g//Tzl9jhIVF9FrE3r9Qmgu71cGamlxbVOtbdilbxDygRgWO8yWbOewIt9B
cXZmvhuYfhZ/8z0bBZoyrjUvnG8dJFrH36BtkP7Y/bLp4Krk4Jq86zYpnCxSXQnp
o7aGmKnUsU8LnzNpCQ460HuSu8Xo3klT92fqRQh83wsT61bR/JYiWSfgKz+EFhjE
4D4JjU7/ZMZM5605uD1pSHJWtJU/ZPdYt54HvMp8WdoMPMBej5UOpfV1i++nnQbT
buExDpFNScxu5bTPjAMsGnIF+CbFx2+luhNGoUmKvJK727izN2/gJaGn7zrtPmAU
n1Khwsa4ZDHUvJ3ufRLapIQtBeqG+GJhd+BbY+R7PScEGc39lVYvF8rAzInKqB3x
6jSFN1bZBvwpVlyxFZ/eb/YHWuleyCREVmoJvwHFQkdckEqgHcziRd8lASAIUPv4
2nGYUFhPnsqt6/0pfHZsBGg/lt4SLmDiwgGlmAjJUPf00TKs1g9tIWvXL98pyum+
FRmoN4c2ZmruY1oTOaHQB0i94YVqnV2GvL46ZwagYqArSEzRm8EYMVAUaCxDpKn3
78iE+FiypSLbvY3N9drx/PsGMls8Jt56FNu3uuYqY1QlP+yaTQtJjWuigmWjrs6m
HrXxxe/JoulXgvuA8ejdvcqppi3olLsIDioXHHttXX03oFyxnFU=
=yHRp
-----END PGP SIGNATURE-----