[PATCH] gnu: fonts: Add font-meslo-lg and font-meslo-lg-dz.

  • Open
  • quality assurance status badge
Details
One participant
  • lgcoelho
Owner
unassigned
Submitted by
lgcoelho
Severity
normal
L
L
lgcoelho wrote on 24 Dec 2023 20:00
(name . Guix Patches)(address . guix-patches@gnu.org)
887af4e40f4a224bbdd6ecc1803ad2d2@disroot.org
Attachment: file
From 5bffad2dd8ea2934fe9fd880140db5684604675f Mon Sep 17 00:00:00 2001
From: Luis Guilherme Coelho <lgcoelho@disroot.org>
Date: Sun, 24 Dec 2023 15:59:01 -0300
Subject: [PATCH] gnu: fonts: Add font-meslo-lg and font-meslo-lg-dz

---
gnu/packages/fonts.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 1b2bc319f7..a1755b1ead 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -59,6 +59,7 @@
;;; Copyright © 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2023 chris <chris@bumblehead.com>
;;; Copyright © 2023 Luis Felipe López Acevedo <sirgazil@zoho.com>
+;;; Copyright © 2023 Luis Guilherme Coelho <lgcoelho@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1394,6 +1395,43 @@ (define-public font-adobe-source-serif-pro
Sans Pro family.")
(license license:silofl1.1)))
+(define-public font-meslo-lg
+ (package
+ (name "font-meslo-lg")
+ (version "1.2.1")
+ (source (origin
+ (file-name "font-meslo-lg")
+ (method url-fetch/zipbomb)
+ (uri (string-append
+ "https://github.com/andreberg/Meslo-Font/raw/master/"
+ "dist/v" version "Meslo%20LG%20v" version ".zip"))
+ (sha256
+ (base32
+ "1l08mxlzaz3i5bamnfr49s2k4k23vdm64b8nz2ha33ysimkbgg6h"))))
+ (build-system font-build-system)
+ (native-inputs (list unzip))
+ (home-page "https://github.com/andreberg/Meslo-Font")
+ (synopsis "Font for dyslexics and high readability")
+ (description
+ "Meslo LG is a customized version of Apple’s Menlo-Regular font
+(which is a customized Bitstream Vera Sans Mono).")
+ (license license:silofl1.1)))
+
+(define-public font-meslo-lg-dz
+ (package
+ (inherit font-meslo-lg)
+ (name "font-meslo-lg-dz")
+ (version (package-version font-meslo-lg))
+ (source (origin
+ (file-name "font-meslo-lg-dz")
+ (method url-fetch/zipbomb)
+ (uri (string-append
+ "https://github.com/andreberg/Meslo-Font/raw/master/"
+ "dist/v" version "Meslo%20LG%20DZ%20v" version ".zip"))
+ (sha256
+ (base32
+ "0lnbkrvcpgz9chnvix79j6fiz36wj6n46brb7b1746182rl1l875"))))))
+
(define-public font-microsoft-cascadia
(package
(name "font-microsoft-cascadia")
--
2.41.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 68013@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68013
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch