[PATCH] gnu: thinkfan: Don't fake SystemD or OpenRC presences.

  • Open
  • quality assurance status badge
Details
One participant
  • lgcoelho
Owner
unassigned
Submitted by
lgcoelho
Severity
normal
L
L
lgcoelho wrote on 24 Dec 2023 19:48
(address . guix-patches@gnu.org)
cecbf30291abd8c90e559a2dd6ef8b5c@disroot.org
This patch removes the modification to CMakeLists.txt made to fake the
presence of SystemD and OpenRC, since it doesn't provide any actual
utility for Guix, and places thinkfan.pid in a non-default place:
/run/thinkfan.pid. This patch corrects it, placing the pid file in
/var/run/, like wpa_supplicant, dhclient, syslog, tor, thermald and
other Guix Services.
Attachment: file
From 13132e9535fd390cf93556436537108b4cab3799 Mon Sep 17 00:00:00 2001
From: Luis Guilherme Coelho <lgcoelho@disroot.org>
Date: Sun, 24 Dec 2023 15:42:02 -0300
Subject: [PATCH] gnu: thinkfan: Don't fake Systemd or OpenRC presences

---
gnu/packages/linux.scm | 11 +----------
1 file changed, 1 insertion(+), 10 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 2d9e4cebbe..887a02d79f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6478,17 +6478,8 @@ (define-public thinkfan
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'create-init-scripts
- ;; CMakeLists.txt relies on build-time symptoms of OpenRC and
- ;; systemd to patch and install their service files. Fake their
- ;; presence rather than duplicating the build system below. Leave
- ;; things like ‘/bin/kill’ because they're not worth a dependency.
- ;; The sysvinit needs manual patching, but since upstream doesn't
- ;; even provide the option to install it: don't.
(lambda _
- (substitute* "CMakeLists.txt"
- (("pkg_check_modules\\((OPENRC|SYSTEMD) .*" _ package)
- (format #f "option(~a_FOUND \"Faked\" ON)\n" package))
- ;; That was easy! Now we just need to fix the destinations.
+ ;; Fix the destinations.
(("/etc" directory)
(string-append #$output directory))))))))
(native-inputs
--
2.41.0
?