Hello, Luis.
Apologies for delay.
Could you send a new patch with applied following suggestions, please?
lgcoelho@disroot.org writes:
Toggle quote (9 lines)
> This service enables a declarative configuration of zathura, the customizable
> document viewer.
>
> commit 76954ed7dc32ac86ee22566cc03cadc5f9fc1864
> Author: Luis Guilherme Coelho <lgcoelho@disroot.org>
> Date: Sun Dec 24 15:16:43 2023 -0300
>
> home: services: Add home-zathura-service-type
The commit message should look like:
Toggle snippet (6 lines)
home: services: Add zathura service.
* gnu/home/services/zathura.scm: New file.
* doc/guix.texi (SPECIFY SECTION HERE): Document this.
Toggle quote (6 lines)
> diff --git a/gnu/home/services/zathura.scm b/gnu/home/services/zathura.scm
> new file mode 100644
> index 0000000000..0695ce1614
> --- /dev/null
> +++ b/gnu/home/services/zathura.scm
Toggle quote (12 lines)
> +(define home-zathura-service-type
> + (service-type
> + (name 'zathura-service)
> + (extensions
> + (list (service-extension
> + home-xdg-configuration-files-service-type
> + zathura-xdg-configuration-file-service)))
> + (compose identity)
> + (extend home-zathura-extensions)
> + (default-value (home-zathura-configuration))
> + (description "Set ~/.config/zathura.conf")))
Description should mention that the service configures the Zathura PDF
viewer, e.g.:
Configure the Zathura PDF viewer by providing a
@file{~/.config/zathura.conf} file.
Toggle quote (3 lines)
> +(define (generate-doc)
> + (configuration->documentation 'home-zathura-configuration))
The service documentation should be added to doc/guix.texi file.
See ZNC home service as an example.
Fields documentation could be generated with:
Toggle snippet (14 lines)
~/src/git.savannah.gnu.org/git/guix$ ./pre-inst-env guix repl
GNU Guile 3.0.9
Copyright (C) 1995-2023 Free Software Foundation, Inc.
Guile comes with ABSOLUTELY NO WARRANTY; for details type `,show w'.
This program is free software, and you are welcome to redistribute it
under certain conditions; type `,show c' for details.
Enter `,help' for help.
scheme@(guix-user)> ,m(gnu home services zathura)
scheme@(gnu home services zathura)> (generate-doc)
-----BEGIN PGP SIGNATURE-----
iQJIBAEBCgAyFiEEcjhxI46s62NFSFhXFn+OpQAa+pwFAmWvunUUHGdvLndpZ3Vz
dEBnbWFpbC5jb20ACgkQFn+OpQAa+pwq2A//bAgiSpWIfwEi7+FDAj49hSp5PyxK
LKNbG5CqFQiLjs8boc4Q9684tBekP2+GmibpVBesk0c6nNtpiviOjjvV1X0sUoCU
qrv/z47X/et0ycs/K6XlspBIWopN4T1iOkDlufjfknvSatE+dInhGvViAV0YrlfQ
t315SSsqNCwvICuXpVNk9QKka8sIi7yWrflt2ixNz23cd1rU7eChoKAP/Obl0R9S
gEM6JXAYxx0NvhlFNqV4XrAD1F4aa1doIS8Tj1vLsjjkD+9wBA8x8YYrvJN5NPDI
WtmXuMt+WAJZuCCiqx140zEsanTVK/vPSefJqBOCqSqs7D2yvtEH2D3hjGsWLxOY
Dxr5P0WEMW4gUzY7ksVlwuMNehw6snMKf75NdIUhG8f3VMexgKZJxHIpLlmSD/KH
5xMuTytFcwKVXfBv1th1+1YHQW7gzbMRPMtKVegBlClWaiLSUokMdt8eRmjOCDj5
BwEvyjxsxO00xClWDOfOJMEtieF/pv7cIGnV2qxelkLaP9RSMWITEk43ZZeyjhpN
S3PYak2+yzp3u5pHdqe1o9gFvMMCleGaC+hRPrV+sP1lRv4jY1JcjUhWjvRCv1UU
WTITYwHaWhzUONxBsTLS38r3d4l/bmMU6TbspwvsUnSWK0diZlLEktKxwsJ8XGdx
xcZ06HbfvikCUJs=
=lB0Z
-----END PGP SIGNATURE-----