[PATCH] gnu: emacs-xyz: Add emacs-xref-union.

  • Done
  • quality assurance status badge
Details
One participant
  • Daniel Ziltener
Owner
unassigned
Submitted by
Daniel Ziltener
Severity
normal

Debbugs page

Daniel Ziltener wrote 1 years ago
(address . guix-patches@gnu.org)(address . dziltener@lyrion.ch)
e83812f2d9e3fd0cdebb50598ff244d3@lyrion.ch
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 77d49627fc..6776209143 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -37267,6 +37267,33 @@ (define-public emacs-xref
commands, in particular @code{find-definition}.")
(license license:gpl3+)))
+(define-public emacs-xref-union
+ (package
+ (name "emacs-xref-union")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/xref-union-" version ".tar"))
+ (sha256
+ (base32
+ "0w4gaxypl76d1jw9vcq0zhj7ksj44wyfb148l1fb0vl7h6wpv0pf"))))
+ (build-system emacs-build-system)
+ (home-page "https://elpa.gnu.org/packages/xref-union.html")
+ (synopsis "Combine multiple Xref backends")
+ (description
+ "This package provides a way to combine multiple Xref source
+(e.g. Etags and Eglot) and have the results all at once.
+
+To enable, toggle the @code{xref-union-mode} minor mode. If you want to
+exclude certain modes, take a look at the user option
+`xref-union-excluded-backends'.
+
+You can also manually make use of @code{xref-union} by adding an object
+of the form @code{(union XREF-BACKEND-1 XREF-BACKEND-2 ...)} to
+@code{xref-backend-functions}.")
+ (license license:gpl3+)))
+
(define-public emacs-burly
(package
(name "emacs-burly")
--
2.41.0
Daniel Ziltener wrote 1 years ago
[PATCH] guix: chicken-build-system: fixes to make it actually work
(address . 68517@debbugs.gnu.org)(name . GNU Debbugs)(address . control@debbugs.gnu.org)
869284fe-ed98-cb96-9e1a-263b28748c81@lyrion.ch
close 67966
thanks
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67966@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67966
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help