(address . guix-patches@gnu.org)
Fixes CVE-2023-48795.
* gnu/packages/ssh.scm (openssh): Update to 9.6p1
[arguments]<#:parallel-tests?>: Disable.
Change-Id: I8b7707894d904ec8bcccb943908fff2e69a1a027
---
This may fix additional security problem as well, but the openssh
release notes don't list them:
gnu/packages/ssh.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)
Toggle diff (33 lines)
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 47089b197d..565ac3b079 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -198,7 +198,7 @@ (define-public libssh2
(define-public openssh
(package
(name "openssh")
- (version "9.5p1")
+ (version "9.6p1")
(source
(origin
(method url-fetch)
@@ -206,11 +206,14 @@ (define-public openssh
"openssh-" version ".tar.gz"))
(patches (search-patches "openssh-trust-guix-store-directory.patch"))
(sha256
- (base32 "0sq8hqk6f0x6djgvqawjbwwxpwd8r1nzjahqfl7m9yx7kfvyf9ph"))))
+ (base32 "0z3pgam8b4z05lvdb78iv06p204qwl7b94a3cnnwba2mfb0120li"))))
(build-system gnu-build-system)
(arguments
(list
#:test-target "tests"
+ ;; Not all of the tests can be run in parallel
+ ;; https://marc.info/?l=openssh-unix-dev&m=170313565518842&w=2
+ #:parallel-tests? #f
;; Otherwise, the test scripts try to use a nonexistent directory and fail.
#:make-flags
#~(list "REGRESSTMP=\"$${BUILDDIR}/regress\"")
base-commit: aa22cdd363d3b2cf64586ccee918531aa53ef365
--
2.41.0