Daniel Ziltener wrote 1 years ago
(address . guix-patches@gnu.org)(address . dziltener@lyrion.ch)
This inherits wireplumber, and removes the dependency on elogind to make it
useful for people using seatd.
---
gnu/packages/linux.scm | 10 ++++++++++
1 file changed, 10 insertions(+)
Toggle diff (23 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3ca756dead..999b9b4363 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -9451,6 +9451,16 @@ (define-public wireplumber
tools for managing PipeWire.")
(license license:expat)))
+(define-public wireplumber-minimal
+ (package
+ (inherit wireplumber)
+ (name "wireplumber-minimal")
+ (arguments
+ `(#:configure-flags '("-Dsystemd=disabled"
+ "-Delogind=disabled"
+ "-Dsystem-lua=true")))
+ (inputs (list dbus glib lua pipewire))))
+
(define-public ell
(package
(name "ell")
--
2.41.0