[PATCH] gnu: linux: add wireplumber-minimal.

  • Done
  • quality assurance status badge
Details
2 participants
  • Daniel Ziltener
  • Hilton Chain
Owner
unassigned
Submitted by
Daniel Ziltener
Severity
normal

Debbugs page

Daniel Ziltener wrote 1 years ago
(address . guix-patches@gnu.org)(address . dziltener@lyrion.ch)
9adaf00fe27bf406396f699ececc8d93@lyrion.ch
This inherits wireplumber, and removes the dependency on elogind to make it
useful for people using seatd.
---
gnu/packages/linux.scm | 10 ++++++++++
1 file changed, 10 insertions(+)

Toggle diff (23 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3ca756dead..999b9b4363 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -9451,6 +9451,16 @@ (define-public wireplumber
tools for managing PipeWire.")
(license license:expat)))
+(define-public wireplumber-minimal
+ (package
+ (inherit wireplumber)
+ (name "wireplumber-minimal")
+ (arguments
+ `(#:configure-flags '("-Dsystemd=disabled"
+ "-Delogind=disabled"
+ "-Dsystem-lua=true")))
+ (inputs (list dbus glib lua pipewire))))
+
(define-public ell
(package
(name "ell")
--
2.41.0
Hilton Chain wrote 1 years ago
(name . Daniel Ziltener)(address . dziltener@lyrion.ch)(address . 67943-done@debbugs.gnu.org)
87v88qtiiy.wl-hako@ultrarare.space
Hi Daniel,

On Thu, 21 Dec 2023 06:40:58 +0800,
Daniel Ziltener via Guix-patches via wrote:
Toggle quote (32 lines)
>
> This inherits wireplumber, and removes the dependency on elogind to make it
> useful for people using seatd.
> ---
> gnu/packages/linux.scm | 10 ++++++++++
> 1 file changed, 10 insertions(+)
>
> diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
> index 3ca756dead..999b9b4363 100644
> --- a/gnu/packages/linux.scm
> +++ b/gnu/packages/linux.scm
> @@ -9451,6 +9451,16 @@ (define-public wireplumber
> tools for managing PipeWire.")
> (license license:expat)))
>
> +(define-public wireplumber-minimal
> + (package
> + (inherit wireplumber)
> + (name "wireplumber-minimal")
> + (arguments
> + `(#:configure-flags '("-Dsystemd=disabled"
> + "-Delogind=disabled"
> + "-Dsystem-lua=true")))
> + (inputs (list dbus glib lua pipewire))))
> +
> (define-public ell
> (package
> (name "ell")
> --
> 2.41.0


I have modified the package definition to the following:
Toggle snippet (14 lines)
(define-public wireplumber-minimal
(let ((base wireplumber))
(package
(inherit base)
(name "wireplumber-minimal")
(arguments
(substitute-keyword-arguments (package-arguments base)
((#:configure-flags flags ''())
#~(cons "-Delogind=disabled" #$flags))))
(inputs
(modify-inputs (package-inputs base)
(delete "elogind"))))))

, adjusted the commit message and applied the patch as
c3b99101982be292138f067db2cd429eeeda97fb. Thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67943@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67943
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help