[PATCH] gnu: containers: Add podman-compose.

  • Done
  • quality assurance status badge
Details
One participant
  • Daniel Ziltener
Owner
unassigned
Submitted by
Daniel Ziltener
Severity
normal
D
D
Daniel Ziltener wrote on 20 Dec 2023 17:20
(address . guix-patches@gnu.org)(address . dziltener@lyrion.ch)
6b97b41923d5000e89b44496006530a0@lyrion.ch
---
gnu/packages/containers.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index a3aa9ac1db..ccc428b3d6 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -32,6 +32,7 @@ (define-module (gnu packages containers)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system meson)
+ #:use-module (guix build-system pyproject)
#:use-module (guix utils)
#:use-module (gnu packages admin)
#:use-module (gnu packages autotools)
@@ -401,6 +402,29 @@ (define-public podman
containers.")
(license license:asl2.0)))
+(define-public podman-compose
+ (package
+ (name "podman-compose")
+ (version "1.0.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/containers/podman-compose.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "11dwpifkm20vyi6r3fgmiiqc01mpm4r8l0p5gfh0bawi2gklrhsf"))))
+ (propagated-inputs
+ (list python-pyyaml
+ python-dotenv))
+ (build-system pyproject-build-system)
+ (home-page "https://github.com/containers/podman-compose")
+ (synopsis "a script to run docker-compose.yml using podman")
+ (description "An implementation of Compose Spec with Podman backend, to
+allow you to run docker-compose.yml files with Podman.")
+ (license license:gpl2)))
+
(define-public buildah
(package
(name "buildah")
--
2.41.0
D
D
Daniel Ziltener wrote on 26 Jan 16:31 +0100
GNU Debbugs <control@debbugs.gnu.org>
(address . 67935@debbugs.gnu.org)
9bfe6f0d-3b0f-563c-402f-3e8084b13fb1@lyrion.ch
close 67935
thanks
D
D
Daniel Ziltener wrote on 14 Mar 11:52 +0100
(address . 67935@debbugs.gnu.org)
781f55d5-37c7-48c0-d068-714fa2726f83@lyrion.ch
close 67935
thanks
D
D
Daniel Ziltener wrote on 25 Mar 10:35 +0100
Re: [PATCH] gnu: containers: Add podman-compose.
(address . control@debbugs.gnu.org)
aedbcd2b-54d3-58ea-9c97-1b1bb0af833c@lyrion.ch
close 67935

thanks
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67935@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67935
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch