[PATCH] build-system/composer: Do not try to delete-duplicates.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
N
N
Nicolas Graves wrote on 19 Dec 2023 10:08
(address . guix-patches@gnu.org)
20231219090848.13042-1-ngraves@ngraves.fr
* guix/build-system/composer.scm (create-autoload):
Do not use the delete-duplicates function, stale code that should have
been removed in an earlier cleanup.

Change-Id: I778c1cfba7ef8de16a1ba297b583595b391b7e00
---
guix/build/composer-build-system.scm | 12 +++++-------
1 file changed, 5 insertions(+), 7 deletions(-)

Toggle diff (25 lines)
diff --git a/guix/build/composer-build-system.scm b/guix/build/composer-build-system.scm
index 8896384e0a..8d7d43236e 100644
--- a/guix/build/composer-build-system.scm
+++ b/guix/build/composer-build-system.scm
@@ -191,13 +191,11 @@ (define* (create-autoload vendor composer-file inputs #:key dev-dependencies?)
(cons* (string-join (string-split key #\\) "\\\\")
(append-map (lambda (v) (list vendor v)) vals)))))
(_ (format #t "")))
- (delete-duplicates
- (append
- (composer-autoload-psr-4 autoload)
- (if (and dev-dependencies? (not (null? autoload-dev)))
- (composer-autoload-psr-4 autoload-dev)
- '()))
- '()))
+ (append
+ (composer-autoload-psr-4 autoload)
+ (if (and dev-dependencies? (not (null? autoload-dev)))
+ (composer-autoload-psr-4 autoload-dev)
+ '())))
(for-each
(lambda (psr0)
(match psr0
--
2.41.0
J
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 67895@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67895
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch