herd status does not execute in virsh and macos arm64 m1 - I can press enter multiple time

  • Open
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Roman Fro?ow
Owner
unassigned
Submitted by
Roman Fro?ow
Severity
normal
R
R
Roman Fro?ow wrote on 18 Dec 2023 21:52
(address . bug-guix@gnu.org)
CAFZ1f---UqBvpJAXr5nLXqSZq3yYd-fJ-ijq_LmBbwR96MXHsQ@mail.gmail.com
I have build iso image from ubuntu vm, according to

I have used command

guix system image --system=aarch64-linux --image-type=uncompressed-iso9660
/gnu/store/dgiaqzxx743na0fd88a0mzj7f8jmcj5n-guix-29c94dd52-modules/share/guile/site/3.0/gnu/system/install.scm

virsh config is as follow:

```
<domain type='hvf' xmlns:qemu='http://libvirt.org/schemas/domain/qemu/1.0'
<name>guix</name>
<uuid>FBE8D8DF-6C65-45B3-B422-8D1E7344FC6C</uuid>
<memory unit='GiB'>2</memory>
<cpu mode='custom' match="exact">
<model>host</model>
</cpu>
<vcpu>2</vcpu>
<features>
<gic version='2'/>
</features>
<os firmware='efi'>
<type arch='aarch64' machine='virt'>hvm</type>
</os>
<clock offset='localtime'/>
<devices>
<emulator>/opt/homebrew/bin/qemu-system-aarch64</emulator>
<controller type='usb' model='qemu-xhci'/>
<disk type='file' device='disk'>
<driver name='qemu' type='qcow2'/>
<source file='/Users/roman.frolow/vms/storage/guix.qcow2'/>
<target dev='vda' bus='virtio'/>
<boot order='1'/>
</disk>
<disk type='file' device='disk'>
<driver name='qemu' type='raw'/>
<source
file='/Users/roman.frolow/personal_projects/guix/ij7xbhjgr6zsybj9qyvyzhich1c1xqzp-image.iso'/>
<target dev='vdb' bus='virtio'/>
<boot order='2'/>
</disk>
<console type='pty'>
<target type='serial'/>
</console>
<input type='tablet' bus='usb'/>
<input type='keyboard' bus='usb'/>
<graphics type='vnc' port='5901' listen='127.0.0.1'
passwd='mypass'/>
<video>
<model type='virtio' vram='32768'/>
</video>
</devices>
<seclabel type='none'/>
<qemu:commandline>
<qemu:arg value='-machine'/>
<qemu:arg value='highmem=off'/>
<qemu:arg value='-netdev'/>
<qemu:arg value='user,id=n1,hostfwd=tcp::2223-:22'/>
<qemu:arg value='-device'/>
<qemu:arg value='virtio-net-pci,netdev=n1,bus=pcie.0,addr=0x19'/>
</qemu:commandline>
</domain>
```

I have run:

```
virsh define guix.xml
virsh start guix
```

In finder I have run `cmd+k` and entered `vnc://:mypass@localhost:5901`.

I was able to install guix.

After restart I can run commands like `ls` successfully. But `herd status`
does not work. It does not execute. I can press the Enter key many times.
It just does not return to prompt.

```
% uname -a
Darwin Romans-MacBook-Pro.local 23.2.0 Darwin Kernel Version 23.2.0: Wed
Nov 15 21:53:18 PST 2023; root:xnu-10002.61.3~2/RELEASE_ARM64_T6000 arm64
```

Below is a complete log of building image.

```
$ guix system image --system=aarch64-linux
--image-type=uncompressed-iso9660
/gnu/store/dgiaqzxx743na0fd88a0mzj7f8jmcj5n-guix-29c94dd52-modules/share/guile/site/3.0/gnu/system/install.scm
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://bordeaux.guix.gnu.org'...
100.0%
14.4 MB will be downloaded
guile-3.0.9-debug 6.7MiB 3.2MiB/s 00:02 ????????????????????
100.0%
;;; compiling
/gnu/store/dgiaqzxx743na0fd88a0mzj7f8jmcj5n-guix-29c94dd52-modules/share/guile/site/3.0/gnu/system/examples/bare-bones.tmpl
;;; compiled
/home/rofrol/.cache/guile/ccache/3.0-LE-8-4.6/gnu/store/rhvgbgphv6ydw6xjmzqsz4p3cyx1isdl-guix-system-source/gnu/system/examples/bare-bones.tmpl.go
;;; compiling
/gnu/store/dgiaqzxx743na0fd88a0mzj7f8jmcj5n-guix-29c94dd52-modules/share/guile/site/3.0/gnu/system/examples/bare-bones.tmpl
;;; compiled
/home/rofrol/.cache/guile/ccache/3.0-LE-8-4.6/gnu/store/rhvgbgphv6ydw6xjmzqsz4p3cyx1isdl-guix-system-source/gnu/system/examples/bare-bones.tmpl.go
;;; compiling
/gnu/store/dgiaqzxx743na0fd88a0mzj7f8jmcj5n-guix-29c94dd52-modules/share/guile/site/3.0/gnu/system/examples/bare-bones.tmpl
;;; compiled
/home/rofrol/.cache/guile/ccache/3.0-LE-8-4.6/gnu/store/rhvgbgphv6ydw6xjmzqsz4p3cyx1isdl-guix-system-source/gnu/system/examples/bare-bones.tmpl.go
Updating channel 'guix' from Git repository at '
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://bordeaux.guix.gnu.org'...
100.0%
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://bordeaux.guix.gnu.org'...
100.0%
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://bordeaux.guix.gnu.org'...
100.0%
applying 2 grafts for libffi-3.4.4 ...
applying 2 grafts for libgc-8.2.2 ...
applying 2 grafts for libunistring-1.0 ...
applying 2 grafts for pkg-config-0.29.2 ...
applying 7 grafts for guile-3.0.9 ...
building /gnu/store/rs638pfnr9fj9kyyjz9k6763xz9sb0ix-config.scm.drv...
building /gnu/store/wja567xabnwlf4jcarddy01kyhjzr5h8-git.scm.drv...
building /gnu/store/wga3qk50ih0gl00rzzasd2js68hdmmnw-hash.scm.drv...
building /gnu/store/8njh69iy8zi9mc9cl5ayrd698lw56js0-module-import.drv...
building /gnu/store/aa1zcxrifnyn6sj7av865ak5i25vfw5l-module-import.drv...
building
/gnu/store/znf3aykiwlgyd3j4b5xas9hzpfbmk6yh-module-import-compiled.drv...
building
/gnu/store/122ryj1dwj9f61v1sapxpzm159l7d9wq-module-import-compiled.drv...
building
/gnu/store/cpvzsshhgjh05d6s9k7b8nm060z1q6bw-compute-guix-derivation.drv...
Computing Guix derivation for 'aarch64-linux'... \
Updating channel 'guix' from Git repository at '
Computing Guix derivation for 'aarch64-linux'... -
;;; compiling
/gnu/store/dgiaqzxx743na0fd88a0mzj7f8jmcj5n-guix-29c94dd52-modules/share/guile/site/3.0/gnu/system/examples/bare-bones.tmpl
;;; compiled
/home/rofrol/.cache/guile/ccache/3.0-LE-8-4.6/gnu/store/rhvgbgphv6ydw6xjmzqsz4p3cyx1isdl-guix-system-source/gnu/system/examples/bare-bones.tmpl.go
Updating channel 'guix' from Git repository at '
Computing Guix derivation for 'aarch64-linux'... |
Updating channel 'guix' from Git repository at '
Computing Guix derivation for 'aarch64-linux'... /
;;; compiling
/gnu/store/dgiaqzxx743na0fd88a0mzj7f8jmcj5n-guix-29c94dd52-modules/share/guile/site/3.0/gnu/system/examples/bare-bones.tmpl
;;; compiled
/home/rofrol/.cache/guile/ccache/3.0-LE-8-4.6/gnu/store/rhvgbgphv6ydw6xjmzqsz4p3cyx1isdl-guix-system-source/gnu/system/examples/bare-bones.tmpl.go
Updating channel 'guix' from Git repository at '
Computing Guix derivation for 'aarch64-linux'... /
Updating channel 'guix' from Git repository at '
Computing Guix derivation for 'aarch64-linux'... /
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://bordeaux.guix.gnu.org'...
100.0%
243.2 MB will be downloaded
ath9k-htc-firmware-1.4.0 39KiB 1.2MiB/s 00:00 ????????????????????
100.0%
attr-2.5.1 68KiB 1.0MiB/s 00:00 ????????????????????
100.0%
bash-5.1.16-doc 309KiB 3.2MiB/s 00:00 ????????????????????
100.0%
acl-2.3.1 130KiB 2.3MiB/s 00:00 ????????????????????
100.0%
bash-5.1.16-include 70KiB 1.8MiB/s 00:00 ????????????????????
100.0%
bdb-6.2.32 1.0MiB 5.0MiB/s 00:00 ????????????????????
100.0%
coreutils-9.1 2.4MiB 5.2MiB/s 00:00 ????????????????????
100.0%
dbus-1.14.0-doc 1.1MiB 2.8MiB/s 00:00 ????????????????????
100.0%
console-setup-1.212 1.8MiB 4.6MiB/s 00:00 ????????????????????
100.0%
coreutils-9.1-debug 6.9MiB 5.2MiB/s 00:01 ????????????????????
100.0%
dosfstools-4.2 118KiB 4.7MiB/s 00:00 ????????????????????
100.0%
duktape-2.6.0 149KiB 4.5MiB/s 00:00 ????????????????????
100.0%
e2fsprogs-1.46.4 1.1MiB 5.2MiB/s 00:00 ????????????????????
100.0%
efivar-38-0.ca48d39 118KiB 3.5MiB/s 00:00 ????????????????????
100.0%
file-5.44 322KiB 4.0MiB/s 00:00 ????????????????????
100.0%
findutils-4.9.0 457KiB 5.2MiB/s 00:00 ????????????????????
100.0%
font-gnu-unifont-15.1.01 1.7MiB 3.2MiB/s 00:01 ????????????????????
100.0%
font-gnu-unifont-15.1.01-bin 5.5MiB 5.0MiB/s 00:01 ????????????????????
100.0%
font-gnu-unifont-15.1.01-pcf 2.6MiB 4.9MiB/s 00:01 ????????????????????
100.0%
font-gnu-unifont-15.1.01-psf 18KiB 1.6MiB/s 00:00 ????????????????????
100.0%
glibc-2.33 8.8MiB 5.0MiB/s 00:02 ????????????????????
100.0%
grep-3.8 235KiB 3.2MiB/s 00:00 ????????????????????
100.0%
glibc-2.33-static 1.1MiB 5.1MiB/s 00:00 ????????????????????
100.0%
guile-fibers-1.1.1 292KiB 5.2MiB/s 00:00 ????????????????????
100.0%
glibc-2.33-debug 17.8MiB 5.1MiB/s 00:03 ????????????????????
100.0%
guile-static-stripped-3.0.9 6.7MiB 4.4MiB/s 00:01 ????????????????????
100.0%
guix-1.4.0-16.aeb4943 49.0MiB 5.1MiB/s 00:10 ????????????????????
100.0%
info-reader-6.8 737KiB 5.1MiB/s 00:00 ????????????????????
100.0%
kexec-tools-2.0.23 65KiB 4.2MiB/s 00:00 ????????????????????
100.0%
kmod-29 107KiB 5.4MiB/s 00:00 ????????????????????
100.0%
libaio-0.3.113 14KiB 3.7MiB/s 00:00 ????????????????????
100.0%
eudev-3.2.11 2.0MiB 4.9MiB/s 00:00 ????????????????????
100.0%
libcap-ng-0.8.3 46KiB 3.6MiB/s 00:00 ????????????????????
100.0%
libcbor-0.9.0 27KiB 4.7MiB/s 00:00 ????????????????????
100.0%
libedit-20191231-3.1 127KiB 4.2MiB/s 00:00 ????????????????????
100.0%
libfido2-1.12.0 211KiB 3.5MiB/s 00:00 ????????????????????
100.0%
libfontenc-1.1.4 12KiB 1.4MiB/s 00:00 ????????????????????
100.0%
libice-1.0.10 68KiB 4.0MiB/s 00:00 ????????????????????
100.0%
libidn-1.41 212KiB 4.7MiB/s 00:00 ????????????????????
100.0%
libmnl-1.0.5 19KiB 7.3MiB/s 00:00 ????????????????????
100.0%
libnl-3.5.0 494KiB 4.5MiB/s 00:00 ????????????????????
100.0%
libnftnl-1.2.3 72KiB 5.1MiB/s 00:00 ????????????????????
100.0%
libntlm-1.6 22KiB 4.0MiB/s 00:00 ????????????????????
100.0%
iptables-1.8.8 349KiB 3.5MiB/s 00:00 ????????????????????
100.0%
gsasl-2.2.0 221KiB 3.7MiB/s 00:00 ????????????????????
100.0%
iproute2-6.0.0 930KiB 4.3MiB/s 00:00 ????????????????????
100.0%
libpcap-1.10.1 167KiB 4.0MiB/s 00:00 ????????????????????
100.0%
libsigsegv-2.14 16KiB 4.2MiB/s 00:00 ????????????????????
100.0%
libsm-1.2.3 40KiB 3.7MiB/s 00:00 ????????????????????
100.0%
gawk-5.2.1 1.2MiB 4.0MiB/s 00:00 ????????????????????
100.0%
libxext-1.3.4 34KiB 6.0MiB/s 00:00 ????????????????????
100.0%
libxt-1.2.1 164KiB 3.4MiB/s 00:00 ????????????????????
100.0%
linux-libre-6.6.7 85.5MiB 3.8MiB/s 00:23 ????????????????????
100.0%
libxmu-1.1.3 65KiB 1.1MiB/s 00:00 ????????????????????
100.0%
linux-pam-1.5.2 403KiB 2.9MiB/s 00:00 ????????????????????
100.0%
lvm2-2.03.22 1.4MiB 4.5MiB/s 00:00 ????????????????????
100.0%
lz4-1.9.3 131KiB 4.7MiB/s 00:00 ????????????????????
100.0%
lzo-2.10 88KiB 4.8MiB/s 00:00 ????????????????????
100.0%
mailutils-3.16 1.5MiB 4.5MiB/s 00:00 ????????????????????
100.0%
mcron-1.2.3 456KiB 4.5MiB/s 00:00 ????????????????????
100.0%
mdadm-4.2 315KiB 4.9MiB/s 00:00 ????????????????????
100.0%
mkfontscale-1.2.2 19KiB 8.0MiB/s 00:00 ????????????????????
100.0%
mtools-4.0.42 175KiB 4.5MiB/s 00:00 ????????????????????
100.0%
mkfontdir-1.0.7 4KiB 2.3MiB/s 00:00 ????????????????????
100.0%
net-tools-1.60-0.479bb4a 214KiB 4.4MiB/s 00:00 ????????????????????
100.0%
openfwwf-firmware-5.2 11KiB 2.8MiB/s 00:00 ????????????????????
100.0%
openssh-sans-x-9.5p1 934KiB 4.8MiB/s 00:00 ????????????????????
100.0%
openvpn-2.6.7 431KiB 1.9MiB/s 00:00 ????????????????????
100.0%
parted-3.6 572KiB 4.0MiB/s 00:00 ????????????????????
100.0%
popt-1.18 56KiB 3.1MiB/s 00:00 ????????????????????
100.0%
parted-3.6-debug 1.4MiB 4.9MiB/s 00:00 ????????????????????
100.0%
efibootmgr-18 29KiB 4.4MiB/s 00:00 ????????????????????
100.0%
ppp-2.5.0 257KiB 4.8MiB/s 00:00 ????????????????????
100.0%
rottlog-0.72.2 62KiB 3.3MiB/s 00:00 ????????????????????
100.0%
sed-4.8 216KiB 3.5MiB/s 00:00 ????????????????????
100.0%
shadow-4.13 1.3MiB 5.1MiB/s 00:00 ????????????????????
100.0%
shepherd-0.10.2 420KiB 4.4MiB/s 00:00 ????????????????????
100.0%
inetutils-2.3 391KiB 5.0MiB/s 00:00 ????????????????????
100.0%
mingetty-1.08 13KiB 4.9MiB/s 00:00 ????????????????????
100.0%
isc-dhcp-4.4.3-P1 1.6MiB 5.2MiB/s 00:00 ????????????????????
100.0%
shepherd-0.9.3 307KiB 5.0MiB/s 00:00 ????????????????????
100.0%
slang-2.3.2 653KiB 5.0MiB/s 00:00 ????????????????????
100.0%
elogind-252.9 1.0MiB 5.0MiB/s 00:00 ????????????????????
100.0%
newt-0.52.21 76KiB 2.4MiB/s 00:00 ????????????????????
100.0%
polkit-121 145KiB 3.8MiB/s 00:00 ????????????????????
100.0%
guile-newt-0.0.3 129KiB 3.9MiB/s 00:00 ????????????????????
100.0%
tar-1.34 726KiB 5.1MiB/s 00:00 ????????????????????
100.0%
util-linux-2.37.4 996KiB 5.2MiB/s 00:00 ????????????????????
100.0%
which-2.21 24KiB 6.2MiB/s 00:00 ????????????????????
100.0%
fuse-2.9.9 148KiB 4.2MiB/s 00:00 ????????????????????
100.0%
vpnc-scripts-20200925.3885f8b 22KiB 4.9MiB/s 00:00 ????????????????????
100.0%
grub-hybrid-2.06 3.4MiB 3.5MiB/s 00:01 ????????????????????
100.0%
openconnect-9.12 637KiB 3.3MiB/s 00:00 ????????????????????
100.0%
vpnc-0.5.3 63KiB 3.5MiB/s 00:00 ????????????????????
100.0%
wireless-regdb-2023.05.03 6KiB 3.2MiB/s 00:00 ????????????????????
100.0%
xauth-1.1.2 21KiB 4.4MiB/s 00:00 ????????????????????
100.0%
crda-4.15 57KiB 4.1MiB/s 00:00 ????????????????????
100.0%
openssh-9.5p1 935KiB 5.3MiB/s 00:00 ????????????????????
100.0%
xl2tpd-1.3.17 55KiB 3.0MiB/s 00:00 ????????????????????
100.0%
xorriso-1.5.6.pl02 903KiB 5.2MiB/s 00:00 ????????????????????
100.0%
connman-1.42 444KiB 2.0MiB/s 00:00 ????????????????????
100.0%
xorriso-1.5.6.pl02-gui 51KiB 3.2MiB/s 00:00 ????????????????????
100.0%
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://bordeaux.guix.gnu.org'...
100.0%
29.2 MB will be downloaded
alsa-topology-conf-1.2.4 10KiB 811KiB/s 00:00 ????????????????????
100.0%
alsa-ucm-conf-1.2.4 19KiB 665KiB/s 00:00 ????????????????????
100.0%
eudev-3.2.11-static 80KiB 1.8MiB/s 00:00 ????????????????????
100.0%
alsa-lib-1.2.4 468KiB 4.4MiB/s 00:00 ????????????????????
100.0%
fribidi-1.0.12 47KiB 3.8MiB/s 00:00 ????????????????????
100.0%
graphite2-1.3.13 78KiB 2.6MiB/s 00:00 ????????????????????
100.0%
guile-parted-0.0.7 133KiB 2.8MiB/s 00:00 ????????????????????
100.0%
icu4c-71.1 10.8MiB 5.2MiB/s 00:02 ????????????????????
100.0%
libdatrie-0.2.13 41KiB 2.3MiB/s 00:00 ????????????????????
100.0%
harfbuzz-5.3.1 996KiB 4.7MiB/s 00:00 ????????????????????
100.0%
libogg-1.3.5 186KiB 5.3MiB/s 00:00 ????????????????????
100.0%
libthai-0.1.29 163KiB 3.3MiB/s 00:00 ????????????????????
100.0%
flac-1.3.4 439KiB 4.9MiB/s 00:00 ????????????????????
100.0%
libvorbis-1.3.7 289KiB 4.5MiB/s 00:00 ????????????????????
100.0%
opus-1.3.1 179KiB 4.6MiB/s 00:00 ????????????????????
100.0%
pixman-0.42.2 163KiB 4.7MiB/s 00:00 ????????????????????
100.0%
libsndfile-1.2.0 265KiB 4.8MiB/s 00:00 ????????????????????
100.0%
cairo-1.16.0 537KiB 5.0MiB/s 00:00 ????????????????????
100.0%
libsamplerate-0.1.9 957KiB 5.0MiB/s 00:00 ????????????????????
100.0%
guile-cairo-1.11.2 116KiB 759KiB/s 00:00 ????????????????????
100.0%
alsa-utils-1.2.4 986KiB 4.2MiB/s 00:00 ????????????????????
100.0%
pango-1.50.10 347KiB 2.6MiB/s 00:00 ????????????????????
100.0%
shared-mime-info-1.15 661KiB 3.2MiB/s 00:00 ????????????????????
100.0%
util-linux-2.37.4-static 382KiB 4.7MiB/s 00:00 ????????????????????
100.0%
gdk-pixbuf-2.42.8 444KiB 4.6MiB/s 00:00 ????????????????????
100.0%
wpa-supplicant-2.10 976KiB 4.9MiB/s 00:00 ????????????????????
100.0%
librsvg-2.56.4 1.7MiB 4.8MiB/s 00:00 ????????????????????
100.0%
zstd-1.5.2 411KiB 5.0MiB/s 00:00 ????????????????????
100.0%
guile-rsvg-2.18.1-0.05c6a2f 20KiB 3.1MiB/s 00:00 ????????????????????
100.0%
kbd-2.5.1 1.1MiB 4.9MiB/s 00:00 ????????????????????
100.0%
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://bordeaux.guix.gnu.org'...
100.0%
2.9 MB will be downloaded
guile-json-3.5.0 46KiB 838KiB/s 00:00 ????????????????????
100.0%
fuse-3.10.5 103KiB 1.9MiB/s 00:00 ????????????????????
100.0%
guile-netlink-1.2.1 269KiB 3.2MiB/s 00:00 ????????????????????
100.0%
procps-4.0.3 746KiB 4.1MiB/s 00:00 ????????????????????
100.0%
sudo-1.9.14p3 1.5MiB 3.4MiB/s 00:00 ????????????????????
100.0%
tzdata-2022a 121KiB 1.0MiB/s 00:00 ????????????????????
100.0%
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://bordeaux.guix.gnu.org'...
100.0%
0.1 MB will be downloaded
guile-webutils-0.1-1.d309d65 72KiB 983KiB/s 00:00 ????????????????????
100.0%
net-base-5.3 9KiB 1.7MiB/s 00:00 ????????????????????
100.0%
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://bordeaux.guix.gnu.org'...
100.0%
1.5 MB will be downloaded
e2fsck-static-1.46.4 536KiB 2.7MiB/s 00:00 ????????????????????
100.0%
ed-1.18 49KiB 3.3MiB/s 00:00 ????????????????????
100.0%
lzip-1.23 81KiB 4.4MiB/s 00:00 ????????????????????
100.0%
patch-2.7.6 92KiB 2.1MiB/s 00:00 ????????????????????
100.0%
xkeyboard-config-2.38 741KiB 4.3MiB/s 00:00 ????????????????????
100.0%
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://bordeaux.guix.gnu.org'...
100.0%
0.9 MB will be downloaded
diffutils-3.8 299KiB 2.0MiB/s 00:00 ????????????????????
100.0%
pciutils-3.8.0 393KiB 5.1MiB/s 00:00 ????????????????????
100.0%
psmisc-23.5 177KiB 4.3MiB/s 00:00 ????????????????????
100.0%
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100
This message was truncated. Download the full message here.
Attachment: file
L
L
Ludovic Courtès wrote on 20 Mar 17:32 +0100
(name . Roman Fro?ow)(address . rofrol@gmail.com)(address . 67886@debbugs.gnu.org)
877chw27b0.fsf@gnu.org
Hi Roman,

Sorry for the delay.

Roman Fro?ow <rofrol@gmail.com> skribis:

Toggle quote (3 lines)
> guix system image --system=aarch64-linux --image-type=uncompressed-iso9660
> /gnu/store/dgiaqzxx743na0fd88a0mzj7f8jmcj5n-guix-29c94dd52-modules/share/guile/site/3.0/gnu/system/install.scm

[...]

Toggle quote (6 lines)
> I was able to install guix.
>
> After restart I can run commands like `ls` successfully. But `herd status`
> does not work. It does not execute. I can press the Enter key many times.
> It just does not return to prompt.

So you mean ‘herd status’ hangs, right?

Can you tell us exactly which revision of Guix you used to build the
image and/or which version of the Shepherd it’s running? To answer the
latter question, run ‘herd --version’.

Thanks,
Ludo’.
?