[PATCH] teams: Add ‘core-packages’ team.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Ludovic Courtès
Severity
normal
L
L
Ludovic Courtès wrote on 18 Dec 2023 19:01
[PATCH] teams: Add ‘core-packages’ team.
(address . guix-patches@gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
31136a6326c09473d75801f66d4055dba68a0faf.1702922342.git.ludo@gnu.org
* etc/teams.scm (bootstrap): Add “gnu/packages/commencement.scm”.
(core-packages): New team.
(Ludovic Courtès): Add to ‘core-packages’ team.

Change-Id: I25f22d436a4dc9bf4c8f577f94cc178cbaa80768
---
etc/teams.scm | 20 ++++++++++++++++++--
1 file changed, 18 insertions(+), 2 deletions(-)

Hello Guix!

This is something we discussed last week on IRC: adding a team for
“core” packages. By that I mean: the GNU tool chain, Guile, all
the things in (gnu packages base), and probably the closure of all
this.

These are the packages we would update on ‘core-updates’, and ideally
we wouldn’t touch any other package on that branch. (So Python would
be handled on the ‘python-team’ branch, for instance.)

How does that sound?

I know of a handful of people who’d deserve to be members. :-)

Thanks,
Ludo’.

Toggle diff (49 lines)
diff --git a/etc/teams.scm b/etc/teams.scm
index 76633c2184..9cf827af29 100755
--- a/etc/teams.scm
+++ b/etc/teams.scm
@@ -310,7 +310,8 @@ (define-team go
(define-team bootstrap
(team 'bootstrap
#:name "Bootstrap"
- #:scope (list "gnu/packages/mes.scm")))
+ #:scope (list "gnu/packages/commencement.scm"
+ "gnu/packages/mes.scm")))
(define-team embedded
(team 'embedded
@@ -424,6 +425,21 @@ (define-team core
(make-regexp* "^guix/scripts/")
(make-regexp* "^guix/store/"))))
+(define-team core-packages
+ (team 'core-packages
+ #:name "Core packages"
+ #:description "Core packages: the GNU tool chain, Guile, Coreutils, etc."
+ #:scope (list "gnu/packages/base.scm"
+ "gnu/packages/bootstrap.scm"
+ "gnu/packages/commencement.scm"
+ "gnu/packages/cross-base.scm"
+ "gnu/packages/gcc.scm"
+ "gnu/packages/guile.scm"
+ "gnu/packages/make-bootstrap.scm"
+ "guix/build/gnu-build-system.scm"
+ "guix/build/utils.scm"
+ "guix/build-system/gnu.scm")))
+
(define-team games
(team 'games
#:name "Games and Toys"
@@ -554,7 +570,7 @@ (define-member (person "Jonathan Brielmaier"
(define-member (person "Ludovic Courtès"
"ludo@gnu.org")
- core home bootstrap installer mentors)
+ core home bootstrap core-packages installer mentors)
(define-member (person "Andreas Enge"
"andreas@enge.fr")

base-commit: b681e339fa37f2a26763458ee56b31af1d6a7ec5
--
2.41.0
M
M
Mathieu Othacehe wrote on 25 Dec 2023 17:43
Re: [bug#67880] [PATCH] teams: Add ‘core-packag es’ team.
(name . Ludovic Courtès)(address . ludo@gnu.org)
87mstyi67c.fsf@gnu.org
Hey Ludo,

Toggle quote (15 lines)
> +(define-team core-packages
> + (team 'core-packages
> + #:name "Core packages"
> + #:description "Core packages: the GNU tool chain, Guile, Coreutils, etc."
> + #:scope (list "gnu/packages/base.scm"
> + "gnu/packages/bootstrap.scm"
> + "gnu/packages/commencement.scm"
> + "gnu/packages/cross-base.scm"
> + "gnu/packages/gcc.scm"
> + "gnu/packages/guile.scm"
> + "gnu/packages/make-bootstrap.scm"
> + "guix/build/gnu-build-system.scm"
> + "guix/build/utils.scm"
> + "guix/build-system/gnu.scm")))

Seems nice. This has probably already been discussed, but should
core-updates be renamed core-packages here to be more inline with the
teams workflow?

Thanks,

Mathieu
L
L
Ludovic Courtès wrote on 5 Jan 12:04 +0100
(name . Mathieu Othacehe)(address . othacehe@gnu.org)
87edewf3c6.fsf@gnu.org
Hi!

Mathieu Othacehe <othacehe@gnu.org> skribis:

Toggle quote (17 lines)
>> +(define-team core-packages
>> + (team 'core-packages
>> + #:name "Core packages"
>> + #:description "Core packages: the GNU tool chain, Guile, Coreutils, etc."
>> + #:scope (list "gnu/packages/base.scm"
>> + "gnu/packages/bootstrap.scm"
>> + "gnu/packages/commencement.scm"
>> + "gnu/packages/cross-base.scm"
>> + "gnu/packages/gcc.scm"
>> + "gnu/packages/guile.scm"
>> + "gnu/packages/make-bootstrap.scm"
>> + "guix/build/gnu-build-system.scm"
>> + "guix/build/utils.scm"
>> + "guix/build-system/gnu.scm")))
>
> Seems nice.

Cool, I’m applying the patch.

Toggle quote (3 lines)
> This has probably already been discussed, but should core-updates be
> renamed core-packages here to be more inline with the teams workflow?

IMO yes, that’s the logical next step. (Maybe we can wait until the
next cycle though, dunno.)

Thanks,
Ludo’.
L
L
Ludovic Courtès wrote on 5 Jan 12:05 +0100
control message for bug #67880
(address . control@debbugs.gnu.org)
87cyugf3bo.fsf@gnu.org
close 67880
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67880@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67880
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch